8.х Не выполняется ОбработкаОповещения() в РИБ

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Flash-Dance, 7 сен 2014.

  1. TopicStarter Overlay
    Flash-Dance
    Offline

    Flash-Dance Профессионал в 1С

    Регистрация:
    20 май 2012
    Сообщения:
    365
    Симпатии:
    42
    Баллы:
    54
    Когда была одна база Розницы 2.1, все было нормально. Но после создания РИБ по магазинам в формах внешних обработок перестало обрабатываться считывание штрихкода. Я грешу на событие "ОбработкаОповещения". Причем, в РИБ по УТ 11.1 все считывается нормально.

    1С: 8.3.5.1119
    Розница: 2.1.4.9
    УТ: 11.1.7.56

    &НаКлиенте
    Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
    Если Источник = "ПодключаемоеОборудование" И ВводДоступен() Тогда
    Если ИмяСобытия = "ScanData" Тогда
    Если Параметр[ 1 ] = Неопределено Тогда
    ТекКод = Параметр[ 0 ];
    Иначе
    ТекКод = Параметр[ 1 ][ 1 ];
    КонецЕсли;
    ОбработкаВводаШтрихкода(ТекКод);
    КонецЕсли;
    КонецЕсли;
    КонецПроцедуры
  2. TopicStarter Overlay
    Flash-Dance
    Offline

    Flash-Dance Профессионал в 1С

    Регистрация:
    20 май 2012
    Сообщения:
    365
    Симпатии:
    42
    Баллы:
    54
    РЕШЕНО!
    Дело вовсе не в РИБ, а в обновленной конфигурации розницы. Нашел в описании нововведений:
    то есть необходимо добавить:
    &НаКлиенте
    Процедура ВнешнееСобытие(Источник, Событие, Данные)

    Если ВводДоступен() Тогда

    ОписаниеСобытия = Новый Структура();
    ОписаниеОшибки = "";
    ОписаниеСобытия.Вставить("Источник", Источник);
    ОписаниеСобытия.Вставить("Событие", Событие);
    ОписаниеСобытия.Вставить("Данные", Данные);

    Результат = МенеджерОборудованияКлиент.ПолучитьСобытиеОтУстройства(ОписаниеСобытия, ОписаниеОшибки);
    Если Результат = Неопределено Тогда
    ТекстСообщения = НСтр("ru = 'При обработке внешнего события от устройства произошла ошибка:'")
    + Символы.ПС + ОписаниеОшибки;
    ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстСообщения);
    Иначе
    ОбработкаОповещения(Результат.ИмяСобытия, Результат.Параметр, Результат.Источник);
    КонецЕсли;

    КонецЕсли;
    КонецПроцедуры

Поделиться этой страницей