8.х Не выгружается в Excel ?

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем cobra77777, 11 ноя 2012.

  1. TopicStarter Overlay
    cobra77777
    Offline

    cobra77777 Опытный в 1С

    Регистрация:
    20 апр 2012
    Сообщения:
    154
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте!

    На сайте посмотрел, но темы такой и не нашел. Есть такой код (см.ниже):
    При выполнения кода выдает такую ошибку:
    {Обработка.НоваяОбработка.Форма.Форма.Форма(134)}: Итератор для значения не определен
    Для Каждого Строка ИЗ Справочники.Клиент Цикл. Почему не работает :( ?


    Попытка
    Эксель = Новый COMОбъект("Excel.Application")
    Исключение
    Сообщить(ОписаниеОшибки());
    Возврат;
    КонецПопытки;

    Книга = Эксель.WorkBooks.Add();

    Лист = Книга.WorkSheets(1);
    Лист = Книга.Sheets.Add();

    НомерСтроки = 1;
    Для Каждого Строка ИЗ Справочники.Клиент Цикл
    Лист.Cells(НомерСтроки, 1).Value = Строка.Код;
    Лист.Cells(НомерСтроки, 2).Value = Строка.Наименование;
    НомерСтроки = НомерСтроки + 1;
    КонецЦикла;

    Попытка
    Книга.SaveAs = "c:\123.xls";
    Исключение
    Сообщить(ОписаниеОшибки()+" Файл не сохранен!");
    КонецПопытки;

    Эксель.Application.Quit();
  2. nbIpKuH_BaH9I
    Online

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.987
    Симпатии:
    398
    Баллы:
    104
    Попробуйте так
    Код:
    ВыборкаКлиентов= Справочники.Клиент.Выбрать();
    Пока ВыборкаКлиентов.Следующий() Цикл
    КонецЦикла;
  3. TopicStarter Overlay
    cobra77777
    Offline

    cobra77777 Опытный в 1С

    Регистрация:
    20 апр 2012
    Сообщения:
    154
    Симпатии:
    0
    Баллы:
    26
    Сделал. Пишет :


    {Обработка.НоваяОбработка.Форма.Форма.Форма(136,44)}: Переменная не определена (Строка)
    Лист.Cells(НомерСтроки, 1).Value = <<?>>Строка.Код; (Проверка: Толстый клиент (обычное приложение))
  4. nbIpKuH_BaH9I
    Online

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.987
    Симпатии:
    398
    Баллы:
    104
    Понятное дело. Вместо строка Напишите ВыборкаКлиентов.Код
  5. TopicStarter Overlay
    cobra77777
    Offline

    cobra77777 Опытный в 1С

    Регистрация:
    20 апр 2012
    Сообщения:
    154
    Симпатии:
    0
    Баллы:
    26
    Работает спасибо. Последний вопрос.Почему он при сохранении вывод сообщение :
    {Обработка.НоваяОбработка.Форма.Форма.Форма(143)}: Поле объекта не обнаружено (SaveAs) Файл не сохранен!
  6. nbIpKuH_BaH9I
    Online

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.987
    Симпатии:
    398
    Баллы:
    104
    Код:
    Книга.SaveAs(ПутьКФайлу);
    Когда же научитесь пользоваться поиском
  7. TopicStarter Overlay
    cobra77777
    Offline

    cobra77777 Опытный в 1С

    Регистрация:
    20 апр 2012
    Сообщения:
    154
    Симпатии:
    0
    Баллы:
    26
    Метод Книга.SaveAs(ПутьКФайлу); Просто не отрабатывает :

    Попытка
    Книга.SaveAs = "c:\123.xls";
    Исключение
    Сообщить(ОписаниеОшибки()+" Файл не сохранен!");
    КонецПопытки;

    Эксель.Application.Quit();
  8. nbIpKuH_BaH9I
    Online

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.987
    Симпатии:
    398
    Баллы:
    104
    У всех работает, а у вас нет. Покажите весь код, который у Вас получился в результате.
  9. TopicStarter Overlay
    cobra77777
    Offline

    cobra77777 Опытный в 1С

    Регистрация:
    20 апр 2012
    Сообщения:
    154
    Симпатии:
    0
    Баллы:
    26
    Попытка
    Эксель = Новый COMОбъект("Excel.Application")
    Исключение
    Сообщить(ОписаниеОшибки());
    Возврат;
    КонецПопытки;

    Книга = Эксель.WorkBooks.Add();

    Лист = Книга.WorkSheets(1);
    Лист = Книга.Sheets.Add();

    НомерСтроки = 1;
    ВыборкаКлиентов= Справочники.Клиенты.Выбрать();
    Пока ВыборкаКлиентов.Следующий() Цикл
    Лист.Cells(НомерСтроки, 1).Value = ВыборкаКлиентов.Код;
    Лист.Cells(НомерСтроки, 2).Value = ВыборкаКлиентов.Наименование;
    НомерСтроки = НомерСтроки + 1;
    КонецЦикла;

    Попытка
    Книга.SaveAs = "C:\123.xls";
    Исключение
    Сообщить(ОписаниеОшибки()+" Файл не сохранен!");
    КонецПопытки;

    Эксель.Application.Quit();
  10. nbIpKuH_BaH9I
    Online

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.987
    Симпатии:
    398
    Баллы:
    104
    Только что проверил. Все там работает.
    Код:
     Попытка
    Эксель = Новый COMОбъект("Excel.Application")
    Исключение
    Сообщить(ОписаниеОшибки());
    Возврат;
    КонецПопытки;
    
    Книга = Эксель.WorkBooks.Add();
    
    Лист = Книга.WorkSheets(1);
    Лист = Книга.Sheets.Add();
    
    НомерСтроки = 1;
    ВыборкаКлиентов= Справочники.уит_ДУД_Направления.Выбрать();
    Пока ВыборкаКлиентов.Следующий() Цикл
    Лист.Cells(НомерСтроки, 1).Value = ВыборкаКлиентов.Код;
    Лист.Cells(НомерСтроки, 2).Value = ВыборкаКлиентов.Наименование;
    НомерСтроки = НомерСтроки + 1;
    КонецЦикла;
    
    Попытка
    Книга.SaveAs("C:\123.xls");
    Исключение
    Сообщить(ОписаниеОшибки()+" Файл не сохранен!");
    КонецПопытки;
    
    Эксель.Application.Quit();
  11. TopicStarter Overlay
    cobra77777
    Offline

    cobra77777 Опытный в 1С

    Регистрация:
    20 апр 2012
    Сообщения:
    154
    Симпатии:
    0
    Баллы:
    26
    Из-за ОФИСА значит у меня стоит 2003. У Вас наверняка 2007 или 2010 так ?
  12. nbIpKuH_BaH9I
    Online

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.987
    Симпатии:
    398
    Баллы:
    104
    Да. 2010. Щас проверю на 2003.
  13. nbIpKuH_BaH9I
    Online

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.987
    Симпатии:
    398
    Баллы:
    104
    И 2003 все в порядке. Что-то Вы сами напутали.
  14. TopicStarter Overlay
    cobra77777
    Offline

    cobra77777 Опытный в 1С

    Регистрация:
    20 апр 2012
    Сообщения:
    154
    Симпатии:
    0
    Баллы:
    26
    А тут и путать .... не запутаешь :) . Спасибо за хелп.
  15. nbIpKuH_BaH9I
    Online

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.987
    Симпатии:
    398
    Баллы:
    104
    Да не за что...У вас все еще не работает?
  16. TopicStarter Overlay
    cobra77777
    Offline

    cobra77777 Опытный в 1С

    Регистрация:
    20 апр 2012
    Сообщения:
    154
    Симпатии:
    0
    Баллы:
    26
    Нет. Также выдает ошибку. {Обработка.НоваяОбработка.Форма.Форма.Форма(143)}: Поле объекта не обнаружено (SaveAs) Файл не сохранен!
  17. nbIpKuH_BaH9I
    Online

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.987
    Симпатии:
    398
    Баллы:
    104
    Давно бы кинул обработку свою. И скажи конфа какая?
  18. TopicStarter Overlay
    cobra77777
    Offline

    cobra77777 Опытный в 1С

    Регистрация:
    20 апр 2012
    Сообщения:
    154
    Симпатии:
    0
    Баллы:
    26
  19. nbIpKuH_BaH9I
    Online

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.987
    Симпатии:
    398
    Баллы:
    104
    Хорошо. Буду говорить прямо. Выложите сюда свою обработку и скажите версию конфигурации на которой Вы проверяете ее. Узнать можно здесь
  20. TopicStarter Overlay
    cobra77777
    Offline

    cobra77777 Опытный в 1С

    Регистрация:
    20 апр 2012
    Сообщения:
    154
    Симпатии:
    0
    Баллы:
    26

    Вложения:

    • primer.epf
      Размер файла:
      6,2 КБ
      Просмотров:
      23
    • 1.jpg
      1.jpg
      Размер файла:
      43,4 КБ
      Просмотров:
      17

Поделиться этой страницей