[РЕШЕНО] Не выгружается колонка в ТЧ

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем kittybello, 30 апр 2015.

  1. TopicStarter Overlay
    kittybello
    Offline

    kittybello Опытный в 1С

    Регистрация:
    2 апр 2015
    Сообщения:
    80
    Симпатии:
    0
    Баллы:
    26
    Добрый день, подскажите пожалуйста

    Написала такую функцию автозаполнения ТЧ:
    Запрос1;
    Запрос2;

    Затем:
    Код:
    
    Результат = Запрос2.Выполнить();
    АлиментыПериоды = Результат.Выгрузить();
    
    Таб = Новый ТаблицаЗначений;
        Таб= Запрос1.Выполнить().Выгрузить();
    
        Таб.Колонки.Добавить("УдержаноАлименты");
           
        Для каждого Строка из Таб Цикл
           
            Для НомерСтроки=0  По АлиментыПериоды.Количество()- 1 Цикл
    
                Если Строка.Период=АлиментыПериоды.Получить(НомерСтроки).Период Тогда
                   
                    Строка.УдержаноАлименты= АлиментыПериоды.Получить(НомерСтроки).УдержанияАлименты; 
                    Сообщить(Строка.УдержаноАлименты);
               
               
                ИначеЕсли  АлиментыПериоды.Получить(НомерСтроки).Период = NULL Тогда
                   
                КонецЕсли; 
            КонецЦикла;
        КонецЦикла;
       
        Доходы.Очистить();
        Доходы.Загрузить(Таб);
    
    
    Выводит все колонки, кроме Удержано Алиментов(
  2. TopicStarter Overlay
    kittybello
    Offline

    kittybello Опытный в 1С

    Регистрация:
    2 апр 2015
    Сообщения:
    80
    Симпатии:
    0
    Баллы:
    26
    все, отвечать не нужно), разобралась) Были по разному названы колонки-Hilarious-

Поделиться этой страницей