8.х Не устанавливаются автоматические значения

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Dmitry Rodnenok, 14 янв 2016.

  1. TopicStarter Overlay
    Dmitry Rodnenok
    Offline

    Dmitry Rodnenok

    Регистрация:
    14 янв 2016
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Доброго времени суток.
    Прошу помощи у профессионалов.
    Совсем нету опыта в этой сфере, но поставили следующую задачу:
    Есть внешняя обработка "загрузка и выгрузка данных"
    Необходимо, чтобы при ее запуске автоматически выставлялись след. параметры:
    -Имя файла
    -дата начала
    -дата окончания
    -данные из дерева
    Облазив десятки страниц попытался реализовать самостоятельно, но не получилось. Подскажите пожалуйста в чем ошибка.
    Вот кусок кода:
    ____________
    Процедура ПриОткрытии()
    ДатаНачала = ТекущаяДата();
    ДатаОкончания = ТекущаяДата();
    Если ПолеИмениФайла.Значение=Неопределено Тогда
    ПолеИмениФайла.Значение="Выгрузка данных XML";

    КонецЕсли;
  2. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    Попробуйте так:
    Код:
    Процедура ПриОткрытии()
    ЭтотОбъект.ДатаНачала = ТекущаяДата();
    ЭтотОбъект.ДатаОкончания = ТекущаяДата();
    Если ЭтотОбъект.ПолеИмениФайла.Значение=Неопределено Тогда
    ЭтотОбъект.ПолеИмениФайла.Значение="Выгрузка данных XML";
    КонецЕсли;
  3. TopicStarter Overlay
    Dmitry Rodnenok
    Offline

    Dmitry Rodnenok

    Регистрация:
    14 янв 2016
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Результат тот же :(
    Может быть есть другие варианты реализации?
  4. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    У вас это реквизиты формы или объекта ?
  5. TopicStarter Overlay
    Dmitry Rodnenok
    Offline

    Dmitry Rodnenok

    Регистрация:
    14 янв 2016
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Формы, насколько я понимаю)
    --- Объединение сообщений, 14 янв 2016 ---
    [​IMG]
  6. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.580
    Симпатии:
    717
    Баллы:
    204
    В таком случае еще проще:

    Процедура ПриОткрытии()
    ДатаНачала = ТекущаяДата();
    ДатаОкончания = ТекущаяДата();
    Если НЕ ЗначениеЗаполнено(ПолеИмениФайла) Тогда
    ПолеИмениФайла="Выгрузка данных.XML";
    КонецЕсли;
  7. TopicStarter Overlay
    Dmitry Rodnenok
    Offline

    Dmitry Rodnenok

    Регистрация:
    14 янв 2016
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Все равно значения не устанавливаются.
    Код:
    Процедура ПриОткрытии()
       
        ВосстановитьСписокЗначенийДляЭлементаФормы("Обработки.ВыгрузкаЗагрузкаДанныхXML.ПолеИмениФайла", ЭлементыФормы.ПолеИмениФайла.СписокВыбора);
        ВосстановитьСписокЗначенийДляЭлементаФормы("Обработки.ВыгрузкаЗагрузкаДанныхXML.ПолеИмениФайла2", ЭлементыФормы.ПолеИмениФайла2.СписокВыбора);
        ДатаНачала = ТекущаяДата();
    ДатаОкончания = ТекущаяДата();
    Если НЕ ЗначениеЗаполнено(ПолеИмениФайла) Тогда
    ПолеИмениФайла="Выгрузка данных.XML";
    КонецЕсли;
      
        Если ДеревоМетаданных.Строки.Количество() = 0 Тогда
       
            Инициализация();
           
        КонецЕсли;
       
        ДействияПриИзмененииРежимаВыгрузки();
       
        ИспользоватьФорматFastInfoSetПриИзменении(Неопределено);
       
        ДеревоМетаданных_КопияФормы = ДеревоМетаданных;
       
        ЭтаФорма.Заголовок = "Выгрузка и загрузка данных XML ("+ВерсияОбъекта()+")";
       
        ЗавершитьРаботуСистемы(Ложь);
    КонецПроцедуры
    
  8. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    Нет, это реквизиты объекта.
  9. TopicStarter Overlay
    Dmitry Rodnenok
    Offline

    Dmitry Rodnenok

    Регистрация:
    14 янв 2016
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Тогда прошу прощения, впервые столкнулся с этим :)
    До этого устанавливал только параметры запуска 1С. А поскольку знаний нету, вот и мучаюсь(
    Пытался задать реквизиту свойство "автоматическое назначение заполнения" (на сайберфоруме статья была) но ничего я так в свойствах и не нашел
  10. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.580
    Симпатии:
    717
    Баллы:
    204
    В таком случае, прочтите хотя бы азы про программирование и про программирование 1С в частности.
    Придти на работу менеджером по продажам и запрограммировать 1С в свободное на обеде время не получится.....
  11. TopicStarter Overlay
    Dmitry Rodnenok
    Offline

    Dmitry Rodnenok

    Регистрация:
    14 янв 2016
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Я не менеджер по продажам, однако спасибо за помощь.
  12. Konst82
    Offline

    Konst82 Опытный в 1С

    Регистрация:
    29 авг 2014
    Сообщения:
    56
    Симпатии:
    1
    Баллы:
    29
    ДатаНачала = ТекущаяДата();
    ДатаОкончания= ТекущаяДата();
    Если ПустаяСтрока(ПолеИмениФайла) Тогда
    ПолеИмениФайла = "C:\1C\NashFile.xml";
    КонецЕсли;

    ТОлько на вашем скриншоте не внешняя обработка

Поделиться этой страницей