8.х Не срабатывают предопределенные процедуры.

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем alp, 25 май 2010.

  1. TopicStarter Overlay
    alp
    Offline

    alp Опытный в 1С

    Регистрация:
    8 янв 2009
    Сообщения:
    432
    Симпатии:
    0
    Баллы:
    26
    Добрый день!
    Код:
    Процедура ТабличноеПолеБаноквскихСчетовПередНачаломДобавления(Элемент, Отказ, Копирование, Родитель, ЭтоГруппа)
    Если ЭтоНовый() Тогда
    Ответ = Вопрос("Для перехода к счетам необходимо записать элемент, записать?",РежимДиалогаВопрос.ДаНет);
    Если Ответ = КодВозвратаДиалога.Да Тогда
    ЭтотОбъект.Записать();
    ПриОткрытии();
    Иначе
    Отказ = Истина;
    КонецЕсли;
    КонецЕсли;
    
    КонецПроцедуры
    
    
    
    Проблема в том что после метада "Записать()"не срабатывают предопределенные процедуры на форме,
    Подскажите что я не так делаю.
  2. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    т.е. не отрабатывают процедуры и функции которые прописанные в процедурах ПередЗаписьюИ ПриЗаписи я так поня? вы там точку остановки ставили точно не попадает туда?
  3. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.410
    Симпатии:
    316
    Баллы:
    104
    Возможно глупый вопрос, но: вы процедуры эти как заводили? Просто прописывали в модуле формы? Или из диалога свойств? В любом случае проверьте, выбраны ли они там.
  4. TopicStarter Overlay
    alp
    Offline

    alp Опытный в 1С

    Регистрация:
    8 янв 2009
    Сообщения:
    432
    Симпатии:
    0
    Баллы:
    26
    Они находятся в модуле формы, когда на форме нажимаю кнопку записать они срабатывают, а через метод нет, срабатывают точно в модуле объектка , я проверял, но не в форме.

    Да
  5. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.410
    Симпатии:
    316
    Баллы:
    104
    Я так думаю, они и не должны вызываться.
    Попробуйте не Записать(), а ЗаписатьВФорме().
  6. TopicStarter Overlay
    alp
    Offline

    alp Опытный в 1С

    Регистрация:
    8 янв 2009
    Сообщения:
    432
    Симпатии:
    0
    Баллы:
    26
    вот тепер все сработало , спасибо.

Поделиться этой страницей