7.7 Не срабатывает Запрос.Группировка("...")=1

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем cplusmax, 15 мар 2012.

  1. TopicStarter Overlay
    cplusmax
    Offline

    cplusmax Опытный в 1С

    Регистрация:
    7 сен 2010
    Сообщения:
    154
    Симпатии:
    2
    Баллы:
    29
    Здравствуйте, подскажите пожалуйста почему не работает данный код:

    Код:
     Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса =
    "//{{ЗАПРОС(Сформировать)
    |с ВыбНачПериода по ВыбКонПериода;
    |Без итогов;
    |Номенклатура = Регистр.Продажи.Номенклатура;
    |Себестоимость = Регистр.Продажи.Себестоимость;
    |ПродСтоимость = Регистр.Продажи.ПродСтоимость;
    |Количество = Регистр.Продажи.Количество;
    |Менеджер = Регистр.Продажи.ТекущийДокумент.ОтчетККМ.Менеджер, Регистр.Продажи.ТекущийДокумент.Реализация.менеджер;
    |ТекущийДокумент = Регистр.Продажи.ТекущийДокумент;
    |Функция СебестоимостьСумма = Сумма(Себестоимость);
    |Функция ПродСтоимостьСумма = Сумма(ПродСтоимость);
    |Функция КоличествоСумма = Сумма(Количество);
    |Группировка Менеджер упорядочить по Менеджер.Наименование;
    |Группировка ТекущийДокумент;
    |Группировка Номенклатура без групп;
    |Условие(Номенклатура в ВыбНоменклатура);
    |"//}}ЗАПРОС
    ;
    ТекстЗапроса=ТекстЗапроса + "Условие("+?(ПустоеЗначение(ВыбМенеджер)=0, "Менеджер = ВыбМенеджер", "Менеджер<>ВыбМенеджер")+");";
    
    
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли;
    .........
    Пока Запрос.Группировка("Менеджер")=1 Цикл
    Таб.ВывестиСекцию("Менеджер");
    Пока Запрос.Группировка("ТекущийДокумент")=1 Цикл
    Таб.ВывестиСекцию("Документ");
    Пока Запрос.Группировка("Номенклатура")=1 Цикл
    Таб.ВывестиСекцию("Номенклатура");
    КонецЦикла;
    КонецЦикла;
    КонецЦикла;
    
    Так вот условие "Запрос.Группировка("Менеджер")=1" никогда не выполняется... соответственно в таблицу ничего не выводится :(

    А вот такой код отрабатывает:
    Код:
    Пока Запрос.Группировка() = 1 Цикл
    Таб.ВывестиСекцию("Сформировать");
    КонецЦикла;
    Но мне хотелось бы чтобы для разных группировок выводились свои секции...
    :blush:
  2. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    Уберите "Без итогов" из текста запроса.
  3. TopicStarter Overlay
    cplusmax
    Offline

    cplusmax Опытный в 1С

    Регистрация:
    7 сен 2010
    Сообщения:
    154
    Симпатии:
    2
    Баллы:
    29
    Большое спасибо, все получилось!

Поделиться этой страницей