8.х Не создается элемент справочника, помогите плиз...

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем xxx949, 20 сен 2012.

  1. TopicStarter Overlay
    xxx949
    Offline

    xxx949 Опытный в 1С

    Регистрация:
    29 июл 2010
    Сообщения:
    302
    Симпатии:
    1
    Баллы:
    29
    Уважаемые эксперты!

    У меня стоит задача, создал новую обработку, на нее добавил кнопку "Создать элемент справочника"
    Платформа 1С 8.2, конфигурация своя
    Пытаюсь написать обработку для загрузки данных из Excel в документ. Вот решил попробовать создание элемента на справочнике, то что полегче, и ничего не создается.

    Написал следующий код:

    Код:
    Процедура Загрузка(Команда)
    Документ = Справочники.Склады.СоздатьЭлемент();
    Документ.Наименование = "Склад А";
    Документ.Записать();
    КонецПроцедуры
    
    Но после выполнения и ошибки никакой нет, и элемент справочника не создается, ничего понять не могу, вродже все правильно, но где я ошибся.

    Спасибо за помощь :)
  2. n.s.gnedash
    Offline

    n.s.gnedash Опытный в 1С Команда форума

    Регистрация:
    15 авг 2010
    Сообщения:
    1.359
    Симпатии:
    5
    Баллы:
    29
    точку останова поставь на КонецПроцедуры и вычисли что в Документ.
  3. Dmitriy_76
    Online

    Dmitriy_76 Опытный в 1С Команда форума

    Регистрация:
    26 мар 2011
    Сообщения:
    2.175
    Симпатии:
    13
    Баллы:
    29
    все правильно должно быть...
    точно сюда попадает ? попробуй после
    Документ.Записать();

    добавить строчку
    Сообщить(Документ);
  4. Azamat
    Offline

    Azamat Опытный в 1С

    Регистрация:
    29 июл 2011
    Сообщения:
    271
    Симпатии:
    0
    Баллы:
    26
    У вас управляемое или обычное приложение?
  5. TopicStarter Overlay
    xxx949
    Offline

    xxx949 Опытный в 1С

    Регистрация:
    29 июл 2010
    Сообщения:
    302
    Симпатии:
    1
    Баллы:
    29
    Попробовал, он ничего не выдает, такое чувство, что он вообще эту процедуру не отрабатывает, где можно еще посмотреть?

    А как узнать?

    Как нистранно, но он почему-то даже на точку останова не попадает, результат тот же, как буд-то он данную процедуру просто не видит
  6. Draco
    Online

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.644
    Симпатии:
    948
    Баллы:
    204
    Правильно Вам вопрос задают У Вас обычное приложение или управляемое. И справочник Склады у Вас не подчиненый
  7. TopicStarter Overlay
    xxx949
    Offline

    xxx949 Опытный в 1С

    Регистрация:
    29 июл 2010
    Сообщения:
    302
    Симпатии:
    1
    Баллы:
    29
    Я понимаю, что вопрос верный, я и спрашиваю, как знать какое у меня приложение, обычное или управляемое? Я просто не разу с этим не сталкивался
  8. Azamat
    Offline

    Azamat Опытный в 1С

    Регистрация:
    29 июл 2011
    Сообщения:
    271
    Симпатии:
    0
    Баллы:
    26
    В свойствах конфигурации посмотрите "Основной режим запуска"
  9. TopicStarter Overlay
    xxx949
    Offline

    xxx949 Опытный в 1С

    Регистрация:
    29 июл 2010
    Сообщения:
    302
    Симпатии:
    1
    Баллы:
    29
    Стоит "Управляемое приложение" :)

    Ставлю "Обычное приложение", у меня обработка не открывается...
  10. Azamat
    Offline

    Azamat Опытный в 1С

    Регистрация:
    29 июл 2011
    Сообщения:
    271
    Симпатии:
    0
    Баллы:
    26
    Естественно не откроется форма ведь у вас управляемая.
    Вот так попробуйте:
    Код:
    &НаКлиенте
    Процедура Команда1(Команда)
    Загрузка();
    КонецПроцедуры
    
    Процедура Загрузка()
    Документ = Справочники.Склады.СоздатьЭлемент();
    Документ.Наименование = "Склад А";
    Документ.Записать();
    КонецПроцедуры
    
  11. Dmitriy_76
    Online

    Dmitriy_76 Опытный в 1С Команда форума

    Регистрация:
    26 мар 2011
    Сообщения:
    2.175
    Симпатии:
    13
    Баллы:
    29
    начнем из далека ...
    Процедура Загрузка(Команда)

    где находится ?
  12. TopicStarter Overlay
    xxx949
    Offline

    xxx949 Опытный в 1С

    Регистрация:
    29 июл 2010
    Сообщения:
    302
    Симпатии:
    1
    Баллы:
    29
    Находится в модуле внутренней обработки
  13. TopicStarter Overlay
    xxx949
    Offline

    xxx949 Опытный в 1С

    Регистрация:
    29 июл 2010
    Сообщения:
    302
    Симпатии:
    1
    Баллы:
    29
    Спасибо огромное, вот так получилось, только еще бы понять, почему все-таки так... :)
  14. Draco
    Online

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.644
    Симпатии:
    948
    Баллы:
    204
    Потому что ГЛАДИОЛУС. :)
    Если честно, то советуем почитать чем отличается управляемое от обычного и где выполняются какие операторы
  15. TopicStarter Overlay
    xxx949
    Offline

    xxx949 Опытный в 1С

    Регистрация:
    29 июл 2010
    Сообщения:
    302
    Симпатии:
    1
    Баллы:
    29
    ок, пасиба, обязательно почитаю :)

Поделиться этой страницей