7.7 Не распечатываются справки 2НДФЛ

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем alp, 29 фев 2016.

  1. TopicStarter Overlay
    alp
    Offline

    alp Опытный в 1С

    Регистрация:
    8 янв 2009
    Сообщения:
    432
    Симпатии:
    0
    Баллы:
    26
    Добрый день, программа ЗиК 353 релиз. Первый раз с таким сталкиваюсь, программа(платформа 27) не может вывести на экран результат, то есть 1с виснет на методе
    Код:
    Таб.Показать();
    Справок 500 с небольшим. Может кто сталкивался с такой проблемой ?
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Сталкивались... Так и не понял причину.... Штук по 30-40 показывает. Далее - труба
  3. TopicStarter Overlay
    alp
    Offline

    alp Опытный в 1С

    Регистрация:
    8 янв 2009
    Сообщения:
    432
    Симпатии:
    0
    Баллы:
    26
    В mxl пробовали сохранять программно ?
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    нет.. не было необходимости. Справки печатали только по требованию сотрудников.
    Реестр-то формирует нормально...
    Просто нажмите "заполнить" и сразу выгружайте...
    Кстати .. 353 для сдачи не прокатит.. Нужен 354. Да и в нем при выгрузке ошибка в схеме. Не правильно кавычки поставлены
    Последнее редактирование: 29 фев 2016
    alp нравится это.
  5. TopicStarter Overlay
    alp
    Offline

    alp Опытный в 1С

    Регистрация:
    8 янв 2009
    Сообщения:
    432
    Симпатии:
    0
    Баллы:
    26
    Проблему решил следующим образом: записал справки в формате mxl программно, далее
    через программу йоксель можно распечатать или конвертнуть в xls.
    P.S. попробовал открыть этот mxl файл в 8.2 - тоже не открывает - виснет.

    --- Объединение сообщений, 29 фев 2016 ---
    Спасибо, будем обновлять.
    Последнее редактирование модератором: 29 фев 2016
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    не за что
    в 354 заменить в глобальном модуле
    Код:
    Процедура глЗаписатьXMLФайлПФР(ИмяФайла,ХМЛФайлДанных) Экспорт
        РезФайл        =    СоздатьОбъект("AddIn.V7TextFile");
        РезФайл.ОткрытьФайл(ИмяФайла, 1);
       
       
        Данные = ХМЛФайлДанных.ВыбратьУзел("ФайлПФР");
        РезФайл.ЗаписатьСтроку("<?xml version=""1.0"" encoding=""windows-1251""?>");                   
        РезФайл.ЗаписатьСтроку("<ФайлПФР xmlns=http://schema.pfr.ru>");
        Для Сч = 1 По Данные.КоличествоПодчиненных() Цикл
            глЗаписатьУзелВФайл(РезФайл, Данные.ПолучитьПодчиненныйПоНомеру(Сч),СимволТабуляции);                                  
        КонецЦикла;
        РезФайл.ЗаписатьСтроку("</ФайлПФР>");               
        РезФайл.ЗакрытьФайл();                   
    
    КонецПроцедуры //глЗаписатьXMLФайлПФР
    
    
    на
    Код:
    Процедура глЗаписатьXMLФайлПФР(ИмяФайла,ХМЛФайлДанных) Экспорт
        РезФайл        =    СоздатьОбъект("AddIn.V7TextFile");
        РезФайл.ОткрытьФайл(ИмяФайла, 1);
       
       
        Данные = ХМЛФайлДанных.ВыбратьУзел("ФайлПФР");
        РезФайл.ЗаписатьСтроку("<?xml version=""1.0"" encoding=""windows-1251""?>");                   
        РезФайл.ЗаписатьСтроку("<ФайлПФР ""xmlns=http://schema.pfr.ru>""");
        Для Сч = 1 По Данные.КоличествоПодчиненных() Цикл
            глЗаписатьУзелВФайл(РезФайл, Данные.ПолучитьПодчиненныйПоНомеру(Сч),СимволТабуляции);                                   
        КонецЦикла;
        РезФайл.ЗаписатьСтроку("</ФайлПФР>");               
        РезФайл.ЗакрытьФайл();                   
    
    КонецПроцедуры //глЗаписатьXMLФайлПФР
    
    
  7. LordMaverick
    Online

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.443
    Симпатии:
    376
    Баллы:
    104
    а если подменить
    Код:
    Таб.Показать();
    на
    Код:
    Таб.Записать("C:\2ndfl.xls",1);
    ?

    ps
    Код:
    Записать(<?>,);
    Синтаксис:
    Записать(<ИмяФайла>,<ТипФайла>)
    Назначение:
    Записать таблицу в файл.
    Параметры:
    <ИмяФайла> - имя файла.
    <ТипФайла> - необязательный параметр. Числовое или строковое выражение, определяющее тип файла:
    · отсутствует, 0 или ''MXL'' - формат 1C;
    · 1 или ''XLS'' - формат Ms Excel;
    · 2 или ''HTM'' или ''HTML'' - формат HTML;
    · 3 или ''TXT'' - формат TXT.
    Замечание:
    Метод может использоваться при работе с таблицей в режиме ввода данных.
    
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    лучше разобраться с причиной глюка
  9. LordMaverick
    Online

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.443
    Симпатии:
    376
    Баллы:
    104
    отчёты то 7.7 под 900 000 строк и 20-30 колонок выводит на экран

    PS
    просто нет ЗиК, если только с диска демо дёрнуть
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    могу выложить если хочешь...
  11. TopicStarter Overlay
    alp
    Offline

    alp Опытный в 1С

    Регистрация:
    8 янв 2009
    Сообщения:
    432
    Симпатии:
    0
    Баллы:
    26
    Код:
    Таб.Записать("C:\2ndfl.xls",1)("")
    на сколько я помню, 1с77 не может сохранять большие таблицы в xls, по этому я сохранил сначала в MXL, а потом уже конвертировал.
  12. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Весь вопрос - ЗАЧЕМ? Это раньше требовалось печатать справки и хранить. Теперь это не обязательно.
    Но глюк в принципе интересный. За многолетнюю практику не встречал.
  13. LordMaverick
    Online

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.443
    Симпатии:
    376
    Баллы:
    104
    завтра для начала погляжу что там на диске ИСТ есть
    --- Объединение сообщений, 1 мар 2016 ---
    попутно мысля возникла, на встроенных и дискретных видеокартах одинаково?
    Последнее редактирование: 1 мар 2016
  14. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    от видюхи точно не зависит. проверял
  15. LordMaverick
    Online

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.443
    Симпатии:
    376
    Баллы:
    104
    а проблема с выводом за 2015 год? там кстати отличия в макетах для вывода

    2010, 2011 и 2013 схожи между собой, а вот макет 2015 отличается
    и плюс там в 2015 появилась область со ШК

    PS
    есть ещё замечание по макетам, чем больше на макете объединённых ячеек тем "туже" сохраняет в эксель.
    даже наличие одной такой области отрицательно сказывается на сохранении.
    где нет объединения - сохраняет быстро в эксель, даже на пару тысяч строк
    Последнее редактирование: 2 мар 2016
  16. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    да проблема появилась только в 15... Сильно подозреваю что на ШК как раз ей крышу и срывает
  17. TopicStarter Overlay
    alp
    Offline

    alp Опытный в 1С

    Регистрация:
    8 янв 2009
    Сообщения:
    432
    Симпатии:
    0
    Баллы:
    26
    Ну это надо у Кадровиков спросить :) Надо им и все.
  18. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Штук по 20-30 пробуйте - распечатает
  19. TopicStarter Overlay
    alp
    Offline

    alp Опытный в 1С

    Регистрация:
    8 янв 2009
    Сообщения:
    432
    Симпатии:
    0
    Баллы:
    26
    Да я уже решил проблему, сохранив отчет в mxl программно , а потом открыл его через Ёксель.

Поделиться этой страницей