8.х Не работает обработчик события в расширении

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Peroman, 20 фев 2017.

  1. TopicStarter Overlay
    Peroman
    Offline

    Peroman Профессионал в 1С

    Регистрация:
    26 май 2009
    Сообщения:
    1.008
    Симпатии:
    25
    Баллы:
    54
    Всем доброго времени суток.

    Платформа: 1С:Предприятие 8.3 (8.3.8.1652)
    Конфигурация: Управление торговлей, редакция 11.2 (11.2.3.189)

    Есть некое расширение. В это расширение добавляю форму документа "Перемещение товаров",
    На эту форму кидаю реквизит "ИтогиДокумента" пишу ему заголовок "Сумма документа". В модуле формы делаю:

    Код:
    &НаКлиенте
    Процедура ОприходованиеСписание_ПриОткрытии(Отказ)
       
        Сообщить("До обработчика");
        УстановитьВыполнениеПослеОбработчиковСобытия("ВыполнениеПослеТиповогоОбработчика");
        Сообщить("После обработчика");
       
    КонецПроцедуры
    
    &НаКлиенте
    Процедура ВыполнениеПослеТиповогоОбработчика(Отказ, СтандартнаяОбработка)
       
        ВыполнениеПослеТиповогоОбработчикаНаСервере();
       
    КонецПроцедуры    
    
    &НаСервере
    Процедура ВыполнениеПослеТиповогоОбработчикаНаСервере()
       
        СуммаДокумента = 0;
        Запрос = Новый  Запрос;
        Запрос.УстановитьПараметр("ТЗ",Объект.Товары.Выгрузить(,"Количество,Номенклатура"));
        Запрос.Текст =
            "ВЫБРАТЬ
            |    ТЗ.Количество,
            |    ТЗ.Номенклатура
            |ПОМЕСТИТЬ Товары
            |ИЗ
            |    &ТЗ КАК ТЗ
            |;
            |
            |////////////////////////////////////////////////////////////////////////////////
            |ВЫБРАТЬ
            |    СУММА(ЦеныНоменклатурыСрезПоследних.Цена * Товары.Количество) КАК Сумма
            |ИЗ
            |    Товары КАК Товары
            |        ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ЦеныНоменклатуры.СрезПоследних(&Дата, ) КАК ЦеныНоменклатурыСрезПоследних
            |        ПО Товары.Номенклатура = ЦеныНоменклатурыСрезПоследних.Номенклатура
            |ГДЕ
            |    ЦеныНоменклатурыСрезПоследних.ВидЦены = &ВидЦены
            |
            |СГРУППИРОВАТЬ ПО
            |    ЦеныНоменклатурыСрезПоследних.Номенклатура";
           
        Запрос.УстановитьПараметр("Дата", Объект.Дата);
        Запрос.УстановитьПараметр("ВидЦены", Объект.ВидЦены);
        РезультатЗапроса = Запрос.Выполнить().Выгрузить();
        СуммаДокумента = Формат(РезультатЗапроса.Итог("Сумма"),"ЧДЦ=2");
        ИтогиДокумента = "Сумма документа:  "+СуммаДокумента+" руб.";
       
    КонецПроцедуры
    
    Сообщить(); использую исключительно для отладки, как и заголовок реквизита формы.
    Заголовок отображается, что говорит о том, что расширение вроде бы подключилось.
    Но вот обработчики не работают.

    При чём в расширении, к которому я подключаю документ перемещения, абсолютно таким же способом сделано в других документах, ну например "списание недостач товаров" и там всё работает.
  2. bajiepka
    Offline

    bajiepka Профессионал в 1С

    Регистрация:
    26 сен 2014
    Сообщения:
    447
    Симпатии:
    30
    Баллы:
    54
    могу и ошибаться, но вызов до / после обработчиков, в т.ч. и аннотации работают начиная с 8.3.9.х

Поделиться этой страницей