8.х Не производится расчет в документе

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем osipov11789, 25 мар 2016.

  1. TopicStarter Overlay
    osipov11789
    Offline

    osipov11789

    Регистрация:
    25 мар 2016
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Добрый день! Пишет Вам Осипов Михаил Юрьевич. У меня такая проблема.
    Я создал модуль следующего содержания
    &НаКлиенте
    Процедура НаучноПедагогическиеРаботникиКоличествоЧасовОтводимыхНаНаучныеИсследованияПриИзменении(Элемент)
    СтрокаТабличнойЧасти=Элементы.НаучноПедагогическиеРаботники.ТекущиеДанные;
    ФинансированиеНауки.РассчитатьСумму(СтрокаТабличнойЧасти)

    КонецПроцедуры
    а также модуль
    Процедура РассчитатьСумму(СтрокаТабличнойЧасти)Экспорт
    ДоляЗаработнойПлатыЗаНауку=СтрокаТабличнойЧасти.ЗаработнаяПлата/СтрокаТабличнойЧасти.СуммарнаяПродолжительностьРабочегоВремени*СтрокаТабличнойЧасти.КоличествоЧасовОтводимыхНаНаучныеИсследования;
    КонецПроцедуры
    Но расчет почему то не производится, хотя модуль привязан к соотвествующим кнопкам
    Хотелось бы понять, в чем ошибка
  2. vartanet
    Offline

    vartanet Опытный в 1С Команда форума

    Регистрация:
    16 ноя 2010
    Сообщения:
    2.698
    Симпатии:
    15
    Баллы:
    29
    СтрокаТабличнойЧасти.ДоляЗаработнойПлатыЗаНауку
  3. TopicStarter Overlay
    osipov11789
    Offline

    osipov11789

    Регистрация:
    25 мар 2016
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Добавил выражение СтрокаТабличнойЧасти.ДоляЗаработнойПлатыЗаНауку в оббщий модуль. Расчет все равно не производится в чем причина?
  4. Silent_Rain
    Offline

    Silent_Rain

    Регистрация:
    21 июл 2014
    Сообщения:
    30
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте, вызовите процедуру РассчитатьСумму как функцию. Например, так:

    &НаКлиенте
    Процедура НаучноПедагогическиеРаботникиКоличествоЧасовОтводимыхНаНаучныеИсследованияПриИзменении(Элемент)
    СтрокаТабличнойЧасти=Элементы.НаучноПедагогическиеРаботники.ТекущиеДанные;
    СтрокаТабличнойЧасти.ДоляЗаработнойПлатыЗаНауку = ФинансированиеНауки.РассчитатьСумму(СтрокаТабличнойЧасти);

    КонецПроцедуры


    Функция РассчитатьСумму(СтрокаТабличнойЧасти)Экспорт
    ДоляЗаработнойПлатыЗаНауку=СтрокаТабличнойЧасти.ЗаработнаяПлата/СтрокаТабличнойЧасти.СуммарнаяПродолжительностьРабочегоВремени*СтрокаТабличнойЧасти.КоличествоЧасовОтводимыхНаНаучныеИсследования;
    Возврат ДоляЗаработнойПлатыЗаНауку;
    КонецФункции
Похожие темы
  1. zLeoNz
    Ответов:
    11
    Просмотров:
    1.060
  2. tolib85
    Ответов:
    2
    Просмотров:
    727
  3. gravis
    Ответов:
    0
    Просмотров:
    876
  4. Chloe
    Ответов:
    3
    Просмотров:
    438
  5. Cherry_amorel
    Ответов:
    5
    Просмотров:
    790
Загрузка...

Поделиться этой страницей