7.7 Не происходит отбор по кор. субконто в бух. запросе. HELP!

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем alex-79, 22 янв 2007.

  1. TopicStarter Overlay
    alex-79
    Offline

    alex-79 Опытный в 1С

    Регистрация:
    21 сен 2006
    Сообщения:
    643
    Симпатии:
    1
    Баллы:
    29
    Почему-то не происходит отбор по кор. субконто в запросе. Вроде бы всё правильно. Если кто подскажет, то буду весьма признателен.

    Вот листинг программы:

    СпрСКР = СоздатьОбъект("Справочник.СтатьиКоммерческихРасходов");

    БИ = СоздатьОбъект("БухгалтерскиеИтоги");

    БИ.ИспользоватьСубконто(ВидыСубконто.МестаХранения, СпМестаХранения, 1);
    БИ.ИспользоватьСубконто(ВидыСубконто.Номенклатура, СпТовары, 1);

    СпрСКР.ВыбратьЭлементыПоРеквизиту("Статус",1,0,0);
    Пока СпрСКР.ПолучитьЭлемент() = 1 Цикл
    БИ.ИспользоватьКорСубконто(ВидыСубконто.СтатьиКоммерческихРасходов, СпрСКР.ТекущийЭлемент(), 1);
    Прервать;
    КонецЦикла;

    //ТЗ_Б = СоздатьОбъект("ТаблицаЗначений");
    ТЗ_Б.Очистить();
    ТЗ_Б.НоваяКолонка("Пункт");
    ТЗ_Б.НоваяКолонка("Товар");
    ТЗ_Б.НоваяКолонка("Статус", "Число", 1, 0,);

    БИ.ВыполнитьЗапрос(Дата1, Дата2, "43", "44.2");
    БИ.ВыбратьСчета();
    Пока БИ.ПолучитьСчет(1) = 1 Цикл
    БИ.ВыбратьСубконто(1);
    Пока БИ.ПолучитьСубконто(1) = 1 Цикл
    БИ.ВыбратьСубконто(2);
    Пока БИ.ПолучитьСубконто(2) = 1 Цикл
    БИ.ВыбратьКорСчета();
    Пока БИ.ПолучитьКорСчет(1) = 1 Цикл
    БИ.ВыбратьКорСубконто(1);
    Пока БИ.ПолучитьКорСубконто(1) = 1 Цикл
    Сообщить("ывфаывафыва");
    ТЗ_Б.НоваяСтрока();
    ТЗ_Б.Пункт = БИ.Субконто(1);
    //ТЗ_Б.Товар = БИ.Субконто(2);
    ТЗ_Б.Статус = 1;
    КонецЦикла;
    КонецЦикла;
    КонецЦикла;
    КонецЦикла;
    КонецЦикла;

    :unsure:
  2. Amishechka
    Offline

    Amishechka Опытный в 1С

    Регистрация:
    8 сен 2006
    Сообщения:
    361
    Симпатии:
    1
    Баллы:
    26
    Рано вешаться :)
    Повторюсь
    БИ.ВыполнитьЗапрос(Дата1, Дата2, "43", "44.2",,3);

Поделиться этой страницей