7.7 Не правильно записывается результат в журнале расчетов по Районному коэффициенту и северной надбавке

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем mercury99, 5 дек 2011.

  1. TopicStarter Overlay
    mercury99
    Offline

    mercury99

    Регистрация:
    5 дек 2011
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Помогите пожалуйста у меня возникла такая проблема:
    В журнале расчета есть запись стимулирующая надбавка с отрицательной суммой период действия в которой август месяц (текущий период ноябрь). При расчете записи перерасчета районный коэффициента за тот период в отладчике результат равен -1500, а в журнал расчетов приходит совершенно другая сумма -34111.34 в чем может быть причина?
    Модуль расчета:
    Код:
    глСообщениеТрассировки(глСообщенияТрассировки, "" + ?(Исправлена=1,"Результат записи исправлен вручную","Запись фиксирована") + ". Расчет не проводился.", , 1);
    Возврат
    КонецЕсли;       
    Дни=0;
    Часы=0;
    Результат=0;
    ЖР=СоздатьОбъект ("ЖурналРасчетов.Зарплата");                
    База=0;
    Если ДатаНачала=ТекущийПериод().ДатаНачала Тогда
    ЖР.ВыбратьПериодПоОбъекту (Объект, ДатаНачала);
    Пока ЖР.ПолучитьЗапись ()=1 Цикл  
    если   ЖР.РодительскийДокумент .вид() = "Исправление"    Тогда   
    Продолжить;
    КонецЕсли;
    
    если   (ДатаНачала<=ЖР.ПериодДействия.ДатаНачала) и ЖР.ПериодДействия.ДатаОкончания<=ДатаОкончания)   Тогда     
    Если глВходитВБазу (ЖР.ВидРасч,ВидРасч)=1 Тогда
    База=База+ЖР.Результат;
    КонецЕсли;
    КонецЕсли;
    
    КонецЦикла;
    КонецЕсли;	
    
    Если ДатаНачала<>ТекущийПериод().ДатаНачала Тогда
    База=0;
    ЖР1=СоздатьОбъект ("ЖурналРасчетов.Зарплата");                	
    ЖР1.ВыбратьПериодПоОбъекту(Объект, ТекущийПериод().ДатаНачала);
    Пока ЖР1.ПолучитьЗапись ()=1 Цикл  
    
    если   ЖР1.РодительскийДокумент .вид() = "Исправление"    Тогда  
    Продолжить;
    КонецЕсли;
    
    если   
    (ДатаНачала<=ЖР1.ПериодДействия.ДатаНачала) и 
    (ЖР1.ПериодДействия.ДатаОкончания<=ДатаОкончания)
    Тогда     
    Если глВходитВБазу (ЖР1.ВидРасч,ВидРасч)=1 Тогда
    База=База+ЖР1.Результат;	
    КонецЕсли;	
    КонецЕсли;
    
    КонецЦикла;
    КонецЕсли;
    
    Коэффициент=Макс (Константа.РайонныйКоэффициент-1,0);
    Результат = Окр (База*Коэффициент,2);
    
    Если Результат<>0 Тогда
    Дни=Коэффициент*100;     
    КонецЕсли;
    
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Базу ВР не меняли?
  3. TopicStarter Overlay
    mercury99
    Offline

    mercury99

    Регистрация:
    5 дек 2011
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Нет

Поделиться этой страницей