8.х Не получается списывать товар с ОБЩЕГО списка :(

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем cobra77777, 1 мар 2013.

  1. TopicStarter Overlay
    cobra77777
    Offline

    cobra77777 Опытный в 1С

    Регистрация:
    20 апр 2012
    Сообщения:
    154
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте!
    Есть Документ ПоступлениеТовараКартриджи, и человек который принимает этот товар из Основного Склада. Соответственного завхоз принял товар (картриджи). Кроме завхоза могут еще 2 человека этот товар списывать. Вот код:
    Процедура ОбработкаПроведения(Отказ, Режим)
    //{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!


    // регистр УчетКартриджей Приход
    Движения.УчетКартриджей.Записывать = Истина;
    Для Каждого ТекСтрокаМатериал Из Материал Цикл
    Движение = Движения.УчетКартриджей.Добавить();
    Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
    Движение.Период = Дата;
    Движение.Склад = Склад;
    Движение.Картридж = ТекСтрокаМатериал.Картридж;
    Движение.Количество = ТекСтрокаМатериал.Количество;
    КонецЦикла;


    // регистр УчетКартриджейПоСотрудникам Приход
    Движения.УчетКартриджейПоСотрудникам.Записывать = Истина;
    Для Каждого ТекСтрокаМатериал Из Материал Цикл
    Движение = Движения.УчетКартриджейПоСотрудникам.Добавить();
    Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
    Движение.Период = Дата;
    Движение.Сотрудник = СотрудникАвтоматизации;
    Движение.Картридж = ТекСтрокаМатериал.Картридж;
    Движение.Количество = ТекСтрокаМатериал.Количество;
    Движение.СотрудникОтдела = СотрудникОтдела;
    КонецЦикла;


    //}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
    КонецПроцедуры


    Вопрос: На примере (код выше) завхоз с ОБЩЕГО списка списывает картриджи, а другие сотрудники не могут списывать с ОБЩЕГО Списка (списывается только единично). Как сделать так чтобы др.сотрудники тоже могли списывать с ОБЩЕГО Списка ?
  2. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.978
    Симпатии:
    397
    Баллы:
    104
    Что такое общий список?
  3. TopicStarter Overlay
    cobra77777
    Offline

    cobra77777 Опытный в 1С

    Регистрация:
    20 апр 2012
    Сообщения:
    154
    Симпатии:
    0
    Баллы:
    26
    Общий список я имею ввиду Полученный товар.

    Наименование Кол-во
    HP 1200 1
    HP 1300 5
    HP 1320 3
  4. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.978
    Симпатии:
    397
    Баллы:
    104
    Судя по вашему коду у Вас товар приходуется.
  5. TopicStarter Overlay
    cobra77777
    Offline

    cobra77777 Опытный в 1С

    Регистрация:
    20 апр 2012
    Сообщения:
    154
    Симпатии:
    0
    Баллы:
    26
    i'm sorry


    Процедура ОбработкаПроведения(Отказ, Режим)
    //{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

    // регистр УчетКартриджей Расход
    Движения.УчетКартриджей.Записывать = Истина;
    Движение = Движения.УчетКартриджей.Добавить();
    Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
    Движение.Период = Дата;
    Движение.Склад = Склад;
    Движение.Картридж = Картридж;
    Движение.Количество = 1;

    // регистр УчетКартриджейПоСотрудникам Расход
    Движения.УчетКартриджейПоСотрудникам.Записывать = Истина;
    Движение = Движения.УчетКартриджейПоСотрудникам.Добавить();
    Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
    Движение.Период = Дата;
    Движение.Сотрудник = Сотрудникавтоматизации;
    Движение.Картридж = Картридж;
    Движение.Количество = 1;
    Движение.СотрудникОтдела = СотрудникОтдела;

    //}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
    КонецПроцедуры
  6. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.978
    Симпатии:
    397
    Баллы:
    104
    Если честно, то не понятна суть проблемы. Почему сотрудники не могут списывать товар? Ошибка или что вообще? Яснее пожалуйста опишите задачу.

Поделиться этой страницей