8.х Не получается сделать запись в регистр сведений

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем shurikvz, 28 мар 2010.

  1. TopicStarter Overlay
    shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    Доброго дня.

    Вот моя процедура:
    Код:
    Процедура Кнопка3Нажатие(Элемент)
    СвойствоНомер = ПланыВидовХарактеристик.СвойстваОбъектов.НайтиПоНаименованию("Номер входящего документа");
    МЗ = РегистрыСведений.ЗначенияСвойствОбъектов.СоздатьМенеджерЗаписи();
    
    Выборка = Документы.ВозвратТоваровОтПокупателя.Выбрать();
    Пока Выборка.Следующий() Цикл
    ОбработкаПрерыванияПользователя();
    Объект = Выборка.ПолучитьОбъект();
    Сообщить("Обработка: " + Строка(Объект));
    Если НЕ СвойствоНомер.Пустая() Тогда
    Значение = СокрЛП(Объект.НомерВходящегоДокумента);
    Если НЕ ПустаяСтрока(Значение) Тогда
    МЗ.Объект = Объект;       
    МЗ.Свойство = СвойствоНомер;
    МЗ.Значение = Значение;
    МЗ.Записать();
    КонецЕсли;
    КонецЕсли;
    КонецЦикла;
    
    Сообщить("Завершено.");
    КонецПроцедуры
    
    
    Получаю ошибку:
    ---
    {Форма.Форма.Форма(135)}: Ошибка при вызове метода контекста (Записать): Запись не верна! Значение поля "Объект" не может быть пустым!: ЗначенияСвойствОбъектов: , Номер входящего документа (Регистр сведений: Значения свойств объектов)
    МЗ.Записать();
    по причине:
    Запись не верна! Значение поля "Объект" не может быть пустым!: ЗначенияСвойствОбъектов: , Номер входящего документа (Регистр сведений: Значения свойств объектов)
    ---

    Указанный регистр сведений (типовой конфигурация Комплексная автоматизация) имеет 2 измерения (Объект и Свойство) ну и 1 ресурс (Значение).

    Свойство "Номер входящего документа" заведено у меня в базе с назначением "Документ возврат товаров от покупателя", тип строка-15.

    что я делаю не так?
  2. gosn1ck
    Offline

    gosn1ck Опытный в 1С

    Регистрация:
    13 авг 2009
    Сообщения:
    1.329
    Симпатии:
    1
    Баллы:
    26
    вероятно у вас путаница с типами данных.
    МЗ.Объект скорее всего туда надо записать ссылку, а в МЗ.Значение наверняка число, а не строку
  3. TopicStarter Overlay
    shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    Все. Разобрался.

    Вместо
    Код:
    МЗ.Объект = Объект;
    
    Надо
    Код:
    МЗ.Объект = Объект.Ссылка;
    
  4. gosn1ck
    Offline

    gosn1ck Опытный в 1С

    Регистрация:
    13 авг 2009
    Сообщения:
    1.329
    Симпатии:
    1
    Баллы:
    26
    а зачем вы получаете объект? думаю ссылки (Выборка) будет достаточно, вы ведь не изменяете его (объект)
  5. TopicStarter Overlay
    shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    Да, согласен. Спасибо.

    P.S. Обработка "на один раз" поэтому особо не вылизываю. А так, да.

Поделиться этой страницей