8.х Не пишет значения в РН

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Persempre, 14 мар 2014.

  1. TopicStarter Overlay
    Persempre
    Offline

    Persempre Опытный в 1С

    Регистрация:
    18 июл 2012
    Сообщения:
    851
    Симпатии:
    3
    Баллы:
    29
    Добрый день Уважаемые знатоки. Столкнулся с проблемой которая озадачила.
    При проведении документа (Начисление арендной платы пайщикам) (упп) в модуле объекта есть обработчики которые делают движения.

    Код:
        //НДФЛ Сведения о доходах
                    Движение = Движения.НДФЛСведенияОДоходах.Добавить();
                    Движение.Период = КонецМесяца(ДатаВыплатыДохода);
                    Движение.ПериодРегистрации = НачалоМесяца(МесяцНачисления);
                    Движение.Организация = Организация;
                    Движение.ОбособленноеПодразделение = Организация;
                    Движение.ФизЛицо = ТекСтрокаНДФЛ.ФизЛицо;
                    Движение.КодДохода = НДФЛКодДоходаАренда;
                    Движение.КодВычета = НдфлКодВычета;
                    Если ЗначениеЗаполнено(НдфлКодВычета) Тогда
                        Движение.СуммаВычета = текСтрокаНдфл.Сумма;
                    КонецЕсли;
                    Движение.СуммаДохода = ТекСтрокаНДФЛ.Сумма;
                    //Движение.ПодразделениеОрганизации = ТекСтрокаНДФЛ.ДоговорОПае.ПодразделениеОрганизации;
                    Если ЗначениеЗаполнено(ПодразделениеОрганизации) Тогда
                        Движение.ПодразделениеОрганизации = ПодразделениеОрганизации;
                    Иначе
                        Движение.ПодразделениеОрганизации = ТекСтрокаНДФЛ.ДоговорОПае.ПодразделениеОрганизации;  
                    КонецЕсли;
                    Движение.ПодразделениеОрганизации = ПодразделениеОрганизации;
    
                    Движение.ДатаПолученияДохода = ДатаВыплатыДохода;
                  
                    Если ТекСтрокаНДФЛ.НДФЛ <> 0 Тогда
                        хДвижение = Движения.НДФЛРасчетыСБюджетом.Добавить();
                      
                        // Свойства
                        хДвижение.Период                         = КонецМесяца(МесяцНачисления);
                        хДвижение.ВидДвижения                    = ВидДвиженияНакопления.Приход;
    
                        // Измерения
                        хДвижение.ФизЛицо                        = ТекСтрокаНДФЛ.ФизЛицо;
                        хДвижение.Организация                    = Организация;
                        хДвижение.МесяцНалоговогоПериода         = НачалоМесяца(МесяцНачисления);
                        хДвижение.СтавкаНалогообложенияРезидента = Перечисления.НДФЛСтавкиНалогообложенияРезидента.Ставка13;
    
                        // Ресурсы
                        хДвижение.Налог                          = ТекСтрокаНДФЛ.НДФЛ;
                      
                        // Реквизиты
                        хДвижение.ОбособленноеПодразделение      = Организация;
                        хДвижение.ПодразделениеОрганизации       = ТекСтрокаНДФЛ.ДоговорОПае.ПодразделениеОрганизации;
                        хДвижение.ВидСтроки                      = Перечисления.НДФЛРасчетыСБюджетомВидСтроки.Начисление;
                        хДвижение.ИсчисленоИзЗарплаты            = Ложь;
                        хДвижение.КодДохода                      = НДФЛКодДоходаАренда;
    

    интересует строка Движение.ПодразделениеОрганизации = ПодразделениеОрганизации; - при проведении документа и просмотра самого регистра значения этого нет почему-то.... не понимаю почему... может что делаю не так?

    PS в отладчике когда смотрю пошагово - все значения добаляет, но при проведении документа - значение ПодразделениеОрганизации - пустое. т.е. не записанное
    Последнее редактирование: 14 мар 2014
  2. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.977
    Симпатии:
    397
    Баллы:
    104
    Пройдитесь отладчиком до самого конца. И смотрите на строку Движения.НДФЛСведенияОДоходах.ПодразделениеОрганизации. И смотрите на каком этапе оно заполняется или не заполняется вообще...
  3. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    интересный код
    Код:
    Если ЗначениеЗаполнено(ПодразделениеОрганизации) Тогда
                        Движение.ПодразделениеОрганизации = ПодразделениеОрганизации;
                    Иначе
                        Движение.ПодразделениеОрганизации = ТекСтрокаНДФЛ.ДоговорОПае.ПодразделениеОрганизации; 
                    КонецЕсли;
                    Движение.ПодразделениеОрганизации = ПодразделениеОрганизации;//вот тут
    зачем тогда условие Заполнение значения проверять, если потом все равно присвоение прямое идет?

Поделиться этой страницей