8.х РОЗ НЕ ПЕЧАТАЕТ ЧЕК С СН ЕНВД РОЗНИЦА 2.2

Тема в разделе ""1С:Розница"", создана пользователем Demonxp, 5 июн 2019.

  1. TopicStarter Overlay
    Demonxp
    Offline

    Demonxp

    Регистрация:
    5 мар 2017
    Сообщения:
    2
    Симпатии:
    2
    Баллы:
    1
    Как я решил проблему
    [​IMG]
    Открываем в режиме "Реконфигурация"
    Общиймодуль.ПодключаемоеОборудованиеРК или (РТ)
    Открываем
    Ишим
    Функция ПолучитьСистемуНалогообложенияККТ
    Код:
    Функция ПолучитьСистемуНалогообложенияККТ(Организация, ВидНалога, ДатаДокумента = Неопределено) Экспорт
      
        Если НЕ ЗначениеЗаполнено(ДатаДокумента) Тогда
            ДатаДокумента = ТекущаяДатаСеанса();
        КонецЕсли;
      
        Если ВидНалога = Перечисления.ВидыНалогов.Общая Тогда
            Возврат Перечисления.ТипыСистемНалогообложенияККТ.ОСН;
        ИначеЕсли ВидНалога = Перечисления.ВидыНалогов.Упрощенная_Доход Тогда
            Возврат Перечисления.ТипыСистемНалогообложенияККТ.УСНДоход;
        ИначеЕсли ВидНалога = Перечисления.ВидыНалогов.Упрощенная_ДоходРасход Тогда
            Возврат Перечисления.ТипыСистемНалогообложенияККТ.УСНДоходРасход;
        ИначеЕсли ВидНалога = Перечисления.ВидыНалогов.ЕНВД Тогда
            Возврат Перечисления.ТипыСистемНалогообложенияККТ.ЕНВД;
        ИначеЕсли ВидНалога = Перечисления.ВидыНалогов.ЕСХН Тогда
            Возврат Перечисления.ТипыСистемНалогообложенияККТ.ЕСН;
        ИначеЕсли ВидНалога = Перечисления.ВидыНалогов.ПСН Тогда
            Возврат Перечисления.ТипыСистемНалогообложенияККТ.Патент;
        КонецЕсли;[/color]
      
        Запрос = Новый Запрос;
        Запрос.Текст = "ВЫБРАТЬ
        |    СистемыНалогообложенияОрганизацийСрезПоследних.СистемаНалогообложения,
        |    СистемыНалогообложенияОрганизацийСрезПоследних.ОбъектНалогообложения
        |ИЗ
        |    РегистрСведений.СистемыНалогообложенияОрганизаций.СрезПоследних(&ДатаДокумента, Организация = &Организация) КАК СистемыНалогообложенияОрганизацийСрезПоследних";
      
        Запрос.УстановитьПараметр("ДатаДокумента", ДатаДокумента);
        Запрос.УстановитьПараметр("Организация"  , Организация);
      
        Результат = Запрос.Выполнить();
        Выборка = Результат.Выбрать();
      
        Если Выборка.Следующий() Тогда
            Если Выборка.СистемаНалогообложения = Перечисления.СистемыНалогообложения.Общая Тогда
                Возврат Перечисления.ТипыСистемНалогообложенияККТ.ОСН;
            ИначеЕсли Выборка.СистемаНалогообложения = Перечисления.СистемыНалогообложения.ЕНВД Тогда
                Возврат Перечисления.ТипыСистемНалогообложенияККТ.ЕНВД;
            ИначеЕсли Выборка.СистемаНалогообложения = Перечисления.СистемыНалогообложения.ЕСН Тогда
                Возврат Перечисления.ТипыСистемНалогообложенияККТ.ЕСН;
            ИначеЕсли Выборка.СистемаНалогообложения = Перечисления.СистемыНалогообложения.Патент Тогда
                Возврат Перечисления.ТипыСистемНалогообложенияККТ.Патент;
            ИначеЕсли Выборка.ОбъектНалогообложения = Перечисления.ОбъектыНалогообложенияПоУСН.Доходы Тогда
                Возврат Перечисления.ТипыСистемНалогообложенияККТ.УСНДоход;
            Иначе
                Возврат Перечисления.ТипыСистемНалогообложенияККТ.УСНДоходРасход
            КонецЕсли;
        Иначе
            Возврат Перечисления.ТипыСистемНалогообложенияККТ.ОСН;
        КонецЕсли;
          
    КонецФункции
    
    Прописываем.
    Открываем
    Перечисления.ВидыНалогов(Добавляем)
    Открываем
    Перечисления.СистемыНалогообложения(Добавляем)
    Открываем
    Регистры сведения.СистемыНалогообложенияОрганизаций
    ФормаЗаписи
    [​IMG]
    Добавляем
    Итог
    [​IMG]
    Последнее редактирование: 5 июн 2019
    nsk1C и Rad&K нравится это.
  2. Rad&K
    Offline

    Rad&K Профессионал в 1С

    Регистрация:
    3 авг 2015
    Сообщения:
    1.511
    Симпатии:
    144
    Баллы:
    104
    Судя по всему, топикстартер проделал немалую работу.. Правда не указал точную версию РТ 2.2 и торговое оборудование.
    Спасибо, конечно, и за подробное пошаговое описание действий, что не часто встретишь. За это - лайк. :)
    Однако, может быть только мне, не понятно к чему всё описанное нужно делать? o_O
    Я начал знакомство с РТ начиная уже с версии 2.1, но ещё с релиза 2.0.1 было уже, цитирую:
    Код:
    В конфигурации "Розница" (редакция 2.0) поддерживаются общая и упрощенная системы налогообложения организаций автоматизируемого предприятия. В программе можно также вести учет на складах магазинов, которые переведены на единый налог на вмененный доход (ЕНВД).
    Релиз 2.0.2:
    Код:
    Для организаций поддерживаются Общая и Упрощенная система налогобложения. Применение ЕНВД для учета розничной торговли можно указать с детализацией до складов магазинов.
    и т.д.
    ...
    Релиз 2.2.12 от 31.05.2019:
    Код:
    Изменён механизм определения системы налогообложения (СНО).
    Система налогообложения и соответствующие СНО ставки НДС определяются в зависимости от Организации, Магазина, Склада по настройкам, произведенным пользователем в регистре "Применение систем налогообложения". Регистр доступен из соответствующих элементов справочников. Система налогообложения определяются автоматически в документах:
         Возврат товаров от покупателя,
         Операция по платежной карте,
         Приходный кассовый ордер,
         Расходный кассовый ордер,
         Реализация товаров,
         Регистрация безналичной оплаты.
    В документе "Чек ККМ" в режиме менеджера и в РМК предоставлена дополнительная возможность автоматического определения системы налогообложения по товарной группе. 
    В чём собственно была проблема у автора темы?
    nsk1C нравится это.