7.7 не печатает ценник

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем anton, 3 авг 2009.

  1. TopicStarter Overlay
    anton
    Offline

    anton Опытный в 1С

    Регистрация:
    3 авг 2009
    Сообщения:
    187
    Симпатии:
    0
    Баллы:
    26
    помогите пожалуйста, не могу разобраться стоит Штрих- ресторан бэк офис v4
    Ситуация такя выхажу на печать ценника делую подбор вывожу на печать форма ценников открывается но цена не подстовляется и выдает ошибку

    Поле агрегатного объекта не обнаружено (ВходНомерДок)
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    В модуле обратоки ошибка. Такой конфы нет к сожалению. Выложи ОТДЕЛЬНО саму обаботку печати ценника - подправлю.
  3. TopicStarter Overlay
    anton
    Offline

    anton Опытный в 1С

    Регистрация:
    3 авг 2009
    Сообщения:
    187
    Симпатии:
    0
    Баллы:
    26
    Приблизительно это выглядит так!!!

    Код:
    Процедура Печать()  
    Перем ПечЦенники;
    Перем ТекТипЦенника;
    
    Таб=СоздатьОбъект("Таблица");
    ПечЦенники=СоздатьОбъект("ТаблицаЗначений");
    Ценники.Выгрузить(ПечЦенники);            
    Сч=1;
    Пока Сч<=ПечЦенники.КоличествоСтрок() Цикл
    Если ПечЦенники.ПолучитьЗначение(Сч,"Пометка")=4 Тогда 
    //Эту строку не печатаем
    ПечЦенники.УдалитьСтроку(Сч);
    Иначе
    Сч=Сч+1;
    КонецЕсли;
    КонецЦикла;
    //Теперь у нас только ценники для печати
    //Отсортируем их по типу ценника
    Если ПечЦенники.КоличествоСтрок()=0 Тогда
    Предупреждение("Не выбран ни один товар для печати ценников!",15);
    Возврат;
    КонецЕсли;	
    ПечЦенники.Сортировать("+КодЦенника");
    ПечЦенники.ВыбратьСтроки();
    ПечЦенники.ПолучитьСтроку();
    ТекТипЦенника=ПечЦенники.ТипЦенника;
    ТекМаксСтрок=ТекТипЦенника.КолвоСтрок;
    ТекМаксСтолбцов=ТекТипЦенника.КолвоСтолбцов;
    ФайлЦенника=СокрЛП(ТекТипценника.ПутьКЦеннику);
    Если ФС.СуществуетФайл(ФайлЦенника)>0 Тогда
    Таб.ИсходнаяТаблица(ФайлЦенника);
    Иначе
    Таб.ИсходнаяТаблица("Ценник");
    ТекМаксСтрок=5;
    ТекМаксСтолбцов=5;
    КонецЕсли;
    ВывелиСтрок=0;
    ВывелиСтолбцов=0;
    ПечЦенники.ВыбратьСтроки();
    ВывелиТаблицу=0;
    Пока ПечЦенники.ПолучитьСтроку()=1 Цикл
    ВывелиТаблицу=1;
    //Тут надо смотреть, какой тип у полученного ценника
    Если ПечЦенники.ТипЦенника<>ТекТипценника Тогда
    //Покажем сформированную таблицу и создадим новую
    Таб.ТолькоПросмотр(0);
    Таб.Показать("Печать ценников","");
    
    //Начнем работать с новым ценником
    Таб=СоздатьОбъект("Таблица");
    ТекТипЦенника=ПечЦенники.ТипЦенника;
    ТекМаксСтрок=ТекТипЦенника.КолвоСтрок;
    ТекМаксСтолбцов=ТекТипЦенника.КолвоСтолбцов;
    ФайлЦенника=СокрЛП(ТекТипценника.ПутьКЦеннику);
    Если ФС.СуществуетФайл(ФайлЦенника)>0 Тогда
    Таб.ИсходнаяТаблица(ФайлЦенника);
    Иначе
    Таб.ИсходнаяТаблица("Ценник");
    ТекМаксСтрок=5;
    ТекМаксСтолбцов=5;
    КонецЕсли;
    ВывелиСтрок=0;
    ВывелиСтолбцов=0;
    Товар=ПечЦенники.Товар;
    РознЦена=ПечЦенники.Цена;
    ГоденДо=ПечЦенники.ГоденДо;   
    КодСтр=Товар.Код;
    ШтрихКод=Товар.ШтрихКод;
    СтранаПроисхождения=Товар.СтранаИзготовитель;
    //Надо вывести первый ценник и поностю его прогнать
    Для Поз=1 По ПечЦенники.Количество Цикл
    //ВывелиСтрок=ВывелиСтрок+1;
    Если ВывелиСтрок=ТекМаксСтрок Тогда
    Таб.НоваяСтраница(); 
    ВывелиСтрок=0; 
    КонецЕсли;                            
    Если  (ВывелиСтолбцов=0)  Тогда
    Таб.ВывестиСекцию("Ценник|Верх");
    ВывелиСтолбцов=1;
    ВывелиСтрок=ВывелиСтрок+1
    ИначеЕсли (ВывелиСтолбцов=ТекМаксСтолбцов) Тогда
    Таб.ВывестиСекцию("Ценник|Верх");
    ВывелиСтолбцов=1;
    ВывелиСтрок=ВывелиСтрок+1
    Иначе
    Таб.ПрисоединитьСекцию("Ценник|Верх");
    ВывелиСтолбцов=ВывелиСтолбцов+1;
    КонецЕсли;
    КонецЦикла;
    Иначе
    Товар=ПечЦенники.Товар;
    РознЦена=ПечЦенники.Цена;
    ГоденДо=ПечЦенники.ГоденДо;
    КодСтр=Товар.Код;
    ШтрихКод=Товар.ШтрихКод;
    СтранаПроисхождения=Товар.СтранаИзготовитель;
    //Для Поз=1 По ПечЦенники.Количество Цикл
    //	//ВывелиСтрок=ВывелиСтрок+1;
    //	Если ВывелиСтрок=ТекМаксСтрок Тогда
    //		Таб.НоваяСтраница(); 
    //		ВывелиСтрок=0;
    //	КонецЕсли;
    //	Если (ВывелиСтолбцов=ТекМаксСтолбцов) ИЛИ (ВывелиСтолбцов=0) Тогда
    //		Таб.ВывестиСекцию("Ценник|Верх");
    //		ВывелиСтолбцов=1;
    //		ВывелиСтрок=ВывелиСтрок+1
    //	Иначе
    //		Таб.ПрисоединитьСекцию("Ценник|Верх");
    //		ВывелиСтолбцов=ВывелиСтолбцов+1;
    //	КонецЕсли;
    //КонецЦикла;
    Для Поз=1 По ПечЦенники.Количество Цикл
    //ВывелиСтрок=ВывелиСтрок+1;
    Если ВывелиСтрок=ТекМаксСтрок Тогда
    Таб.НоваяСтраница(); 
    ВывелиСтрок=0; 
    КонецЕсли;                            
    Если  (ВывелиСтолбцов=0)  Тогда
    Таб.ВывестиСекцию("Ценник|Верх");
    ВывелиСтолбцов=1;
    ВывелиСтрок=ВывелиСтрок+1
    ИначеЕсли (ВывелиСтолбцов=ТекМаксСтолбцов) Тогда
    Таб.ВывестиСекцию("Ценник|Верх");
    ВывелиСтолбцов=1;
    ВывелиСтрок=ВывелиСтрок+1
    Иначе
    Таб.ПрисоединитьСекцию("Ценник|Верх");
    ВывелиСтолбцов=ВывелиСтолбцов+1;
    КонецЕсли;
    КонецЦикла;
    КонецЕсли;
    КонецЦикла;  
    //Выведем ценники последнего типа 
    Если ВывелиТаблицу=1 Тогда
    Таб.ТолькоПросмотр(0);
    Таб.Показать("Печать ценников","");
    КонецЕсли;
    
    //ФайлЦенника=СокрЛП(КаталогИБ())+"\ExtForms\Ценник.mxl";
    //Если ФС.СуществуетФайл(ФайлЦенника)>0 Тогда
    //	Таб.ИсходнаяТаблица(ФайлЦенника);
    //Иначе
    //	Таб.ИсходнаяТаблица("Ценник");
    //КонецЕсли;
    ////ВСтроке=Число(Таб.Область(1,1).Текст);
    ////Строк=Число(Таб.Область(2,1).Текст);
    //ВСтроке=3;
    //Строк=3;
    //Ценники.ВыбратьСтроки();
    //НомКол=1;
    //НомСтр=1;
    //Пока Ценники.ПолучитьСтроку()=1 Цикл
    //	Товар=Ценники.Товар;
    //	РознЦена=Ценники.Цена;
    //	ГоденДо=Ценники.ГоденДо;
    //	Для Поз=1 По Ценники.Количество Цикл
    //		Если НомКол=1 Тогда
    //			Таб.ВывестиСекцию("Секция2Г|Секция2В");
    //			Если НомСтр<Строк Тогда
    //				НомСтр=НомСтр+1;
    //			Иначе
    //				Таб.НоваяСтраница();
    //				НомСтр=1;
    //			КонецЕсли;
    //		Иначе
    //			Таб.ПрисоединитьСекцию("Секция2Г|Секция1В");
    //			Таб.ПрисоединитьСекцию("Секция2Г|Секция2В");
    //		КонецЕсли;
    //		Если НомКол<ВСтроке Тогда
    //			НомКол=НомКол+1;
    //			Таб.ПрисоединитьСекцию("Секция2Г|Секция3В");
    //		Иначе
    //			НомКол=1;
    //		КонецЕсли;
    //	КонецЦикла;
    //КонецЦикла;
    //Таб.ТолькоПросмотр(0);
    //Таб.Показать("Печать ценников","");
    КонецПроцедуры 
    
    Процедура ПодборПоКоду()
    Если КодПоиска=0 Тогда
    Возврат;
    КонецЕсли;
    СпрТов=СоздатьОбъект("Справочник.Товары");
    // Есть ли такой товар в каталоге ?
    Если СпрТов.НайтиПоКоду(КодПоиска,0)=0 Тогда
    Предупреждение("Товар с кодом "+КодПоиска+" не найден!");
    КодПоиска=0;
    Возврат;
    Иначе
    Если СпрТов.ЭтоГруппа()=1 Тогда
    Предупреждение("Товар с кодом "+КодПоиска+" - группа!");
    КодПоиска=0;
    Возврат;
    КонецЕсли;
    Ценники.ВыбратьСтроки();
    Пока Ценники.ПолучитьСтроку()>0 Цикл
    Если Ценники.Товар=СпрТов.ТекущийЭлемент() Тогда
    Ценники.Количество=Ценники.Количество+1;
    Ценники.ТекущаяСтрока(Ценники.НомерСтроки);
    КодПоиска=0;
    Возврат;
    КонецЕсли;
    КонецЦикла;
    УстЦенника(Ценники,СпрТов.ТекущийЭлемент(),ПоискКол,1);
    Ценники.ТекущаяСтрока(Ценники.НомерСтроки);
    КодПоиска=0;
    КонецЕсли;
    КонецПроцедуры
    
    Процедура ОбработкаВнешнегоСобытия(Источник,Событие,Данные)
    Если ( Источник = "BarCodeScaner" )	и ( Событие = "BarCodeValue" ) Тогда
    Если Сканер.OldVersion=0 Тогда
    Данные=Сканер.ScanData;
    КонецЕсли;
    СпрШК=СоздатьОбъект("Справочник.ШтрихКоды");
    ШК=Лев(Данные,13);
    ШК=СокрП(СокрЛ(ШК));
    КонЦ=(13-СтрДлина(ШК));
    Для i=1 по КонЦ Цикл
    ШК="0"+ШК;
    КонецЦикла;
    Сканер.DeleteEvent();
    Если СпрШК.НайтиПоРеквизиту("ШтрихКод",ШК,1)=0 Тогда
    Предупреждение("Товар со штрих-кодом "+ СокрЛ(ШК)+" не найден!");
    Возврат;
    КонецЕсли;
    Если СпрШК.ВладелецШК.Вид()="Товары" Тогда
    ТекТовар=СпрШК.ВладелецШК;
    Иначе
    //Значит отсканировали единицу
    ТекТовар=СпрШК.ВладелецШК.Владелец;
    КонецЕсли;
    Ценники.ВыбратьСтроки();
    Пока Ценники.ПолучитьСтроку()>0 Цикл
    Если Ценники.Товар=ТекТовар.ТекущийЭлемент() Тогда
    Ценники.Количество=Ценники.Количество+1;
    Ценники.ТекущаяСтрока(Ценники.НомерСтроки);
    Возврат;
    КонецЕсли;
    КонецЦикла;
    УстЦенника(Ценники,ТекТовар,1,1);
    Ценники.ТекущаяСтрока(Ценники.НомерСтроки);
    КонецЕсли;
    КонецПроцедуры     
    
    Процедура УстКолвоЦенников()
    Если Ценники.КоличествоСтрок()>0 Тогда
    Ценники.ВыбратьСтроки();
    Пока Ценники.ПолучитьСтроку()=1 Цикл
    Ценники.Количество=КолвоЭкземпляров;
    КонецЦикла;
    КонецЕсли;
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры	</span>  
    
    Процедура УстТипаЦенников()
    Если Ценники.КоличествоСтрок()>0 Тогда
    Ценники.ВыбратьСтроки();
    Пока Ценники.ПолучитьСтроку()=1 Цикл
    Ценники.ТипЦенника=УстТипЦенника;
    Ценники.КодЦенника=УстТипЦенника.Код;
    КонецЦикла;
    КонецЕсли;
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры	</span>  
    Процедура ВыбратьВсе()
    Если Ценники.КоличествоСтрок()>0 Тогда
    Ценники.ВыбратьСтроки();
    Пока Ценники.ПолучитьСтроку()=1 Цикл
    Ценники.Пометка=5;
    КонецЦикла;
    КонецЕсли;
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры	</span>  
    Процедура СнятьВсе()
    Если Ценники.КоличествоСтрок()>0 Тогда
    Ценники.ВыбратьСтроки();
    Пока Ценники.ПолучитьСтроку()=1 Цикл
    Ценники.Пометка=4;
    КонецЦикла;
    КонецЕсли;
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры	</span>  
    
    
    

    Вложения:

  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Ты бы еще глобальный модуль сюда выложил))))))). Я же просил не текст а саму обработку!

    ВходНомерДок - это в шаблоне самого ценника (смотри внизу). А цены нет потому что скорее всего у тебя не установлена РОЗНИЧНАЯ цена. (она бере ее)
  5. TopicStarter Overlay
    anton
    Offline

    anton Опытный в 1С

    Регистрация:
    3 авг 2009
    Сообщения:
    187
    Симпатии:
    0
    Баллы:
    26

    ну вот я полностью процедуру печати выложил!
    а цена установлена там же картинка есть 75 р.
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    из текста не видно, что за объект "Ценники" (он выгружается в ПечЦенники). Выложи саму обработку как ert файл или весь МД
  7. TopicStarter Overlay
    anton
    Offline

    anton Опытный в 1С

    Регистрация:
    3 авг 2009
    Сообщения:
    187
    Симпатии:
    0
    Баллы:
    26
    знал бы я как это сделать я в 1с не бум-бум только начал изучать!!!!!
    куда зайти и что от туду дернуть нужно???
  8. TopicStarter Overlay
    anton
    Offline

    anton Опытный в 1С

    Регистрация:
    3 авг 2009
    Сообщения:
    187
    Симпатии:
    0
    Баллы:
    26
    вот это обработки "ПечатьЦенников"
    может это :unsure:

    Вложения:

  9. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Зайдите в конфигуратор, найдите обработку (как-же текст нашли) Не захидя в св-ва пр.кн. мышки - сохранить как внешний отчет
  10. TopicStarter Overlay
    anton
    Offline

    anton Опытный в 1С

    Регистрация:
    3 авг 2009
    Сообщения:
    187
    Симпатии:
    0
    Баллы:
    26
    и 1с стала другую ошибку выдавать почему то

    Код:
    Значение не представляет агрегатный объект (ВходНомерДок)
    

    Вложения:

  11. TopicStarter Overlay
    anton
    Offline

    anton Опытный в 1С

    Регистрация:
    3 авг 2009
    Сообщения:
    187
    Симпатии:
    0
    Баллы:
    26
    и еще немогу понять программа сетевая пользуемся через терминал у меня и у управляющего по кафе не работает эта функция а у технолога в кафе все печатает и подставляет без проблем! :unsure:
    Ничего не пеонимаю товариши специалисты помогите выйти из ситуации пожалуйста!!!! а то меня начальство :smile:
  12. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    У вас тип ценника - это справочник. В нем хранится ПУТЬ к шаблону справочника. На 99% путь задан не корректно (отностельный а не сетевой). Поэтому программа не находит ценник и пытается использовать встроеный шаблон, а они (шаблоны) не совпадают! Ройтесь в этом направлении
  13. TopicStarter Overlay
    anton
    Offline

    anton Опытный в 1С

    Регистрация:
    3 авг 2009
    Сообщения:
    187
    Симпатии:
    0
    Баллы:
    26
    вот

    Вложения:

  14. TopicStarter Overlay
    anton
    Offline

    anton Опытный в 1С

    Регистрация:
    3 авг 2009
    Сообщения:
    187
    Симпатии:
    0
    Баллы:
    26
    вот

    Вложения:

    • admin.rar
      Размер файла:
      945 байт
      Просмотров:
      24
  15. TopicStarter Overlay
    anton
    Offline

    anton Опытный в 1С

    Регистрация:
    3 авг 2009
    Сообщения:
    187
    Симпатии:
    0
    Баллы:
    26
    это на моем компе

    Вложения:

    • 1.JPG
      1.JPG
      Размер файла:
      221,6 КБ
      Просмотров:
      36
  16. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Выложеные ценники НЕ ТЕ (отсутствет формула с ошибкой в строке 9). Судя по всему вы выложиши внешние шаблоны, а в программе где-то еще есть внутренний (скорее всего в общих таблицах)
  17. TopicStarter Overlay
    anton
    Offline

    anton Опытный в 1С

    Регистрация:
    3 авг 2009
    Сообщения:
    187
    Симпатии:
    0
    Баллы:
    26
    а где посмотреть эти обшие таблицы????
    и еще вопрос на моем компьютере отражается цена а на терминале нет

    Вложения:

    • 2.JPG
      2.JPG
      Размер файла:
      201,8 КБ
      Просмотров:
      12
  18. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    конфигуратор в заголовке конфы пр. кн. мышки - общие таблицы
  19. TopicStarter Overlay
    anton
    Offline

    anton Опытный в 1С

    Регистрация:
    3 авг 2009
    Сообщения:
    187
    Симпатии:
    0
    Баллы:
    26
    ну открыл там ценник а толку мало там вобше строки 9 нет тоесть ценник получается не тот, я даже поломал его ну не он это почемуто! ладно номер фактуры еще как то можно подставить, руками, а размеры ценника при печати ни как не меняются!
  20. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Выложите МДшник + каталог ExtForms с его содержимым (иначе в "угадайку" еще долго можно играть)

Поделиться этой страницей