8.х Не отображается значение колонки

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем X-Man, 2 июн 2008.

  1. TopicStarter Overlay
    X-Man
    Offline

    X-Man Опытный в 1С

    Регистрация:
    18 май 2007
    Сообщения:
    428
    Симпатии:
    3
    Баллы:
    29
    Здравствуйте уважаемые профессионалы. Очень нуждаюсь в Вашей помощи. Проблема такая: в документе есть 2 реквизита: сумма и суммаНДС. На форму в табличную часть добавляю их и плюс еще одну колонку с именем "Всего", которая считается как сумма + суммаНДС. Так вот, при пересчете сумм значение не показывается, хотя в отладчике все нормально. Что не так?

    Суммы пересчитываются в сле. процедуре:
    Код:
    Процедура ПересчетСумм(СтрокаТЧ)
    
    СтрокаТЧ.Сумма = СтрокаТЧ.Цена * СтрокаТЧ.Количество;
    ЭлементыФормы.Услуги.Колонки.Всего.ЭлементУправления.Значение = СтрокаТЧ.Сумма;
    
    Если УчитыватьНДСМатериалы = Истина Тогда
    СтрокаТЧ.СуммаНДС = СтрокаТЧ.Цена * СтрокаТЧ.Количество * 
    обКоэффициентНДС(СтрокаТЧ.СтавкаНДС);
    
    Если СуммаВклНДСУслуги = Истина Тогда
    СтрокаТЧ.Сумма = СтрокаТЧ.Сумма + СтрокаТЧ.СуммаНДС;
    КонецЕсли;
    
    ЭлементыФормы.Услуги.Колонки.Всего.ЭлементУправления.Значение = ЭлементыФормы.Услуги.Колонки.Всего.ЭлементУправления.Значение + СтрокаТЧ.СуммаНДС; 
    
    КонецЕсли;
    
    КонецПроцедуры
    

    Значение присваивается, но на форме почему-то не отображается. Тип значения в с войствах колонки задан(число), параметр СтрокаТЧ - строка табличной части документа. Можно конечно завести еще один реквизит табличной части "Всего", но не хочется размножать. И так их дофига. Помогите пожалуйста.
  2. AlexFF
    Offline

    AlexFF Разбирающийся

    Регистрация:
    6 мар 2007
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    26
    Спионерено из Типовой бухгалтерии
    Код:
    // Процедура - обработчик события "ПриВыводеСтроки" табличной части
    // "Товары". Формирует данные в колонке "Всего".
    //
    Процедура ТоварыПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    
    Если ЭлементыФормы.Товары.Колонки.Всего.Видимость Тогда
    
    ОформлениеСтроки.Ячейки.Всего.УстановитьТекст(ФорматСумм(ДанныеСтроки.Сумма
    + ?(СуммаВключаетНДС, 0, ДанныеСтроки.СуммаНДС)));
    
    КонецЕсли;
    
    
    КонецПроцедуры // ТоварыПриВыводеСтроки()
    

Поделиться этой страницей