8.х Не отображается заполненое поле

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем __Вячеслав__, 17 фев 2015.

  1. TopicStarter Overlay
    __Вячеслав__
    Offline

    __Вячеслав__

    Регистрация:
    4 янв 2015
    Сообщения:
    7
    Симпатии:
    0
    Баллы:
    1
    Всем привет.

    Заполняю форму Реализация товаров и услуг (услуги) без её записи.
    Но поле ПорядокУчетаРасчетов (Расчеты) заполняется, но не отображается.
    Тоже самое и с ячейкой Счета учета в таблице.
    При записи не ругается. Но хотелось, что бы было видно, что там заполнено.
    1С:Предприятие 8.3 (8.3.4.437)
    Бухгалтерия предприятия (базовая), редакция 3.0 (3.0.32.7)

    Код:
    &НаКлиенте
    Процедура ПолучаемФорму()
           
       СтруктураПараметров = Новый Структура;
       ЗначенияЗаполнения = Новый Структура;
     
       ВидОперации = ПредопределенноеЗначение("Перечисление.ВидыОперацийРеализацияТоваров.Услуги");
       ЗначенияЗаполнения.Вставить("ВидОперации", ВидОперации); 
       СтруктураПараметров.Вставить("ЗначенияЗаполнения", ЗначенияЗаполнения);
      мФорма = ПолучитьФорму("Документ.РеализацияТоваровУслуг.ФормаОбъекта", СтруктураПараметров, ЭтаФорма,Истина); 
       ДокОбъект = мФорма.Объект;
       ДокЭлементы = мФорма.Элементы;
       ОткрытьФормуНезаписанногоДокументаНаСервере(ДокОбъект);
     
      УправлениемФорма(ДокОбъект,ДокЭлементы);
       КопироватьДанныеФормы(ДокОбъект, мФорма.Объект);
     
      мФорма.Открыть();
    КонецПроцедуры
    &НаСервере
    Процедура ОткрытьФормуНезаписанногоДокументаНаСервере(ДокОбъект)
     
     
       ДокОбъект.Дата=ЗначениеДатаОплаты;
       ДокОбъект.Организация=Справочники.Организации.ОрганизацияПоУмолчанию();
     
       НайденнаяСсылка=Справочники.Контрагенты.НайтиПоНаименованию(ЗначениеКонтрагент);
      Если НайденнаяСсылка = Справочники.Контрагенты.ПустаяСсылка() Тогда
        Сообщить(ЗначениеКонтрагентПолное+" - контрагент не найден!");
         Иначе
         ДокОбъект.Контрагент=НайденнаяСсылка;
       
         НайденнаяСсылка2=Справочники.ДоговорыКонтрагентов.НайтиПоНаименованию(ЗначениеНомерДоговора);
         Если НайденнаяСсылка2 = Справочники.Номенклатура.ПустаяСсылка() Тогда 
           Сообщить(ЗначениеКонтрагентПолное+" договор "+ ЗначениеНомерДоговора +" не найден!");
         Иначе
           ДокОбъект.ДоговорКонтрагента=НайденнаяСсылка2;
           ДокОбъект.Комментарий=НайденнаяСсылка2;
         КонецЕсли;   
       КонецЕсли;
     
       ДоговорУказан = ЗначениеЗаполнено(ДокОбъект.ДоговорКонтрагента);
       РеквизитыДоговора = ОбщегоНазначения.ЗначенияРеквизитовОбъекта(
         ДокОбъект.ДоговорКонтрагента, "ВидДоговора, ВалютаВзаиморасчетов"); 
       Если ДоговорУказан Тогда
         ВалютаВзаиморасчетов = РеквизитыДоговора.ВалютаВзаиморасчетов;
       КонецЕсли; 
       ДокОбъект.АдресДоставки = "";
       ДокОбъект.Склад= "";
       СчетаУчета = Неопределено; 
       Если СчетаУчета = Неопределено Тогда
         СчетаУчета = БухгалтерскийУчетПереопределяемый.ПолучитьСчетаРасчетовСКонтрагентом(
           ДокОбъект.Организация, ДокОбъект.Контрагент, ДокОбъект.ДоговорКонтрагента);
       КонецЕсли;
     
       Если ОбщегоНазначения.ЗначениеРеквизитаОбъекта(
           ДокОбъект.ДоговорКонтрагента, "ВидДоговора") = Перечисления.ВидыДоговоровКонтрагентов.СКомиссионером
         ИЛИ ДокОбъект.ВидОперации = Перечисления.ВидыОперацийРеализацияТоваров.ОтгрузкаБезПереходаПраваСобственности Тогда
         ДокОбъект.СчетУчетаРасчетовСКонтрагентом = ПланыСчетов.Хозрасчетный.ПустаяСсылка();
         ДокОбъект.СчетУчетаРасчетовПоАвансам  = ПланыСчетов.Хозрасчетный.ПустаяСсылка();
       Иначе
         ДокОбъект.СчетУчетаРасчетовСКонтрагентом = СчетаУчета.СчетРасчетовПокупателя;
         Если ДокОбъект.СпособЗачетаАвансов = Перечисления.СпособыЗачетаАвансов.Автоматически
           ИЛИ ДокОбъект.СпособЗачетаАвансов = Перечисления.СпособыЗачетаАвансов.ПоДокументу Тогда
           ДокОбъект.СчетУчетаРасчетовПоАвансам = СчетаУчета.СчетАвансовПокупателя;
         Иначе
           ДокОбъект.СчетУчетаРасчетовПоАвансам = ПланыСчетов.Хозрасчетный.ПустаяСсылка();
         КонецЕсли;
       КонецЕсли;
     
       //добавлям табличную часть
       ТабличнаяЧасть=ДокОбъект.Услуги;
       НоваяСтрока=ТабличнаяЧасть.Добавить();
       НайденнаяСсылка3=Справочники.Номенклатура.НайтиПоНаименованию(ЗначениеМесто);
       Если НайденнаяСсылка3 = Справочники.Номенклатура.ПустаяСсылка() Тогда 
           Сообщить(ЗначениеКонтрагентПолное+" договор "+ ЗначениеМесто +" номенклатура не найдена!");
         Иначе
           НоваяСтрока.Номенклатура=НайденнаяСсылка3;
           НоваяСтрока.Содержание=НайденнаяСсылка3.НаименованиеПолное;
           НоваяСтрока.СтавкаНДС = НайденнаяСсылка3.СтавкаНДС;
       КонецЕсли;   
       НоваяСтрока.Количество=День(ЗначениеДатаОплаты);
       НоваяСтрока.Цена=ЗначениеСумма;
       НоваяСтрока.Сумма=ЗначениеСумма;
       НоваяСтрока.СуммаНДС=ЗначениеСумма*18/118; 
       НоваяСтрока.Всего=ЗначениеСумма;
       НоваяСтрока.СчетУчетаНДСПоРеализации=ПланыСчетов.Хозрасчетный.НайтиПоКоду("90.03"); 
       НоваяСтрока.СчетДоходов = ПланыСчетов.Хозрасчетный.НайтиПоКоду("90.01.1");
       НоваяСтрока.СчетРасходов = ПланыСчетов.Хозрасчетный.НайтиПоКоду("90.02.1");
       НоваяСтрока.Субконто=НоваяСтрока.Номенклатура.НоменклатурнаяГруппа;
       
     
    КонецПроцедуры
    Последнее редактирование: 17 фев 2015
  2. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.429
    Симпатии:
    372
    Баллы:
    104
    тегами для оформления кода пользуйтесь плиз
    upload_2015-2-17_21-55-43.png

    и последний релиз БП 3.0 -
    3.0.37.43

Поделиться этой страницей