8.х не могу записать новое значение строки документа

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем mari8998, 11 фев 2008.

  1. TopicStarter Overlay
    mari8998
    Offline

    mari8998

    Регистрация:
    31 окт 2007
    Сообщения:
    30
    Симпатии:
    0
    Баллы:
    1
    Код:
    Док = Документы.ПриемНаРаботуВОрганизацию.Выбрать(Дата1, Дата2);
    спр = Справочники.ПодразделенияОрганизаций;
    Подразделение =спр.НайтиПоНаименованию("Основное");
    П=Подразделение.ПолучитьОбъект().Ссылка;
    Пока Док.Следующий() Цикл
    объект = Док.ПолучитьОбъект();
    Для Каждого ТекущаяСтрока Из Док.РаботникиОрганизации Цикл 
    М=ТекущаяСтрока.ПодразделениеОрганизации.ПолучитьОбъект();
    М=П;
    КонецЦикла;
    объект.Записать();
    
    КонецЦикла;
    
    
    :unsure:

    [warn=Читайте правила]1. Используйте тэг
    Код:
    2. Прочитайте, как [url="http://www.1c-pro.ru/index.php?act=announce&id=8"]правильно задавать вопрос[/url]
    3. Оба этих требования висят в шапке темы - если вы не читаете, то что написано прямо перед глазами, как вы собираетесь вникать в ответ?[/warn]
  2. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Вы хоть на код смотрели?
    Что такое "М" и что такое "объект"?
  3. Senya
    Offline

    Senya Опытный в 1С

    Регистрация:
    6 июн 2006
    Сообщения:
    594
    Симпатии:
    0
    Баллы:
    26
    Код:
    Док = Документы.ПриемНаРаботуВОрганизацию.Выбрать(Дата1, Дата2);
    спр = Справочники.ПодразделенияОрганизаций;   
    Подразделение =спр.НайтиПоНаименованию("Основное"); 
    //П=Подразделение.ПолучитьОбъект().Ссылка;  // Это лишнее
    Пока Док.Следующий() Цикл   
    объект = Док.ПолучитьОбъект();   
    Для Каждого ТекущаяСтрока Из Док.РаботникиОрганизации Цикл  
    //М=ТекущаяСтрока.ПодразделениеОрганизации.ПолучитьОбъект();  // Это тоже лишнее
    //М=П;  //Не так - смотри ниже
    ТекущаяСтрока. ПодразделениеОрганизации = Подразделение; 
    КонецЦикла;    
    объект.Записать(); 
    КонецЦикла;
    
    
    
Похожие темы
  1. Svet42
    Ответов:
    8
    Просмотров:
    603
  2. Maks
    Ответов:
    6
    Просмотров:
    307
Загрузка...

Поделиться этой страницей