7.7 Не могу вывести значения в таблицу

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем Glodiator007, 14 апр 2017.

  1. TopicStarter Overlay
    Glodiator007
    Offline

    Glodiator007

    Регистрация:
    14 апр 2017
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    разработан код, формеруется отлично, осталось только вывести все значения в заранее приготовленную таблицу.
    что бы было на так: http://keep4u.ru/image/SQtSs
    а было в этой таблице: http://keep4u.ru/image/SQtS0
    вот код:
    Код:
    Процедура ПриОткрытии()
       
        //Убрать!!  
       
        КонДата = Дата(2016,12,31);   
        Конецпроцедуры             
    Процедура Сформировать()
       
        // начальная проверка
       
        Если ПустоеЗначение(КонДата)=1 Тогда
            Предупреждение("Не выбрана кон. дата"); 
            возврат;            
        КонецЕсли;
       
        //---
       
        // блок подготовки конструкций
       
        ТекГод_КонДата = КонМесяца(КонДата); //пример 31.12.2016 
       
       
       
        ТекГод_КонДата_МинусТриМесяца_НачМесяца = ДобавитьМесяц(НачМесяца(ТекГод_КонДата),-2); //01.10.2016         
        ТекГод_НачалоГода =  НачГода(КонДата); //01.01.2016         
       
        ПрошлыйГод_НачалоГода=ДобавитьМесяц( ТекГод_НачалоГода, -12); //01.01.2015 
       
        ПозапрошлыйГод_НачалоГода=ДобавитьМесяц(ПрошлыйГод_НачалоГода,-12);    // 01.01.2014 
       
       
       
        ТЗ = СоздатьОбъект("ТаблицаЗначений");
        ТЗ.НоваяКолонка("Объект","Справочник.Объекты");
        ТЗ.НоваяКолонка("ТекЗадолж","Число",15,3);
        ТЗ.НоваяКолонка("Начисление_Посл_3месяца","Число",15,3);
        ТЗ.НоваяКолонка("Начисление_ТекГод","Число",15,3);
        ТЗ.НоваяКолонка("Начисление_ПрошлыйГод","Число",15,3);
        ТЗ.НоваяКолонка("Начисление_ПозапрошлыйГод","Число",15,3);
        ТЗ.НоваяКолонка("Оплата_Посл_3месяца","Число",15,3);
        ТЗ.НоваяКолонка("Оплата_ТекГод","Число",15,3);
        ТЗ.НоваяКолонка("Оплата_ПрошлыйГод","Число",15,3);
        ТЗ.НоваяКолонка("Оплата_ПозапрошлыйГод","Число",15,3);
       
       
       
        // получение данных
        ЖР=СоздатьОбъект("ЖурналРасчетов.Платежи");
        ЖР.ВыбратьЗаписи(ПозапрошлыйГод_НачалоГода,КонДата);   
        Сумма=0;
        КоличествоЗаписей=0;   
        Сообщить ("Цикл начат в:"+ТекущееВремя());   
        Пока ЖР.ПолучитьЗапись()=1 Цикл      
           
            Если КоличествоЗаписей>=1000 тогда
                прервать;   
            конецЕсли;
                                
            Если ЖР.ВидРасч.ВходитВГруппу(ГруппаРасчетов.ВсеНачисления)=1 Тогда      
                ТЗ.НоваяСтрока();
                    
                ТЗ.Объект =  ЖР.Объект;        
            //    сообщить(ЖР.ДатаНачала);
                Если (ЖР.ДатаНачала >= ТекГод_КонДата_МинусТриМесяца_НачМесяца) И
                    (ЖР.ДатаНачала <= ТекГод_КонДата) Тогда
                    ТЗ.Начисление_Посл_3месяца = ЖР.Результат;
                КонецЕсли;
                                                           
                Если (ЖР.ДатаНачала >=     ТекГод_НачалоГода) И
                    (ЖР.ДатаНачала <= ТекГод_КонДата) Тогда       
                       
                        ТЗ.Начисление_ТекГод = ЖР.Результат;     
                   
                ИначеЕсли (ЖР.ДатаНачала >= ПрошлыйГод_НачалоГода) И
                    (ЖР.ДатаНачала < ТекГод_НачалоГода) Тогда
                                                            
                        ТЗ.Начисление_ПрошлыйГод = ЖР.Результат;
                       
                ИначеЕсли (ЖР.ДатаНачала >= ПозапрошлыйГод_НачалоГода ) И
                    (ЖР.ДатаНачала < ПрошлыйГод_НачалоГода) Тогда
                       
                        ТЗ.Начисление_ПозапрошлыйГод = ЖР.Результат;   
                КонецЕсли;
           
               
               
            ИначеЕсли ЖР.ВидРасч.ВходитВГруппу(ГруппаРасчетов.ВсеОплаты)=1 Тогда
                ТЗ.НоваяСтрока();
                    
                ТЗ.Объект =  ЖР.Объект;        
    
                Если (ЖР.ДатаНачала >= ТекГод_КонДата_МинусТриМесяца_НачМесяца) И
                    (ЖР.ДатаНачала <= ТекГод_КонДата) Тогда
                    ТЗ.Оплата_Посл_3месяца = ЖР.Результат;
                КонецЕсли;
                                
                //
                Если (ЖР.ДатаНачала >=     ТекГод_НачалоГода) И
                    (ЖР.ДатаНачала <= ТекГод_КонДата) Тогда       
                       
                        ТЗ.Оплата_ТекГод = ЖР.Результат;     
                   
                ИначеЕсли (ЖР.ДатаНачала >= ПрошлыйГод_НачалоГода) И
                    (ЖР.ДатаНачала < ТекГод_НачалоГода) Тогда
                                                            
                        ТЗ.Оплата_ПрошлыйГод = ЖР.Результат;
                       
                ИначеЕсли (ЖР.ДатаНачала >= ПозапрошлыйГод_НачалоГода ) И
                    (ЖР.ДатаНачала < ПрошлыйГод_НачалоГода) Тогда
                       
                        ТЗ.Оплата_ПозапрошлыйГод = ЖР.Результат;   
                КонецЕсли;
       
            КонецЕсли;           
           
           
           
            КоличествоЗаписей=КоличествоЗаписей+1;
            Сумма=Сумма+ЖР.Результат;
        КонецЦикла;
       
       
        ТЗ.свернуть("Объект", "ТекЗадолж, Начисление_Посл_3месяца,Начисление_ТекГод, Начисление_ПрошлыйГод, Начисление_ПозапрошлыйГо, Оплата_Посл_3месяца, Оплата_ТекГод, Оплата_ПрошлыйГод, Оплата_ПозапрошлыйГод");
    ТЗ.выбратьСтроку();// УБРАТЬ потом!
       
        Сообщить ("Цикл закончен в:"+ТекущееВремя());
        Сообщить ("КоличествоЗаписей"+КоличествоЗаписей);
        Сообщить ("Итоговая сумма"+Сумма);
    
          
    КонецПроцедуры
    Последнее редактирование: 14 апр 2017
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.734
    Симпатии:
    432
    Баллы:
    104
    Изучайте метод ВывестиСекцию объекта Таблица.
    За вас код ни кто писать не будет

Поделиться этой страницей