[РЕШЕНО] Не могу вывести картинку на печать

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем fenlork, 28 июл 2016.

  1. TopicStarter Overlay
    fenlork
    Offline

    fenlork Опытный в 1С

    Регистрация:
    5 сен 2013
    Сообщения:
    71
    Симпатии:
    0
    Баллы:
    26
    Доброго времени суток.
    Управляемое приложение. Конфигурация далека от типовой CRM., есть спр. номенклатура, есть спр Объект недвижимости.
    Связывает их между собой рс .А_НоменклатураНедвижимость. В спр. Номенклатура есть картинка-тип справочник- номенк.прикрепленные файлы.
    запрос=новый запрос;
    запрос.Текст="ВЫБРАТЬ
    | А_НоменклатураНедвижимость.Номенклатура.ФайлКартинки как Файл
    |ИЗ
    | РегистрСведений.А_НоменклатураНедвижимость КАК А_НоменклатураНедвижимость
    |ГДЕ
    | А_НоменклатураНедвижимость.ОбъектНедвижимости.Ссылка = &Ссылка";
    запрос.УстановитьПараметр("ссылка",ссылканаобъект.объектнедвижимости);
    рез=запрос.Выполнить().Выбрать();
    если рез.Следующий() тогда

    СправДопИнф=рез.файл;
    Изображение=СправДопИнф.ФайлХранилище.получить();
    ИзображениеОбласть = приложение1.Рисунки.кк;
    _Картинка = Новый Картинка(изображение);
    ИзображениеОбласть.Картинка=_Картинка;

    конецесли;
    в отладке рез.файл-ссылка на справочник .номенклатура присоединенные файлы.
    в итоге область выводить пустой без картинки.
  2. TopicStarter Overlay
    fenlork
    Offline

    fenlork Опытный в 1С

    Регистрация:
    5 сен 2013
    Сообщения:
    71
    Симпатии:
    0
    Баллы:
    26
    Если кто столкнется то вот так
    запрос=новый запрос;
    запрос.Текст="ВЫБРАТЬ
    | А_НоменклатураНедвижимость.Номенклатура.ФайлКартинки как ФайлКартинки
    |ИЗ
    | РегистрСведений.А_НоменклатураНедвижимость КАК А_НоменклатураНедвижимость
    |ГДЕ
    | А_НоменклатураНедвижимость.ОбъектНедвижимости.Ссылка = &Ссылка";
    запрос.УстановитьПараметр("ссылка",ссылканаобъект.объектнедвижимости);
    Результат=запрос.Выполнить();
    ВыборкаКартинки = Результат.Выбрать();

    Пока ВыборкаКартинки.Следующий() Цикл
    Если ВыборкаКартинки.ФайлКартинки <> Справочники.НоменклатураПрисоединенныеФайлы.ПустаяСсылка() Тогда

    Картинка = Новый Картинка;
    СтруктураКартинки = ПрисоединенныеФайлы.ПолучитьДанныеФайла(ВыборкаКартинки.ФайлКартинки);
    ЗнКартинки = ПолучитьИзВременногоХранилища(СтруктураКартинки.СсылкаНаДвоичныеДАнныеФайла);
    ИзображениеОбласть = приложение1.Рисунки.кк;
    Если ТипЗнч(ЗнКартинки) = Тип("Картинка") Тогда
    ИзображениеОбласть.Картинка = ЗнКартинки;
    Иначе
    ИзображениеОбласть.Картинка = Новый Картинка(ЗнКартинки);
    КонецЕсли;
    Иначе
    Сообщить("У номенклатуры: "+ВыборкаКартинки.Номенклатура + " нет изображения!");
    КонецЕсли;


    КонецЦикла;
    табДок.Вывести(ПРИЛОЖЕНИЕ1);

Поделиться этой страницей