8.х Не могу выйти из процедуры

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Serge, 12 сен 2008.

  1. TopicStarter Overlay
    Serge
    Offline

    Serge Опытный в 1С

    Регистрация:
    15 фев 2008
    Сообщения:
    160
    Симпатии:
    0
    Баллы:
    26
    бухгалтерия п/п 1.6.8.3
    Необходимо выйти из процедуры ОбработкаЗаполнения по условию, но чето не получается

    Код примерно тогда

    Код:
    Если <условие> Тогда
    Возврат;
    Иначе
    <текст обработки заполнения>
    КонецЕсли;
    
    Условие отрабатывается, но документ все равно появляется (не заполненный естественно). Как его, дьявола, сделать, чтоб он не открывался?
  2. Kaboom
    Offline

    Kaboom Опытный в 1С

    Регистрация:
    2 июл 2007
    Сообщения:
    158
    Симпатии:
    0
    Баллы:
    26
    От себя добавлю, что инструкция Возврат просто выходит из процедуры НЕ ОТМЕНЯЯ стандартную обработку, тоесть при
    Код:
    Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
    Возврат;
    КонецПроцедуры
    
    
    форма откроется, нужно сделалать:
    Код:
    Отказ = Истина
    
    
  3. GvH
    Offline

    GvH Опытный в 1С

    Регистрация:
    12 авг 2008
    Сообщения:
    179
    Симпатии:
    0
    Баллы:
    26
    Kaboom, это конечно всё весело, но в таком случае документ вообще никогда не откроется.
    Чтобы не открывалась форма после отработки процедуры ОбработкаЗаполнения нужно воспользоваться свойством расширения формы документа ПараметрОснование.
    Например:
    Код:
    Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
    Если ЗначениеЗаполнено(ПараметрОснование) Тогда
    Отказ = Истина;
    КонецЕсли;
    КонецПроцедуры // ПередОткрытием()
    
  4. Kaboom
    Offline

    Kaboom Опытный в 1С

    Регистрация:
    2 июл 2007
    Сообщения:
    158
    Симпатии:
    0
    Баллы:
    26
    Код:
    Kaboom, это конечно всё весело, но в таком случае документ вообще никогда не откроется.
    
    Это был пример :unsure: , если бездумно переписывать весь код который ты гдето увидел, то не только документ никогда не откроется:)
  5. TopicStarter Overlay
    Serge
    Offline

    Serge Опытный в 1С

    Регистрация:
    15 фев 2008
    Сообщения:
    160
    Симпатии:
    0
    Баллы:
    26
    Пасиб, камрады. Как я сразу не додумался перенести условие в процедуру ПередОткрытием.

Поделиться этой страницей