7.7 Не могу сформировать окно для вывода на печать. Помогите разобраться в ошибках. Код и ошибк

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем kulkrise, 5 сен 2011.

  1. TopicStarter Overlay
    kulkrise
    Offline

    kulkrise

    Регистрация:
    5 сен 2011
    Сообщения:
    16
    Симпатии:
    0
    Баллы:
    1
    КодМодуля

    Код:
    Перем СпрГрупп;
    Перем СпрЭлемен;
    Перем Таб;
    
    Процедура Печать()
    СпрГрупп=СоздатьОбъект("Справочник.Контрагенты");	
    СпрЭлемен=СоздатьОбъект("Справочник.Контрагенты");	
    Таб=СоздатьОбъект("Таблица"):
    Таб.ИсходнаяТаблица("ТаблицаКонтр");
    Таб.ВывестиСекцию("Шапка");
    Если СпрГрупп.ВыбратьЭлементы()=1 Тогда
    Пока СпрГрупп.ПолучитьЭлемент()=1 Цикл
    Если СпрГрупп.ЭтоГруппа()=1 Тогда
    Групп=СпрГрупп.ТекущийЭлемент();
    Таб.ВывестиСекцию("Группа");
    СпрЭлемен.ИспользоватьРодителя(Групп);
    Если СпрЭлемен.ВыбратьЭлементы()=1 Тогда
    Пока СпрЭлемен.ПолучитьЭлемент()=1 Цикл
    Наименов=СпрЭлемен.ТекущийЭлемент();
    Адрес=Наименов.Адрес;
    Банк=Наименов.Банк;
    РасчСчет=Наименов.РасчетныйСчет;
    Таб.ВывестиСекцию("Строка");
    КонецЦикла;
    КонецЕсли;
    КонецЕсли;
    КонецЦикла;
    КонецЕсли;
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Контрагенты","");
    КонецПроцедуры
    
    Ошибки

    Посмотреть вложение 8461 Посмотреть вложение 8462 Посмотреть вложение 8463 Посмотреть вложение 8464

    Вложения:

    • рис.2.9.jpg
      рис.2.9.jpg
      Размер файла:
      20,8 КБ
      Просмотров:
      23
    • рис.2.11.jpg
      рис.2.11.jpg
      Размер файла:
      19,7 КБ
      Просмотров:
      18
  2. Dmitriy_76
    Offline

    Dmitriy_76 Опытный в 1С Команда форума

    Регистрация:
    26 мар 2011
    Сообщения:
    2.175
    Симпатии:
    13
    Баллы:
    29

    ; на конце должна быть
  3. TopicStarter Overlay
    kulkrise
    Offline

    kulkrise

    Регистрация:
    5 сен 2011
    Сообщения:
    16
    Симпатии:
    0
    Баллы:
    1
    Спасибо большое, так невнимательно набирала, да и потом так и не увидела:(

Поделиться этой страницей