7.7 Не могу рассчитать временные итоги после ТА!

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем Iven, 11 авг 2010.

Статус темы:
Закрыта.
  1. TopicStarter Overlay
    Iven
    Offline

    Iven

    Регистрация:
    11 авг 2010
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    Имеется отчет - оборот товара с возможностью выбора периода времени
    Выдает сегодня ошибку, указанную в теме, если указать дату формирования отчета по 10 или по 11(сегодняшнее) нынешнего месяца.

    Код:
    РассчитатьРегистрыНа(начДата);
    нс=0;
    СпрТ.ВыбратьЭлементы();
    Пока СпрТ.ПолучитьЭлемент() = 1 Цикл
    Если ВыбТовары.Принадлежит(СпрТ.ТекущийЭлемент())=1 Тогда 
    Если СпрТ.ЭтоГруппа()=1 Тогда
    продолжить;
    КонецЕсли;
    ост = Рег.СводныйОстаток(Константа.ОсновнаяФирма, Спрт.ТекущийЭлемент(), , "ОстатокТовара");                       
    нс=нс+1;
    ТЗ.НоваяСтрока(нс);
    ТЗ.УстановитьЗначение(нс,1,Спрт.ТекущийЭлемент());
    ТЗ.УстановитьЗначение(нс,2,ост); 
    ТЗ.УстановитьЗначение(нс,3,0);  
    ТЗ.УстановитьЗначение(нс,4,0);
    ТЗ.УстановитьЗначение(нс,5,0);  
    ТЗ.УстановитьЗначение(нс,6,СпрТ.Родитель);          
    //	Сообщить(СокрЛП(СпрТ.ТекущийЭлемент()) + "  " + ост);
    КонецЕсли;
    КонецЦикла;
    
    
    РассчитатьРегистрыПо(конДата);
    
    СпрТ.ВыбратьЭлементы();
    Пока СпрТ.ПолучитьЭлемент() = 1 Цикл
    Если ВыбТовары.Принадлежит(СпрТ.ТекущийЭлемент())=1 Тогда
    Если СпрТ.ЭтоГруппа()=1 Тогда
    продолжить;
    КонецЕсли;
    ост = Рег.СводныйОстаток(Константа.ОсновнаяФирма, Спрт.ТекущийЭлемент(), , "ОстатокТовара");                       
    нс=нс+1;
    ТЗ.НоваяСтрока(нс);
    ТЗ.УстановитьЗначение(нс,1,Спрт.ТекущийЭлемент());
    ТЗ.УстановитьЗначение(нс,2,0);  
    ТЗ.УстановитьЗначение(нс,3,0);
    ТЗ.УстановитьЗначение(нс,4,0); 
    ТЗ.УстановитьЗначение(нс,5,ост);
    ТЗ.УстановитьЗначение(нс,6,СпрТ.Родитель);          
    //	Сообщить(СокрЛП(СпрТ.ТекущийЭлемент()) + "  " + ост);
    КонецЕсли;
    КонецЦикла;
    
    
    К сожалению, с 1с только знакомлюсь.
    По сему прошу помочь и ответить как чайнику.
  2. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    А что там рассчитывать если их нет?

    Нужно ставить условие на проверку с ТА, и ТОЛЬКО при необходимости делать временный расчет.
  3. TopicStarter Overlay
    Iven
    Offline

    Iven

    Регистрация:
    11 авг 2010
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    а как на счет такого варианта
    и почему по ПолучитьДатуТА() выдает туже самую ошибку ? (похоже здесь уже с настройкой базы что-то ?)

    Код:
    Процедура Сформировать()  
    СпрТ = СоздатьОбъект("Справочник.Номенклатура");
    ДокР = СоздатьОБъект("Документ.РасходнаяНакладная"); 
    ДокП = СоздатьОБъект("Документ.ПриходнаяНакладная");
    ТЗ = СоздатьОБъект("ТаблицаЗначений");
    ТЗ.КоличествоКолонок(6); 
    Таб = СоздатьОБъект("Таблица");
    Рег = СоздатьОбъект("Регистр.ОстаткиТоваров");    
    Рег.ВременныйРасчет(1);  
    
    Если ПустоеЗначение(начДата) = 1 Тогда
    Предупреждение("НЕ указана дата начала отчета !", 30);
    Возврат;
    ИначеЕсли начДата > конДата Тогда
    Предупреждение("Дата начала отчета больше чем дата окончания !", 30);
    Возврат;
    ИначеЕсли конДата > ПолучитьДатуТА() Тогда
    конДата = ПолучитьДатуТА();
    КонецЕсли;
    
    РассчитатьРегистрыНа(начДата);
    нс=0;
    СпрТ.ВыбратьЭлементы();
    Пока СпрТ.ПолучитьЭлемент() = 1 Цикл
    Если ВыбТовары.Принадлежит(СпрТ.ТекущийЭлемент())=1 Тогда 
    Если СпрТ.ЭтоГруппа()=1 Тогда
    продолжить;
    КонецЕсли;
    ост = Рег.СводныйОстаток(Константа.ОсновнаяФирма, Спрт.ТекущийЭлемент(), , "ОстатокТовара");                       
    нс=нс+1;
    ТЗ.НоваяСтрока(нс);
    ТЗ.УстановитьЗначение(нс,1,Спрт.ТекущийЭлемент());
    ТЗ.УстановитьЗначение(нс,2,ост); 
    ТЗ.УстановитьЗначение(нс,3,0);  
    ТЗ.УстановитьЗначение(нс,4,0);
    ТЗ.УстановитьЗначение(нс,5,0);  
    ТЗ.УстановитьЗначение(нс,6,СпрТ.Родитель);          
    //	Сообщить(СокрЛП(СпрТ.ТекущийЭлемент()) + "  " + ост);
    КонецЕсли;
    КонецЦикла;
    
    
    РассчитатьРегистрыПо(конДата);
    
    СпрТ.ВыбратьЭлементы();
    Пока СпрТ.ПолучитьЭлемент() = 1 Цикл
    Если ВыбТовары.Принадлежит(СпрТ.ТекущийЭлемент())=1 Тогда
    Если СпрТ.ЭтоГруппа()=1 Тогда
    продолжить;
    КонецЕсли;
    ост = Рег.СводныйОстаток(Константа.ОсновнаяФирма, Спрт.ТекущийЭлемент(), , "ОстатокТовара");                       
    нс=нс+1;
    ТЗ.НоваяСтрока(нс);
    ТЗ.УстановитьЗначение(нс,1,Спрт.ТекущийЭлемент());
    ТЗ.УстановитьЗначение(нс,2,0);  
    ТЗ.УстановитьЗначение(нс,3,0);
    ТЗ.УстановитьЗначение(нс,4,0); 
    ТЗ.УстановитьЗначение(нс,5,ост);
    ТЗ.УстановитьЗначение(нс,6,СпрТ.Родитель);          
    //	Сообщить(СокрЛП(СпрТ.ТекущийЭлемент()) + "  " + ост);
    КонецЕсли;
    КонецЦикла; 
    
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Функция ПолучитьДатуТА() не может выдавать ошибку, т.к. она ПОЛУЧАЕТ а не УСТАНАВЛИВАЕТ дату ТА
  5. TopicStarter Overlay
    Iven
    Offline

    Iven

    Регистрация:
    11 авг 2010
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    а по сути вопроса ответа никто не знает ?

    дата функции получитьдатута, если вы не смотрели код, у нас присваивается конечной дате, так что получитьдатута, конечная дата и ныненшнее число в данной теме синонимы, выдающие ошибку - Не могу рассчитать временные итоги после ТА. (в базе та приравнивается нынешнему числу)
  6. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    почему никто не знает? Включай логику и следи за алгоритмом.

    Допустим
    ТА = 01.01.2010
    НачДата = 01.02.2010
    КонДата = 28.02.2010

    Смотрим условие
    пропускаем.... далее
    тоже ложное условие.... далее

    Действительно истина. Значит теперь
    КонДата = 01.01.2010

    Теперь переходим к расчету итогов.

    Теперь вопрос: КАК РАССЧИТАТЬ ИТОГИ НА 01.02.2010, ЕСЛИ ОНИ СУЩЕСТВУЮТ ТОЛЬКО ДО 01.01.2010????

    Поэтому убираем истерику типа "никто ничего не знает", и выбираем один из двух путей:
    1. Берем МНОГО книжек и усердно практикуемся
    2. Не жадничаем деньги и заказываем у специалистов

    PS Я, например, много знаю про зубы - где расположены, сколько штук и т.д. Но если начинают болеть, то иду к дантисту, а не лезу сам смотреть, и тем более не доверю это сантехнику

    PSS Надеюсь метафора понятна, и далее будет только конструктивный разговор.
  7. TopicStarter Overlay
    Iven
    Offline

    Iven

    Регистрация:
    11 авг 2010
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    лол истерик нет
    есть лишь похоже недопонимание

    оффтоп
    ах да, полагаю вы тоже не заканчивали универ с дипломом программиста 1с, а предположиетльно когда-то это дело начинали изучать саомстоятельно
    да и не делайте снова ошибочных предположений будто я только что выпустившийся студент, а то с вас станется, и снова занесет в какие-то фантазии про книжи, специалистов и тп, вопрос вроде бы не касался темы смысла жизни и вообще чего, как в автостопе по галактике
    это на счет лирики

    а теперь по теме я постараюсь на пальцах объяснить конструктивно мой вопрос (да и не стоит снова разводить оффтоп, если вдруг кому покажутся эти пальци расстопыренными, как у новых русских, это всеголишь метафора)

    никто не считает несуществующий оборот за завтра

    смотрим на часики - опа, 13 число, обед
    что же, та, судя логически, должна равняться этой дате(не знаю учитывает ли она время)
    что же посмотрим-ка какой у нас оборот был с утра
    так-с в окошке конечной даты стоит 13 число
    нажимаем кнопочку рассчитать
    опаньки - ошибка Не могу рассчитать временные итоги после ТА!
    ой, господи, что ж за дата то такая, верно проклятое 13 число всю систему барыжит

    надеюсь доступно описал проблему
    и хотелось бы услышать конструктивный ответ - с чем может быть связанна даная проблема - настройки 1с ? какие ? найстройки базы ? какие ? неправильній код отчета ? как правильно ? тєто не ошибка, а так должно быть ? (тогда почему, как утверждают, раньше работало нормально)
  8. TopicStarter Overlay
    Iven
    Offline

    Iven

    Регистрация:
    11 авг 2010
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    да, и мне кажеться, суть проблемы можна было бы понять просто взгялнув на код

    ИначеЕсли конДата > ПолучитьДатуТА() Тогда
    конДата = ПолучитьДатуТА();

    и зная, что при его наличии выдает ошибку указанную в названии темы
    это о птичках

    может я просто не понял сути ответов ? тогда просьба ответить на уровне плинтуса
  9. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Или посмотрите отладчиком или добавьте Сообщить("!!!"); в условие чтобы убедиться что срабатывает. Да просто поставьте
    Код:
    РассчитатьРегистрыНа(ПолучитьДатуТА());
    
    
    и убедитесь что метод РАБОТАЕТ. М.б. в условии вы совершили орфографическиую ошибку и у вас присваивается не той переменной?
  10. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    ОШИБКА В КОДЕ.

    Выше, я уже "носом ткнул" где именно.

    Если код останется темже, и не будет переписан по указанным моментам - тему можно закрывать.
  11. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
  12. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    Просто ваш логический вывод неверен. Если сегодня 13/08/10г, то далеко не факт что ТА, тоже стоит на 13/08/10г., она может быть хоть 01/01/07.
  13. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    Хотя здесь конечно я не совсем прав. Такое будет возможно только если вручную установить ТА на прошлую дату. Скорее возможна ситуация, когда она будет в будующем времени.
  14. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Если ТА в будущем, то ошибки расчета временных итогов не будет.
    А в прошлом - легко. Начиная с ситуаций, когда было выполнено неудачное восстановление последовательности (ТА установлено на момент восстановления), заканчивая, тупо, отсутствием документов за последние дни.
  15. TopicStarter Overlay
    Iven
    Offline

    Iven

    Регистрация:
    11 авг 2010
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    кхм, условия работают, орфографических ошибок нет

    что значит убедится что метод работает ? я сюда и пришел чтобы спросить почему код не работает с указанием конечной точки расчета равной нынешнему числу

    дату ПолучитьДатуТА() я наблюдаю в управлении операционных итогов и она равна сегодняшнему числу (о птичках - может надо перед созданием отчета делать какой-то перерасчет каких-то операций в базе чтобы она видела изменения за сегодня или еще что-то)

    также я наблюдаю изменение конечной даты в окне отчета при его срабатывании и выводе ошибки та
    при указании даты превышающей та - любая дата выше та автоматически меняется на нынешнее число

    WaRDeR
    я чего то не понимаю с вашими условиями
    (хотя все эти условия вообще-то никакого отношения к проблеме невозможности отобразить оборот за дату равную ТА не имеют)

    Если ПустоеЗначение(начДата) = 1 Тогда
    Предупреждение("НЕ указана дата начала отчета !", 30);
    Возврат;
    ИначеЕсли начДата > конДата Тогда
    Предупреждение("Дата начала отчета больше чем дата окончания !", 30);
    Возврат;
    ИначеЕсли конДата > ПолучитьДатуТА() Тогда
    конДата = ПолучитьДатуТА();
    КонецЕсли;


    Допустим

    ТА = 13.08.2010
    НачДата = 01.08.2010
    КонДата = 13.08.2010 ( или даже 14.08 и выше - условие работает и это не играет роли)

    Смотрим условие
    Цитата
    Если ПустоеЗначение(начДата) = 1 Тогда
    пропускаем.... далее
    Цитата
    ИначеЕсли начДата > конДата Тогда
    тоже ложное условие.... далее

    Цитата
    ИначеЕсли конДата > ПолучитьДатуТА() Тогда
    Действительно истина. Значит теперь
    КонДата = 13.08.2010

    Теперь переходим к расчету итогов.

    Цитата
    Код:
    	РассчитатьРегистрыНа(начДата);
    нс=0;
    СпрТ.ВыбратьЭлементы();
    Пока СпрТ.ПолучитьЭлемент() = 1 Цикл
    Если ВыбТовары.Принадлежит(СпрТ.ТекущийЭлемент())=1 Тогда 
    Если СпрТ.ЭтоГруппа()=1 Тогда
    продолжить;
    КонецЕсли;
    ост = Рег.СводныйОстаток(Константа.ОсновнаяФирма, Спрт.ТекущийЭлемент(), , "ОстатокТовара");                       
    нс=нс+1;
    ТЗ.НоваяСтрока(нс);
    ТЗ.УстановитьЗначение(нс,1,Спрт.ТекущийЭлемент());
    ТЗ.УстановитьЗначение(нс,2,ост); 
    ТЗ.УстановитьЗначение(нс,3,0);  
    ТЗ.УстановитьЗначение(нс,4,0);
    ТЗ.УстановитьЗначение(нс,5,0);  
    ТЗ.УстановитьЗначение(нс,6,СпрТ.Родитель);          
    //	Сообщить(СокрЛП(СпрТ.ТекущийЭлемент()) + "  " + ост);
    КонецЕсли;
    КонецЦикла;
    
    
    РассчитатьРегистрыПо(конДата);
    
    СпрТ.ВыбратьЭлементы();
    Пока СпрТ.ПолучитьЭлемент() = 1 Цикл
    Если ВыбТовары.Принадлежит(СпрТ.ТекущийЭлемент())=1 Тогда
    Если СпрТ.ЭтоГруппа()=1 Тогда
    продолжить;
    КонецЕсли;
    ост = Рег.СводныйОстаток(Константа.ОсновнаяФирма, Спрт.ТекущийЭлемент(), , "ОстатокТовара");                       
    нс=нс+1;
    ТЗ.НоваяСтрока(нс);
    ТЗ.УстановитьЗначение(нс,1,Спрт.ТекущийЭлемент());
    ТЗ.УстановитьЗначение(нс,2,0);  
    ТЗ.УстановитьЗначение(нс,3,0);
    ТЗ.УстановитьЗначение(нс,4,0); 
    ТЗ.УстановитьЗначение(нс,5,ост);
    ТЗ.УстановитьЗначение(нс,6,СпрТ.Родитель);          
    //	Сообщить(СокрЛП(СпрТ.ТекущийЭлемент()) + "  " + ост);
    КонецЕсли;
    КонецЦикла;
    
    
    
    ДокР.ВЫбратьДокументы(начДата, КонДата);
    Пока ДокР.ПолучитьДокумент()=1 Цикл
    Если ДокР.Проведен()=0 Тогда
    Продолжить;
    КонецЕсли;
    Если ВыбКлиент.Принадлежит(ДокР.Клиент)=1 Тогда
    Продолжить;
    КонецЕсли;     
    ДокР.ВЫбратьСтроки();
    Пока ДокР.ПолучитьСтроку()=1 Цикл
    Если ВыбТовары.Принадлежит(ДокР.Товар)=0 Тогда
    Продолжить;
    КонецЕсли; 
    нс=нс+1;
    ТЗ.НоваяСтрока(нс);
    ТЗ.УстановитьЗначение(нс,1,ДокР.Товар);
    ТЗ.УстановитьЗначение(нс,2,0);  
    ТЗ.УстановитьЗначение(нс,3,0);
    ТЗ.УстановитьЗначение(нс,5,0); 
    ТЗ.УстановитьЗначение(нс,4,ДокР.Количество*ДокР.Коэффициент);                                
    ТЗ.УстановитьЗначение(нс,6,ДокР.Товар.Родитель);          
    
    КонецЦикла;
    
    
    Теперь вопрос: КАК РАССЧИТАТЬ ИТОГИ НА 13.08.2010, ЕСЛИ ОНИ СУЩЕСТВУЮТ в базе ТОЛЬКО ДО 13.08.2010????
  16. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Без переноса ТА на 13.08.2010 НИКАК. Похоже вы вообще не понимате принцип. Да и зачем считать на 13е когда документы допустим за 10е... В период с 10 по 13 их просто НЕТ
  17. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Проблема вот где - если я скажу, что строку
    Код:
    РассчитатьРегистрыНа(начДата);
    
    надо заменить на
    Код:
    Если начДата < ПолучтиьДатуТА() Тогда
    РассчитатьРегистрыНа(начДата);
    КонецЕсли;
    
    
    (о чем было сказано в моем первом посте), то дальше начнуться совсем тупые вопросы: А ПОЧЕМУ ОНО РАБОТАЕТ НЕПРАВИЛЬНО (об этом тоже уже было сказано).

    Думаю проще - рассказать, что в комплекте 1С есть такой инструмент ОТЛАДЧИК.

    Уважаемый, Iven. Предлагаю воспользоваться отладчиком, пройти алгоритм по шагам, посмотреть значения всех встречающихся переменных.

    Ну и тему пока не буду закрывать, если действительно есть желание разобраться.
  18. TopicStarter Overlay
    Iven
    Offline

    Iven

    Регистрация:
    11 авг 2010
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    действительно я не понимаю, как я уже упоминал в первом посте 1с, может быть вы тогда объясните
    да можно перекрутить та в управлении итогами на завтрашнее число и тогда оно увидит сегодняшнее, но так как я не знаю к чему приведет такой перевод даты во всей базе, то пытаюсь понять почему не срабатывает отчет по сегодняшнее число

    и я не спрашивал надо ли мне считать за 13, надо, потому что за эту дату, пуская пару часов или минут назад вносилась информация, по которой можно сформировать отчет

    почему вы так решили?

    WaRDeR
    господи, чтож вы прицепились к этому условию

    ну а если я заменю

    Если ПустоеЗначение(начДата) = 1 Тогда
    Предупреждение("НЕ указана дата начала отчета !", 30);
    Возврат;
    ИначеЕсли начДата > конДата Тогда
    Предупреждение("Дата начала отчета больше чем дата окончания !", 30);
    Возврат;
    ИначеЕсли конДата > ПолучитьДатуТА() Тогда
    конДата = ПолучитьДатуТА();
    КонецЕсли;

    на

    Если ПустоеЗначение(начДата) = 1 Тогда
    Предупреждение("НЕ указана дата начала отчета !", 30);
    Возврат;
    ИначеЕсли начДата > конДата Тогда
    Предупреждение("Дата начала отчета больше чем дата окончания !", 30);
    Возврат;
    ИначеЕсли начДата > ПолучитьДатуТА() Тогда
    Предупреждение("Дата начала отчета еще не настала !", 30);
    Возврат;
    ИначеЕсли конДата > ПолучитьДатуТА() Тогда
    конДата = ПолучитьДатуТА();
    КонецЕсли;

    это вас устроит надеюсь

    объясните пожалуйста что такое ПолучитьДатуТА() и почему нельзя обрабатывать информацию внесенную в базу датой равной ПолучитьДатуТА()
  19. TopicStarter Overlay
    Iven
    Offline

    Iven

    Регистрация:
    11 авг 2010
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    мда,
    значит отвечаю сам себе - в управлении итогами я не заметил такую вещь как время - 00:00
    тоесть действительно при указанной дате 13 число но времени 00 ошибка вполне логична

    вопрос - на что повлияет в базе изменение даты в управлении итогами на завтрашнее число ? будет ли меть какие то негативные последствия ? можно ли изменить не дату, а время, к примеру, на 23:00 (изменение времени в окне итогов не доступно)
  20. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Потому что именно это ключевой момент вашей "логической" ошибки

    Чесно говоря, мне все равно, оно вас устроить должно.

    Для этого надо почитать книжку, там буквально на 2х страницах подробно описано, что это такое.
    Тут приводить их смысла нет.

    Если в двух словах: ТА - это тот момент времени (сказал бы даже мгновение, потому что идет с большей точностью, чем до секунды), на который имеются остатки (для предприятия - это актуальный баланс ресурсов). Значение ТА можно узнать в строке состояния 1С (снизу справа).
    ПолучитьДатуТА() - это дата, в которую попадает этот момент.
    Расчет временных итогов, это узнать баланс ресурсов предприятия в какой-то уже прошедший момент.

    От сюда делаем вывод - расчитать можно только итоги в прошлом.

    Выполнять расчет на дату ТА - найти остатки на НАЧАЛО дня (т.е. не текущие, а уже в прошлом).

    Расчет ПО дату ТА - по сути это текущие остатки, но ошибку не выдаст, просто нет смысла выполнять такой расчет.

    Поэтому, еще раз перечитай всю ветку, но вдумчиво.
    Потом воспользуйся советом подключить к работе ОТЛАДЧИК (по сути им можно увидеть все ошибки логики алгоритма с точностью до команды).

    Если обращаешься за советом, то воспользуйся им. Больше сказать нечего.....

    ps пля, кратко не получилось. За сим откланяюсь.
Статус темы:
Закрыта.

Поделиться этой страницей