8.х Не могу получить верную кодировку через HTTPОтвет.ПолучитьТелоКакСтроку

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем DmitryV, 30 сен 2014.

  1. TopicStarter Overlay
    DmitryV
    Offline

    DmitryV

    Регистрация:
    17 апр 2011
    Сообщения:
    48
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте, собственно проблема в заголовке темы, когда вызываю метод результат получается в иероглифах, на сайте кодировка UTF-8, я уже все перепробывал.
    Буду признателен за любые советы.

    Код:
    Процедура Выполнить()
    Соединение = Новый HTTPСоединение (АдресСайта);
      
        ДокументHTML = ВыполнитьHTTPЗапрос("/catalog/vannaya_komnata/", ЗаголовкиЗапроса);
    
    КонецПроцедуры
    
    
    //Возвращает ДокументHTML
    Функция ВыполнитьHTTPЗапрос(АдресНазначения, ЗаголовкиДляЗапроса)
      
        Запрос = Новый HTTPЗапрос (АдресНазначения, ЗаголовкиДляЗапроса);
        Ответ = Соединение.Получить(Запрос);
        Если Ответ.КодСостояния <> 200 Тогда
            Сообщить("Получен ответ с кодом "+Ответ.КодСостояния+" по адресу: "+АдресНазначения, СтатусСообщения.Важное);
            Возврат Неопределено;
        КонецЕсли;
        СтрокаХТМЛ = Ответ.ПолучитьТелоКакСтроку(КодировкаТекста.UTF8);
      
        ЧтениеHTML = Новый ЧтениеHTML;
        ЧтениеHTML.УстановитьСтроку(СтрокаХТМЛ);
        ПостроительDOM = Новый ПостроительDOM;
        ДокументHTML = ПостроительDOM.Прочитать(ЧтениеHTML);
                          
        Возврат ДокументHTML;
      
    КонецФункции
    
    P.S. адрес сайта decorТИРЕp.ru
  2. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.581
    Симпатии:
    717
    Баллы:
    204
    Сдается мне, что какой-то косяк в конструкции:

    Код:
    ЧтениеHTML = Новый ЧтениеHTML;
    ЧтениеHTML.УстановитьСтроку(СтрокаХТМЛ);
    ПостроительDOM = Новый ПостроительDOM;
    ДокументHTML = ПостроительDOM.Прочитать(ЧтениеHTML);
    ибо сам ответ от сервера в нужной кодировке:
    Безымянный.png
  3. TopicStarter Overlay
    DmitryV
    Offline

    DmitryV

    Регистрация:
    17 апр 2011
    Сообщения:
    48
    Симпатии:
    0
    Баллы:
    1
    у меня не так, ответ в иероглифах, попробую платформу обновить...
  4. TopicStarter Overlay
    DmitryV
    Offline

    DmitryV

    Регистрация:
    17 апр 2011
    Сообщения:
    48
    Симпатии:
    0
    Баллы:
    1
    можете скинуть обработку, которая на скиншоте? Не могу понять где моя ошибка, ответ в нормальном виде не приходит
  5. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.581
    Симпатии:
    717
    Баллы:
    204
    Сделайте новую обработку и вставьте тот код, который указали сами в начале темы..
    Я ничего нового не придумывал.

    Сдается мне, что у вас прокси чудит, либо еще чего с кодировкой происходит по пути от удаленного сервера до вашей машины.
    DmitryV нравится это.
  6. TopicStarter Overlay
    DmitryV
    Offline

    DmitryV

    Регистрация:
    17 апр 2011
    Сообщения:
    48
    Симпатии:
    0
    Баллы:
    1
    Причина была в заголовках, не знаю почему. Смотрел какие firefox отправляет, ставил такие же и приходили иероглифы, хотя недавно другой сайт парсил и писал тоже самое и было ОК.
    Оставил в заголовках только Connection и Host, пришел нормальный ответ.

Поделиться этой страницей