8.х Не могу подключить макет к форме документа!Помогите!

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем Lily_1C, 6 сен 2011.

  1. TopicStarter Overlay
    Lily_1C
    Offline

    Lily_1C Опытный в 1С

    Регистрация:
    25 окт 2010
    Сообщения:
    152
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте еще раз!
    Макет,о котором я писала в прошлой теме, теперь нужно подключить к форме документа. Пробую разными способами,пока не получается,к сожалению..Подскажите,пожалуйста,в общих словах!
    (чтобы при нажатии на кнопку ПечатьДополнительно,выходил опред.макет.бз всяких условий)
    Раньше я делала подобные вещи,просто добавляла макет в деревоМакетов док-та,а потом по аналогии с др.документами,подключала его.
    Здесь же не могу сообразить,т.к. нужный мне документ был создан др.программистами с усложненным выводом на печать. :angry: Поэтому я и хочу вывести одну дополнительную кнопку,которая ы формировала Дополнительный макет.
    Подскажите,пожалуйста! Очень была бы благодарна!!!
  2. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.771
    Симпатии:
    509
    Баллы:
    204
    Т.е. вы хотите добавить ваш отчет в список печатных форм документа?
  3. 1cUserAndrew
    Offline

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.948
    Симпатии:
    149
    Баллы:
    104
    У Вас ведь есть код, который формирует печатную форму???
    Вот, надо, чтобы этот код располагался в процедуре-обработчике события нажатия на дополнительную кнопку (или вызывался из этой процедуры).

    Это тоже вариант :)
  4. TopicStarter Overlay
    Lily_1C
    Offline

    Lily_1C Опытный в 1С

    Регистрация:
    25 окт 2010
    Сообщения:
    152
    Симпатии:
    0
    Баллы:
    26
    Да,у меня есть функция(экспортная),которая формирует макет,она возвращает пар-р ТабДокумент,а входящим пар-ром является ИмяМакета. В обработчике события нажатия кнопки я обр-сь к этой функции,но программа ругается на имя макета,не распознает его..что можно сдеать?посоветуйте,пож-та :angry:


    свой макет я добавила в список макетов док-та
  5. 1cUserAndrew
    Offline

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.948
    Симпатии:
    149
    Баллы:
    104
    Присвойте параметру значение по умолчанию. Т.е.
    Код:
    Функция Моя(ИмяМакета = "Счет")
    
    
    "Счет" - это я для примера. Какие у Вас варианты, не знаю...Посмотрите ниже по коду.
  6. TopicStarter Overlay
    Lily_1C
    Offline

    Lily_1C Опытный в 1С

    Регистрация:
    25 окт 2010
    Сообщения:
    152
    Симпатии:
    0
    Баллы:
    26
    не получается:(
  7. 1cUserAndrew
    Offline

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.948
    Симпатии:
    149
    Баллы:
    104
    Что именно?
    По-прежнему на "ИмяМакета" ругается??
    Приведите фрагмент кода, где встречается "ИмяМакета".
    И ошибку, которую выдает программа.

    +

    Эта функция у Вас возвращает табличный документ, так?
    Из процедуры-обработчика нажатия на кнопку вы эту функцию вызываете?
    Должно быть типа такого:
    Код:
    Функция МояФункция(ИмяМакета = "Счет")
    .....
    Возврат ТабДокумент;
    КонецФункции
    
    
    Процедура ДополнительнаяКнопкаНажатие()
    ТабДокумент = МояФункция();
    ТабДокумент.Показать();
    КонецПроцедуры
    
    
    
    
    
  8. TopicStarter Overlay
    Lily_1C
    Offline

    Lily_1C Опытный в 1С

    Регистрация:
    25 окт 2010
    Сообщения:
    152
    Симпатии:
    0
    Баллы:
    26
    Извините,что поздно отвечаю..но может еще получится получить помощь :angry:
    Код:
    Процедура ОсновныеДействияФормыДополнительный(Кнопка)
    
    ТабДокумент = уатПечать_Дополнительный(ИмяМакета="Дополнительный");
    ТабДокумент.Показать();
    
    КонецПроцедуры  
    
    //в модуле объекта
    
    Функция уатПечать_Дополнительный(ИмяМакета="Дополнительный")Экспорт
    
    Перем мВодительскоеУдСерия, мВодительскоеУдНомер, мВодительскоеУдКатегория;	
    
    мМаксСтрок = 18;
    
    ТабДокумент = Новый ТабличныйДокумент;
    ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ПутевойЛист_ПутевойЛист";
    
    Макет = ПолучитьМакет(ИмяМакета);
    
    // и т.д. и т.п.
    
    ТабДокумент.Вывести(Обл);  			
    
    Возврат ТабДокумент;
    
    
    КонецФункции 
    
    

    Вложения:

    • 111.JPG
      111.JPG
      Размер файла:
      104,6 КБ
      Просмотров:
      56
  9. mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.398
    Симпатии:
    40
    Баллы:
    54
    Здраствуйте!
    Проверьте, имя макета который Вы добавили должно быть "Дополнительный", тогда все должен находить
  10. 1cUserAndrew
    Offline

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.948
    Симпатии:
    149
    Баллы:
    104
    Мне кажется, что вот здесь:
    Код:
    ТабДокумент = уатПечать_Дополнительный(ИмяМакета="Дополнительный");
    
    ИмяМакета="Дополнительный" - лишнее.
    Надо просто:
    Код:
    ТабДокумент = уатПечать_Дополнительный();
    
    А вот тут:
    Код:
    Функция уатПечать_Дополнительный(ИмяМакета="Дополнительный")Экспорт
    
    да, все правильно, это надо.
  11. TopicStarter Overlay
    Lily_1C
    Offline

    Lily_1C Опытный в 1С

    Регистрация:
    25 окт 2010
    Сообщения:
    152
    Симпатии:
    0
    Баллы:
    26
    Имя макета Дополнительный :angry:
  12. 1cUserAndrew
    Offline

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.948
    Симпатии:
    149
    Баллы:
    104
    Lily_1C, какую ошибку-то программа выдает????
    Дословно приведите.
  13. TopicStarter Overlay
    Lily_1C
    Offline

    Lily_1C Опытный в 1С

    Регистрация:
    25 окт 2010
    Сообщения:
    152
    Симпатии:
    0
    Баллы:
    26
    {Документ.уатПутевойЛист.Форма.ФормаДокумента(3019,41)}: Переменная не определена (ИмяМакета)
    ТабДокумент = уатПечать_Дополнительный(<<?>>ИмяМакета="Дополнительный"); (Проверка: Толстый клиент (обычное приложение))
  14. 1cUserAndrew
    Offline

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.948
    Симпатии:
    149
    Баллы:
    104
    Вот я Вам и говорил об этом в предыдущем сообщении...:)))
    В данном фрагменте кода вот это: ИмяМакета="Дополнительный" не нужно. Уберите.
  15. TopicStarter Overlay
    Lily_1C
    Offline

    Lily_1C Опытный в 1С

    Регистрация:
    25 окт 2010
    Сообщения:
    152
    Симпатии:
    0
    Баллы:
    26
    {Документ.уатПутевойЛист.Форма.ФормаДокумента(3019,41)}: Переменная не определена (ИмяМакета)
    ТабДокумент = уатПечать_Дополнительный(<<?>>ИмяМакета); (Проверка: Толстый клиент (обычное приложение))
    Хрень какая-то!:(((
  16. 1cUserAndrew
    Offline

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.948
    Симпатии:
    149
    Баллы:
    104
    "ИмяМакета" тоже уберите....
    Просто оставьте:
    Код:
    ТабДокумент = уатПечать_Дополнительный();
    
  17. TopicStarter Overlay
    Lily_1C
    Offline

    Lily_1C Опытный в 1С

    Регистрация:
    25 окт 2010
    Сообщения:
    152
    Симпатии:
    0
    Баллы:
    26
    Получилось!Спасибо большое! :angry: :D

Поделиться этой страницей