7.7 Не могу найти текст метода "Сменить период" объекта Журналы.Расчет Зарплаты

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Hexfrog, 1 сен 2008.

  1. TopicStarter Overlay
    Hexfrog
    Offline

    Hexfrog

    Регистрация:
    9 фев 2007
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Извините, если ступил, но сам разобраться не могу.

    1С: Предприятие 7.7 ЗиК

    Появилась необходимость отредактировать в конфигураторе действия выполняемые при смене периода расчета зарплаты (изменение пустячное - добавить в очередь на отправку во внешнюю систему сигнал о том, что действие таковое произошло).

    Открываю конфигуратор, в нем смотрю пункты меню, и вижу, что "Регламенты - Сменить период расчета зарплаты" - ссылается на команду "Журналы Расчетов.Зарплата.Сменить период". Открываю объект "Журналы расчетов.Зарплата" и не могу найти где же исходники вообще хоть чего-нибудь, в частности и этого метода.
    Единственное что хоть как-то говорит о смене текущего периода - это функция в глобальном модуле:

    Код:
    Функция глСменитьПериод(ДатаАктуальности,Направление=0) Экспорт
    ЖР = СоздатьОбъект("ЖурналРасчетов.Зарплата");
    Если ТипЗначения(ДатаАктуальности)<>3 Тогда
    ДатаАктуальности = ЖР.КонецТекущегоПериода()
    КонецЕсли;
    Если Направление=1 Тогда
    ДатаАктуальности = ЖР.КонецПериодаПоДате(ЖР.КонецПериодаПоДате(ДатаАктуальности)+1)
    ИначеЕсли Направление=-1 Тогда
    ДатаАктуальности = ЖР.НачалоПериодаПоДате(ДатаАктуальности)-1
    КонецЕсли;
    Возврат ЖР.ОписательПериода(ДатаАктуальности)
    КонецФункции
    
    
    Но остатки здравого смысла подсказывают мне, что это что-то совсем не то...
    Где же то?
  2. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Процедура ПриСменеРасчетногоПериода(<?>,)
    КонецПроцедуры
    Синтаксис:
    ПриСменеРасчетногоПериода(<ЖурналРасчетов>,<Период>)
    Назначение:
    Предопределенная процедура, вызываемая при смене текущего расчетного периода журнала расчетов.
    Параметры:
    <ЖурналРасчетов> - журнал расчетов, период которого изменяется (агрегатный объект типа ''ЖурналРасчетов'').
    <Период> - устанавливаемый расчетный период (значение типа ''ПериодРасчета'').
    Замечание:
    Данная процедура может располагаться в глобальном программном модуле.
    Подробнее см. в документации, глава 'Системные предопределенные процедуры'

Поделиться этой страницей