8.х Не могу найти обработку commerceML на УТ 11.1

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Dragomaster, 10 мар 2014.

  1. TopicStarter Overlay
    Dragomaster
    Offline

    Dragomaster

    Регистрация:
    17 янв 2014
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Всем привет! Подскажите, где ее найти или если ее нет - поделитесь, пожалуйста.
  2. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.978
    Симпатии:
    397
    Баллы:
    104
  3. jonsony
    Offline

    jonsony Опытный в 1С Заблокирован

    Регистрация:
    16 апр 2009
    Сообщения:
    224
    Симпатии:
    25
    Баллы:
    29
    оно там вроде встроенное же?
    вот кусок кода из общего модуля "ЭлектронныеДокументыВнутренний"
    Код:
            ОбъектXML.ОткрытьФайл(ПолноеИмяФайла);
            ЭД_XML = ФабрикаXDTO.ПрочитатьXML(ОбъектXML);
            НаборДанных = Неопределено;
            ЕстьСвойствоИдФайл = ЭД_XML.Свойства().Получить("ИдФайл") <> Неопределено;
           
            Если ЭД_XML.Тип() = ПолучитьТипЗначенияCML("ПрайсЛист", "4.02") Тогда
                НаборДанных = ЭД_XML["Предложения"].Предложение;
                СформироватьТЗПоНаборуДанныхXDTO(ТаблицаВозврата, НаборДанных, ЭД, ОбъектXML,,,,, ИменаДопКолонок);
            ИначеЕсли ЭД_XML.Тип() = ПолучитьТипЗначенияCML("КоммерческаяИнформация", "urn:1C.ru:commerceml_2") Тогда
                Если ТипЗнч(ЭД_XML.Каталог) = Тип("ОбъектXDTO") Тогда
                    НаборДанных = ЭД_XML.Каталог["Товары"].Товар;
                ИначеЕсли ТипЗнч(ЭД_XML.Документ) = Тип("СписокXDTO") И (ЭД_XML.Документ.Количество() > 0) Тогда
                    НаборДанных = ЭД_XML.Документ[0]["Товары"].Товар;
                ИначеЕсли ТипЗнч(ЭД_XML.ПакетПредложений) = Тип("ОбъектXDTO")
                    И ТипЗнч(ЭД_XML.ПакетПредложений.Предложения) = Тип("ОбъектXDTO")
                    И ТипЗнч(ЭД_XML.ПакетПредложений.Предложения.Предложение) = Тип("СписокXDTO")
                    И ЭД_XML.ПакетПредложений.Предложения.Предложение.Количество() > 0 Тогда
                   
                    НаборДанных = ЭД_XML.ПакетПредложений.Предложения.Предложение;
                   
                КонецЕсли;
                СформироватьТЗПоНаборуДанныхXDTO(ТаблицаВозврата, НаборДанных, ЭД, ОбъектXML,,,,, ИменаДопКолонок);
            ИначеЕсли ЭД_XML.Тип() = ПолучитьТипЗначенияCML("Каталог", "4.02")
                    ИЛИ ЭД_XML.Тип() = ПолучитьТипЗначенияCML("АктОПриемке", "4.02")
                    ИЛИ ЭД_XML.Тип() = ПолучитьТипЗначенияCML("ТОРГ12", "4.02")
                    ИЛИ ЭД_XML.Тип() = ПолучитьТипЗначенияCML("СчетНаОплату", "4.02")
                    ИЛИ ЭД_XML.Тип() = ПолучитьТипЗначенияCML("ОтчетОСписанииКомиссионногоТовара", "4.02")
                    ИЛИ ЭД_XML.Тип() = ПолучитьТипЗначенияCML("ОтчетОПродажахКомиссионногоТовара", "4.02")
                    ИЛИ ЭД_XML.Тип() = ПолучитьТипЗначенияCML("ЗаказКлиента", "4.02") Тогда
                Если ЭД_XML["Товары"] <> Неопределено Тогда
                    НаборДанных = ЭД_XML["Товары"].Товар;
                    СформироватьТЗПоНаборуДанныхXDTO(ТаблицаВозврата, НаборДанных, ЭД, ОбъектXML, , , , , ИменаДопКолонок);
                КонецЕсли;
            ИначеЕсли ЕстьСвойствоИдФайл Тогда
                // Обрабатываем случай когда к нам пришел сторонний XML файл.
                Если НЕ ЗначениеЗаполнено(ОбъектXML.URIПространстваИмен) Тогда
           
                    // Вставляем во временный файл ЭД пространство имен 1С.
                    ДобавитьПространствоИмен1СВоВнешнийФайлЭД(ОбъектXML, ЭД_XML, ПолноеИмяФайла);
                КонецЕсли;
    

Поделиться этой страницей