7.7 Не могу доделать обработку выгрузки из excel

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем Korj, 6 апр 2014.

  1. TopicStarter Overlay
    Korj
    Offline

    Korj

    Регистрация:
    3 апр 2014
    Сообщения:
    6
    Симпатии:
    1
    Баллы:
    1
    Здравствуйте, помогите пожалуйста с обработкой 1С 7.7
    По плану должна создаваться реализация на основе документа Excel. На сегодняшний момент документ создается, со списком товаров, проставлена дата документа, но не заполнены реквизиты шапки, не указан Тип Цены, % боя, тип склада, безндс.
    Код:
    Перем Док, Окно, Область, СписПарам, СписРугПодр;
    //******************************************************************************
    Процедура ВыбФайл()
       ФС.ВыбратьФайл(0,ИмяФайла,Строка(ФС.ТекКаталог()),"Выбор файла для вывода","*.xls","xls",);
       Окно = СоздатьОбъект("Excel.Application");
      Если ИмяФайла <> "" Тогда
        Книга = Окно.WorkBooks.Open(ФС.ТекКаталог()+"\"+ИмяФайла);
         Путь = Строка(ФС.ТекКаталог());
         //Окно.Visible = 1;
       КонецЕсли; 
    КонецПроцедуры
    //******************************************************************************
    Процедура ВыбКаталог()
       Если Путь = "" Тогда
         Путь = Строка(ФС.ТекКаталог());
       КонецЕсли;
       ФС.ВыбратьКаталог(Путь, "Выбор каталога для выбора файла");
    КонецПроцедуры
    //******************************************************************************
    Процедура Загрузить()
    
       Если ПустоеЗначение(ИмяФайла) = 1 Тогда
         Предупреждение("Не выбран файл-заказ для загрузки!");
         СтатусВозврата(0);
         Возврат;
       КонецЕсли;
     
       Окно = СоздатьОбъект("Excel.Application");
      Если ИмяФайла <> "" Тогда
        Книга = Окно.WorkBooks.Open(ФС.ТекКаталог() + "\" + ИмяФайла);
         //Окно.Visible = 1;
       КонецЕсли;
     
       чКоличествоСтрок = 0;
       Область = Окно.Sheets.Item(1); 
       чКоличествоСтрок = Область.UsedRange.Rows.Count();
     
       Товары = СоздатьОбъект("Справочник.Номенклатура");
     
       НомерЗаявки = "";
       НомерЗаявки = СокрЛП(Область.Cells(2, 4).Value);
       Если ПустоеЗначение(НомерЗаявки) = 0 Тогда
         НомерЗаявки = СокрЛП(СтрЗаменить(НомерЗаявки, "Заказ поставщику №", ""));
         НомерЗаявки = СокрЛП(Лев(НомерЗаявки, 11));
       КонецЕсли; 
     
       //ПН = СоздатьОбъект("Документ.РасходнаяНакладная");
       ПН = СоздатьОбъект("Документ.Реализация");
       ПН.Новый();
       ПН.ДатаДок      = ТекущаяДата();
       //ПН.Валюта=Спр.НайтиПоНаименованию("руб.");
       //ПН.НАЙТИДОКУМЕНТ(ТекДок1);
        ПН.Комментарий  = НомерЗаявки;
       //ПН.ВидОтгрузки  = 11; 
       //ПН.НДСвключатьВСтоимость = 1;
       //ПН.Записать();
     
       НачатьТранзакцию();
       Для Стр = 7 По чКоличествоСтрок Цикл
     
         АртТовара = "";
         НаимТов    = "";
         ШтрихКод  = "";
         Кол      = 0;
       
         АртТовара = СокрЛП(Область.Cells(Стр, 8).Value);
         НаимТов  = СокрЛП(Область.Cells(Стр, 9).Value);
         ШтрихКод  = СокрЛП(Область.Cells(Стр, 10).Value);
         Кол      = Число(Область.Cells(Стр, 7).Value);
    
         Если ПустоеЗначение(АртТовара) = 1 Тогда
           Сообщить("Не указан артикул товара " + НаимТов + " " + ШтрихКод, "!!"); 
           Продолжить;
         КонецЕсли;
       
         Если Товары.НайтиПоКоду(АртТовара,0) = 0 Тогда
           Сообщить("Не найден товар с артикулом " + АртТовара + " " + НаимТов + " " + ШтрихКод, "!"); 
           Продолжить;
         КонецЕсли;
       
         ПН.НоваяСтрока();
         //ПН.Товар     = Товары.ТекущийЭлемент();
         ПН.Номенклатура     = Товары.ТекущийЭлемент();
         ПН.Количество    = Кол; 
         ПН.Записать();
       КонецЦикла;
       ЗафиксироватьТранзакцию();
     
       ОткрытьФорму(ПН.ТекущийДокумент());
    
    КонецПроцедуры
    
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    какая конфигурация, тис?
  3. TopicStarter Overlay
    Korj
    Offline

    Korj

    Регистрация:
    3 апр 2014
    Сообщения:
    6
    Симпатии:
    1
    Баллы:
    1
    Комплексная конфигурация (Бухгалтерия+ТиС) Конфигурация типовая.
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    ПН = СоздатьОбъект("Документ.Реализация");
    ПН.Новый();
    ПН.ДатаДок = ТекущаяДата();
    глЗаполнитьШапку(ПН, 0,"Продажа");
    ПН.КодОперации = Перечисление.КодыОпераций.Продажа;
    После загрузки установите реквизит СуммаВзаиморасчетов. Он равен сумме документа.
  5. TopicStarter Overlay
    Korj
    Offline

    Korj

    Регистрация:
    3 апр 2014
    Сообщения:
    6
    Симпатии:
    1
    Баллы:
    1
    Из всего перечисленного встал только курс рубля, шапка по прежнему не работает=(
    Шапка практический не измена, меняется только контрагент и список товаров, все остальные условия одинаковы.
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    У пользователя, под которым происходит загрузка нужно выставить значения по умолчанию (фирма/склад, тип цен и т.д).
  7. TopicStarter Overlay
    Korj
    Offline

    Korj

    Регистрация:
    3 апр 2014
    Сообщения:
    6
    Симпатии:
    1
    Баллы:
    1
    Ок, сейчас попробуем
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    просто глЗаполнитьШапку как раз оттуда значения и берет....
  9. TopicStarter Overlay
    Korj
    Offline

    Korj

    Регистрация:
    3 апр 2014
    Сообщения:
    6
    Симпатии:
    1
    Баллы:
    1
    Ура! Шапка заполнилась, Вот только цена,количество, коэффициент пересчета, %боя упорно не хочет заполняться. Но если перевыбрать товар, то все встает автоматом. Копаю дальше.
    --- Объединение сообщений, 9 апр 2014 ---
    С НДС разобрался
    Slaviko нравится это.
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    не забудьте про СуммуВзаиморасчетов........
  11. TopicStarter Overlay
    Korj
    Offline

    Korj

    Регистрация:
    3 апр 2014
    Сообщения:
    6
    Симпатии:
    1
    Баллы:
    1
    Спасибо! Все работает!

Поделиться этой страницей