8.х Не могу данные запихать в ТабличноеПоле

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем Rafik, 7 авг 2007.

  1. TopicStarter Overlay
    Rafik
    Offline

    Rafik

    Регистрация:
    7 авг 2007
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    connection = New COMObject("ADODB.Connection");
    connection.Open("Provider=SQLOLEDB.1;Password ....)
    SQLQuery1 = New COMObject("ADODB.Command");
    SQLQuery1.ActiveConnection = Connection;
    SQLQuery1.CommandText = "select distinct top 50 DocName from DocMainParams where (docname is not null) and (docname<>'')";

    ну и на форме поставил Табличное поле, а как мне в него поместить результат запроса, понятия не имею, подскажите
  2. Эмин
    Offline

    Эмин Руководитель проектов

    Регистрация:
    25 май 2007
    Сообщения:
    1.178
    Симпатии:
    1
    Баллы:
    26
    Напишу тебе код, как я в таблицу значений грузил, оттуда уже в табличное поле легко наберешь.

    Код:
    Функция ВернутьТаблицу(Соединение, ТекстЗапроса)
    Попытка
    ТаблицаЗначений = Новый ("ТаблицаЗначений");
    
    Command = Новый COMОбъект("ADODB.Command");
    Command.ActiveConnection = Соединение;
    Command.CommandText = ТекстЗапроса;
    
    Записи = Новый COMОбъект("ADODB.RecordSet");
    Записи = Command.Execute(); 
    
    Для НомерКолонки = 0 По Записи.Fields.Count-1 Цикл
    ТаблицаЗначений.Колонки.Добавить(Записи.Fields.Item(НомерКолонки).Name);
    КонецЦикла;
    
    Записи.MoveFirst();                 
    Пока Записи.EOF() = 0 Цикл
    СтрокаТаблицыЗначений = ТаблицаЗначений.Добавить();
    Для НомерКолонки = 0 По Записи.Fields.Count-1 Цикл
    СтрокаТаблицыЗначений[НомерКолонки] = Записи.Fields(Записи.Fields.Item(НомерКолонки).Name).Value;
    КонецЦикла;
    Записи.MoveNext();  
    КонецЦикла;
    
    Записи.Close(); 
    
    Возврат ТаблицаЗначений;
    Исключение
    Сообщить(ОписаниеОшибки());
    Возврат 0;
    КонецПопытки;
    КонецФункции // ВернутьТаблицу()
    
    
    
    А вот как этот код вызывался
    Код:
    Попытка
    База.ActiveConnection = СокрЛП(СтрокаПодключения);
    Соединение.Open(СокрЛП(СтрокаПодключения));
    Исключение
    Сообщить(ОписаниеОшибки());
    Возврат;
    КонецПопытки;
    
    ТекстЗапроса = "SELECT * FROM NOBASE
    | WHERE NNUM > "+Формат(ПоследнийКод, "ЧГ=0")+"
    | ORDER BY NGPARENT, NPARENT, NNUM";
    Таблица = ВернутьТаблицу(Соединение, ТекстЗапроса);
    
    
    Делали вот так.
Похожие темы
  1. Новичек
    Ответов:
    4
    Просмотров:
    3.029
  2. slonykk
    Ответов:
    4
    Просмотров:
    1.116
  3. maritime
    Ответов:
    2
    Просмотров:
    561
  4. alex585
    Ответов:
    2
    Просмотров:
    832
  5. dia1000
    Ответов:
    3
    Просмотров:
    2.603
Загрузка...

Поделиться этой страницей