7.7 не меняются данные

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Dmitrij, 10 окт 2011.

  1. TopicStarter Overlay
    Dmitrij
    Offline

    Dmitrij Опытный в 1С

    Регистрация:
    6 май 2008
    Сообщения:
    844
    Симпатии:
    1
    Баллы:
    26
    Написал обработку чтоб изменить данные в документе, в отладчике показывает что все меняется, а открываю сам док там все как было
    Код:
     Процедура Сформировать()
    
    ДатаНачала="01.04.2011";
    ДатаКонца="30.04.2011";  
    
    Док=СоздатьОбъект("Документ.ЗаписиКнигиПродаж");
    Док.ВыбратьДокументы(ДатаНачала,ДатаКонца);
    Пока Док.ПолучитьДокумент()>0 Цикл
    ТекДок=Док.ТекущийДокумент();  
    Пока ТекДок.ПолучитьСтроку()=1 Цикл 
    ТекДок.БезНДС20=0; 
    ТекДок.НДС20=0;
    ТекДок.Всего=0;
    ТекДок.БезНДС20=ТекДок.Освобождаемые;
    ТекДок.НДС20=ТекДок.Освобождаемые*0.18;
    ТекДок.Освобождаемые=0;             
    ТекДок.Всего=ТекДок.НДС20+ТекДок.БезНДС20;
    Док.Записать();
    КонецЦИКЛА;
    
    КонецЦикла;         
    Сообщить("Обработка завершена!!!");
    
    КонецПроцедуры
    
  2. sergejk74
    Offline

    sergejk74 Опытный в 1С

    Регистрация:
    15 ноя 2010
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    ТекДок.ВыбратьСтроки() пропустил
  3. TopicStarter Overlay
    Dmitrij
    Offline

    Dmitrij Опытный в 1С

    Регистрация:
    6 май 2008
    Сообщения:
    844
    Симпатии:
    1
    Баллы:
    26
    Поставил, все равно не проходит
  4. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    Так попробуйте:
    Код:
    Док = СоздатьОбъект("Документ.ЗаписиКнигиПродаж");
    ТекДок = СоздатьОбъект("Документ.ЗаписиКнигиПродаж");
    Док.ВыбратьДокументы(ДатаНачала,ДатаКонца);
    Пока Док.ПолучитьДокумент() > 0 Цикл
    ТекДок.НайтиДокумент(Док.ТекущийДокумент());
    ТекДок.ВыбратьСтроки();
    Пока ТекДок.ПолучитьСтроку()=1 Цикл 
    // ....
    КонецЦикла;
    ТекДок.Записать();
    КонецЦикла;
    

Поделиться этой страницей