8.х Не идет отчет

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем ximera, 6 фев 2008.

  1. TopicStarter Overlay
    ximera
    Offline

    ximera Опытный в 1С

    Регистрация:
    5 фев 2008
    Сообщения:
    205
    Симпатии:
    0
    Баллы:
    26
    Пытаюсь написать отчет, вывод происходит не во все ячейки. Отчет должен на основе документа реализации - выводить сведения в печатную форму. Не заполняются поля (проверял также и при помощи метода сообщить) КоличествоУпаковок, ВесНетто, ВесБрутто.

    Код:
    Функция Печать() экспорт
    
    ТабДокумент = Новый ТабличныйДокумент;
    ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_РеализацияТоваровИУслуг_УпаковочныйЛист";
    
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("СсылкаНаОбъект", СсылкаНаОбъект);
    //    если ТипЗнч(СсылкаНаОбъект) = Тип("ДокументСсылка.РеализацияТоваровУслуг") тогда
    Запрос.Текст = " 
    |    ВЫБРАТЬ 
    |    таб.НомерСтроки,
    |    таб.Номенклатура,
    |    таб.ЕдиницаИзмерения,
    |    таб.Количество, 
    |    таб.ВидУпаковки,
    |    таб.КоличествоУпаковок КАК КоличествоУпаковок,
    |    таб.ВесНетто КАК ВесНетто,                    
    |    таб.ВесБрутто КАК ВесБрутто
    |ИЗ
    |    Документ.РеализацияТоваровУслуг.Товары КАК таб
    |ГДЕ
    |    таб.Ссылка = &СсылкаНаОбъект
    |
    |УПОРЯДОЧИТЬ ПО
    |    таб.НомерСтроки";
    //    иначе
    //    сообщить("Неверная ссылка на объект!");
    //    возврат неопределено;
    //конецесли;
    
    ЗапросТовары = Запрос.Выполнить().Выгрузить();
    
    // заполняем шапку 
    Макет = ПолучитьМакет("УпаковочныйЛист");
    ОбластьМакета       = Макет.ПолучитьОбласть("Шапка");
    ОбластьМакета.Параметры.НомерДокумента=СсылкаНаОбъект.Номер;
    ОбластьМакета.Параметры.ДатаДокумента=СсылкаНаОбъект.Дата;
    Грузоотправитель =?(ЗначениеНЕЗаполнено(СсылкаНаОбъект.Грузоотправитель),
    СсылкаНаОбъект.Организация,СсылкаНаОбъект.Грузоотправитель);
    Грузополучатель =?(ЗначениеНЕЗаполнено(СсылкаНаОбъект.Грузополучатель),
    СсылкаНаОбъект.Контрагент,СсылкаНаОбъект.Грузополучатель);
    ОбластьМакета.Параметры.Грузоотправитель= ОписаниеОрганизации(СведенияОЮрФизЛице(
    Грузоотправитель,СсылкаНаОбъект.Дата), 
    "ПолноеНаименование,ИНН,КПП,ЮридическийАдрес")+"; тел./факс: 11111";
    ОбластьМакета.Параметры.Грузополучатель=ОписаниеОрганизации(СведенияОЮрФизЛице(
    Грузополучатель,СсылкаНаОбъект.Дата), 
    "ПолноеНаименование,ИНН,КПП,ЮридическийАдрес,Телефоны,");
    ТабДокумент.Вывести(ОбластьМакета);
    
    // построчный вывод номенклатуры со всеми характеристиками
    ОбластьМакета   = Макет.ПолучитьОбласть("Детали");
    КолвоНетто = 0;
    КолвоБрутто = 0;
    КолвоМест  = 0;
    
    Для каждого ВыборкаСтрокТовары Из ЗапросТовары Цикл 
    ОбластьМакета.Параметры.Заполнить(ВыборкаСтрокТовары);
    //    Добавить вывод "Ящиков" для пустого ВидаУпаковки
    Если Значениенезаполнено(ВыборкаСтрокТовары.ВидУпаковки) Тогда
    ОбластьМакета.Параметры.ВидУпаковки = Справочники.ВидУпаковки.Ящик;
    КонецЕсли;
    сообщить(ВыборкаСтрокТовары.КоличествоУпаковок);
    //Если Значениенезаполнено(ВыборкаСтрокТовары.ВидУпаковки) Тогда
    //      ОбластьМакета.Параметры.ВесНетто   = ВыборкаСтрокТовары.ВесНетто;
    //КонецЕсли;
    КолвоМест = КолвоМест+ВыборкаСтрокТовары.КоличествоУпаковок;
    КолвоНетто =  КолвоНетто+ВыборкаСтрокТовары.ВесНетто;
    КолвоБрутто =  КолвоБрутто+ВыборкаСтрокТовары.ВесБрутто;
    ОбластьМакета.Параметры.Количество= ВыборкаСтрокТовары.Количество;
    ТабДокумент.Вывести(ОбластьМакета);
    КонецЦикла;
    ОбластьМакета       = Макет.ПолучитьОбласть("Подвал");
    
    ОбластьМакета.Параметры.ВМест = КолвоМест;
    ОбластьМакета.Параметры.ВсНетто = КолвоНетто;
    ОбластьМакета.Параметры.ВсБрутто = КолвоБрутто;
    
    //ОбластьМакета.Параметры.Комментарий = СсылкаНаОбъект.Комментарий;
    
    
    ТабДокумент.Вывести(ОбластьМакета);
    
    ТабДокумент.ВерхнийКолонтитул.ТекстСлева= "Продолжение "+ 
    СформироватьЗаголовокДокумента(СсылкаНаОбъект, "к документу ");
    
    ТабДокумент.НижнийКолонтитул.ТекстСлева=ПараметрыСеанса.ТекущийПользователь.Наименование;
    
    Возврат ТабДокумент;
    
    
    Возврат ТабДокумент;
    конецфункции
    
    
    Заранее спасибо
Похожие темы
  1. Savant
    Ответов:
    4
    Просмотров:
    611
  2. eugenefromvrn
    Ответов:
    1
    Просмотров:
    1.015
  3. Oksana-Larionova
    Ответов:
    3
    Просмотров:
    1.626
  4. OlgaOsipova
    Ответов:
    0
    Просмотров:
    469
Загрузка...

Поделиться этой страницей