8.х УПП НДС удваивается, утраивается и т.д.

Тема в разделе ""1С:Управление производственным предприятием УПП"", создана пользователем kera, 6 фев 2009.

  1. TopicStarter Overlay
    kera
    Offline

    kera

    Регистрация:
    28 янв 2009
    Сообщения:
    31
    Симпатии:
    0
    Баллы:
    1
    Всем приветик. тут такая штука, не знаю что поделать. Делаем возврат товара, получаем в журнале проводок неверный НДС. На картинке все показано. Ктонибудь возможно сталкивался?

    Вложения:

    • nds.JPG
      nds.JPG
      Размер файла:
      273,4 КБ
      Просмотров:
      62
  2. TopicStarter Overlay
    kera
    Offline

    kera

    Регистрация:
    28 янв 2009
    Сообщения:
    31
    Симпатии:
    0
    Баллы:
    1
    щас смотрю от номенклатуры ничего не зависит
  3. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    А релиз какой?
  4. TopicStarter Overlay
    kera
    Offline

    kera

    Регистрация:
    28 янв 2009
    Сообщения:
    31
    Симпатии:
    0
    Баллы:
    1
    1.2.19.1
  5. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Запустите восстановление НДС обработку и посмотрите. что она скажет.
  6. TopicStarter Overlay
    kera
    Offline

    kera

    Регистрация:
    28 янв 2009
    Сообщения:
    31
    Симпатии:
    0
    Баллы:
    1
    Берет и умножает количество приходов 1го товара . Итак есть такой скриптец
    Код:
    Процедура СформироватьДвиженияПоРегиструНДСПредъявленный_ВозвратОтПокупателя(СтруктураШапкиДокумента, ТаблицаПредъявленногоНДС, СтруктураПараметров, Отказ)
    перем i;
    i=0;
    
    Если не СтруктураПараметров.Свойство("СтруктураСодержитНаборыЗаписей") тогда
    ТаблицаДвижений_НДСПредъявленный	= СтруктураПараметров.ТаблицаДвиженийНДСПредъявленный;
    ТаблицаДвижений_Хозрасчетный		= СтруктураПараметров.ДвиженияХозрасчетный;
    Иначе
    ДобавитьНаборЗаписейВСтруктуруДвижений(СтруктураПараметров,"НДСПредъявленный",СтруктураШапкиДокумента.Ссылка);
    ТаблицаДвижений_НДСПредъявленный	= СтруктураПараметров.НДСПредъявленный.ВыгрузитьКолонки();
    ТаблицаДвижений_Хозрасчетный = РегистрыБухгалтерии.Хозрасчетный.СоздатьНаборЗаписей();
    ТаблицаДвижений_Хозрасчетный.Отбор.Регистратор.Установить(СтруктураШапкиДокумента.Ссылка);
    КонецЕсли;
    
    ИмяКолонкиСчет = ?(ТаблицаПредъявленногоНДС.Колонки.Найти("КорСчетБУ") <> Неопределено, "КорСчетБУ", "СчетРасходовБУ");
    ИмяКолонкиСубконто = ?(ТаблицаПредъявленногоНДС.Колонки.Найти("КорСубконтоСписанияБУ2") <> Неопределено, "КорСубконтоСписанияБУ2", "СубконтоБУ");
    
    //Для Каждого СтрокаДок из ТаблицаПредъявленногоНДС Цикл
    Для Каждого СтрокаДок из ТаблицаПредъявленногоНДС <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл	</span>
    СчетУчетаЦенности = СтрокаДок.СчетУчетаБУ;
    Если (ТипЗнч(СчетУчетаЦенности) = Тип("ПланСчетовСсылка.Хозрасчетный")) и СчетУчетаЦенности.Забалансовый Тогда
    // Пропускаем забалансовые поступления
    Продолжить;
    КонецЕсли;
    
    СтрокаДвижения = ТаблицаДвижений_НДСПредъявленный.Добавить();
    
    СтрокаДвижения.Организация = СтруктураШапкиДокумента.Организация;
    СтрокаДвижения.ВидЦенности = Перечисления.ВидыЦенностей.Возврат;
    
    СтрокаДвижения.Поставщик   = СтруктураШапкиДокумента.Контрагент;
    СтрокаДвижения.СчетФактура = ?(СтруктураШапкиДокумента.ПокупателемВыставляетсяСчетФактураНаВозврат Или НЕ ЗначениеЗаполнено(СтрокаДок.ДокументПартии), 
    СтруктураШапкиДокумента.Ссылка, 
    СтрокаДок.ДокументПартии);
    
    СтрокаДвижения.СтавкаНДС   = СтрокаДок.СтавкаНДС;
    
    СтрокаДвижения.СчетУчетаНДС = СтруктураШапкиДокумента.СчетУчетаНДС;
    
    СтрокаДвижения.СуммаБезНДС = СтрокаДок.СуммаБезНДС;
    СтрокаДвижения.НДС         = СтрокаДок.НДС;
    
    СтрокаДвижения.ВидДвижения  = ВидДвиженияНакопления.Приход;
    
    СтрокаДвижения.Событие     = Перечисления.СобытияПоНДСПокупки.ПредъявленНДСПоставщиком;
    
    // Проводка в БУ
    Проводка = ТаблицаДвижений_Хозрасчетный.Добавить();
    
    Проводка.Период      = СтруктураШапкиДокумента.Дата;
    Проводка.Организация = СтруктураШапкиДокумента.Организация;
    //	если i=0 тогда 
    Проводка.Сумма       = (-1) * СтрокаДок.НДС;
    //		i=i+1;
    //	КонецЕсли;	
    Проводка.Содержание  = "НДС при возврате от покупателя";
    
    Если БухгалтерскийУчет.ЭтоСубсчет(СтрокаДок[ИмяКолонкиСчет], ПланыСчетов.Хозрасчетный.ПрочиеДоходыИРасходы) тогда
    Проводка.СчетДт = СтрокаДок[ИмяКолонкиСчет];
    Если ТипЗнч(СтрокаДок[ИмяКолонкиСубконто]) = Тип("СправочникСсылка.ПрочиеДоходыИРасходы") Тогда
    БухгалтерскийУчет.УстановитьСубконто(Проводка.СчетДт, Проводка.СубконтоДт, 1, СтрокаДок[ИмяКолонкиСубконто]);
    КонецЕсли;
    Иначе
    Проводка.СчетДт = ПланыСчетов.Хозрасчетный.Продажи_НДС;
    КонецЕсли;
    
    Если ТипЗнч(СтрокаДок[ИмяКолонкиСубконто]) = Тип("СправочникСсылка.НоменклатурныеГруппы") Тогда
    БухгалтерскийУчет.УстановитьСубконто(Проводка.СчетДт, Проводка.СубконтоДт, 1, СтрокаДок[ИмяКолонкиСубконто]);
    КонецЕсли;
    
    БухгалтерскийУчет.УстановитьСубконто(Проводка.СчетДт, Проводка.СубконтоДт, "СтавкиНДС", СтрокаДок.СтавкаНДС);
    
    Проводка.СчетКт      = СтруктураШапкиДокумента.СчетУчетаНДС;
    БухгалтерскийУчет.УстановитьСубконто(Проводка.СчетКт, Проводка.СубконтоКт, "СФПолученные", СтрокаДвижения.СчетФактура);
    БухгалтерскийУчет.УстановитьСубконто(Проводка.СчетКт, Проводка.СубконтоКт, "Контрагенты",  СтруктураШапкиДокумента.Контрагент, Истина);
    
    КонецЦикла;
    
    Если ТаблицаДвижений_НДСПредъявленный.Количество() > 0 Тогда
    Если не СтруктураПараметров.Свойство("СтруктураСодержитНаборыЗаписей") тогда
    ТаблицаДвижений_НДСПредъявленный.ЗаполнитьЗначения(СтруктураШапкиДокумента.Дата, "Период");
    СтруктураПараметров.Вставить("ИзмененыДвиженияНДСПредъявленный", Истина);
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">		Иначе	</span>
    СтруктураПараметров.НДСПредъявленный.мПериод          = СтруктураШапкиДокумента.Дата;
    СтруктураПараметров.НДСПредъявленный.мТаблицаДвижений = ТаблицаДвижений_НДСПредъявленный;
    СтруктураПараметров.НДСПредъявленный.ДобавитьДвижение();
    СтруктураПараметров.НДСПредъявленный.Записать(Ложь);
    ТаблицаДвижений_Хозрасчетный.Записать(ложь);
    КонецЕсли;
    
    КонецЕсли;
    
    КонецПроцедуры // СформироватьДвиженияПоРегиструНДСПредъявленный()
    
    
    Если в нем изменить кое что , то все формируется норм, но случай с несколькими позициями не катит, берет тока первую.
    Такой вариант к сожалению не приемлем


    Код:
    	// Проводка в БУ
    Проводка = ТаблицаДвижений_Хозрасчетный.Добавить();
    
    Проводка.Период      = СтруктураШапкиДокумента.Дата;
    Проводка.Организация = СтруктураШапкиДокумента.Организация;
    если i=0 тогда 
    Проводка.Сумма       = (-1) * СтрокаДок.НДС;
    i=i+1;
    КонецЕсли;	
    Проводка.Содержание  = "НДС при возврате от покупателя";
    

Поделиться этой страницей