8.х ОБМЕН Настройка обмена УПП БП 3.0

Тема в разделе "Обмен данными в "1С:Предприятие 8"", создана пользователем Vladiwir, 1 апр 2014.

  1. TopicStarter Overlay
    Vladiwir
    Offline

    Vladiwir

    Регистрация:
    13 фев 2014
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    При настройке обмена на 2-м шаге ошибка: "Итератор для значения не определен".
    С чем связана ошибка и как исправить?
  2. Yuriy_Alexandrovich
    Offline

    Yuriy_Alexandrovich Профессионал в 1С Команда форума

    Регистрация:
    15 сен 2011
    Сообщения:
    1.275
    Симпатии:
    76
    Баллы:
    54
    Слишком мало информации, посмотрите в журнале регистрации, какие ошибки валяться
  3. TopicStarter Overlay
    Vladiwir
    Offline

    Vladiwir

    Регистрация:
    13 фев 2014
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    Журнал регистрации
    {ОбщийМодуль.ОбменДаннымиСобытия.Модуль(2852)}: Итератор для значения не определен
    Для Каждого Элемент Из Настройки Цикл


    Это в БП 3.0.27.7
    .7Процедура УстановитьЗначенияНаУзле(УзелПланаОбмена, Настройки)

    ИмяПланаОбмена = УзелПланаОбмена.Метаданные().Имя;

    Для Каждого Элемент Из Настройки Цикл

    Ключ = Элемент.Ключ;
    Значение = Элемент.Значение;

    Если УзелПланаОбмена.Метаданные().Реквизиты.Найти(Ключ) = Неопределено
    И УзелПланаОбмена.Метаданные().ТабличныеЧасти.Найти(Ключ) = Неопределено Тогда
    Продолжить;
    КонецЕсли;

    Если ТипЗнч(Значение) = Тип("Массив") Тогда

    ДанныеРеквизита = ПолучитьСсылочныйТипИзПервогоРеквизитаТабличнойЧастиПланаОбмена(ИмяПланаОбмена, Ключ);

    Если ДанныеРеквизита = Неопределено Тогда
    Продолжить;
    КонецЕсли;

    ТаблицаУзла = УзелПланаОбмена[Ключ];

    ТаблицаУзла.Очистить();

    Для Каждого СтрокаТаблицы Из Значение Цикл

    Если СтрокаТаблицы.Использовать Тогда

    МенеджерОбъекта = ОбщегоНазначения.МенеджерОбъектаПоСсылке(ДанныеРеквизита.Тип.ПривестиЗначение());

    ЗначениеРеквизита = МенеджерОбъекта.ПолучитьСсылку(Новый УникальныйИдентификатор(СтрокаТаблицы.УникальныйИдентификаторСсылки));

    ТаблицаУзла.Добавить()[ДанныеРеквизита.Имя] = ЗначениеРеквизита;

    КонецЕсли;

    КонецЦикла;

    ИначеЕсли ТипЗнч(Значение) = Тип("Структура") Тогда

    ЗаполнитьТаблицуУзлаПланаОбмена(УзелПланаОбмена, Значение, Ключ);

    Иначе // примитивные типы

    УзелПланаОбмена[Ключ] = Значение;

    КонецЕсли;

    КонецЦикла;

    КонецПроцедуры
    Последнее редактирование: 1 апр 2014
  4. Yuriy_Alexandrovich
    Offline

    Yuriy_Alexandrovich Профессионал в 1С Команда форума

    Регистрация:
    15 сен 2011
    Сообщения:
    1.275
    Симпатии:
    76
    Баллы:
    54
    Проверте настройки обмена, вероятно что где то стоит лишнее

Поделиться этой страницей