7.7 Нашёл элемент а дальше?

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем mihaly81, 3 ноя 2007.

  1. TopicStarter Overlay
    mihaly81
    Offline

    mihaly81

    Регистрация:
    27 окт 2007
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    в форме списка справочника нужно организовать свой поиск по двум критериям.
    есть поле ввода и кнопку с процедурой поиск()

    Процедура Поиск()
    Перем пр;
    пр=критерийпоиска.получитьзначение(критерийпоиска.текущаястрока());
    спр=создатьобъект("справочник.видеопродукция");
    если спр.найтипонаименованию(искать,0,0)=1 тогда
    активизироватьобъект(спр.текущийэлемент());
    конецесли;
    КонецПроцедуры

    объект активизируется а при дальнейшем нажатии кнопки не обходит дальше элементы справочника?
    подскажите плиз что сделать?
  2. yourname
    Offline

    yourname Опытный в 1С

    Регистрация:
    15 июл 2007
    Сообщения:
    84
    Симпатии:
    0
    Баллы:
    26
    Поблема в том, что методы НайтиПоНаименованию и другие ищут ПЕРВЫЙ подходящий элемент.
    Как решить:
    Используй ТЗ или с пом транзакций(тут где-то уже писали)
  3. Prospero
    Offline

    Prospero Опытный в 1С

    Регистрация:
    13 сен 2006
    Сообщения:
    111
    Симпатии:
    0
    Баллы:
    26
    А если использовать
    Код:
    ВыбратьЭлементыПоРеквизиту
    
    
    ?
    а потом перебирать выборку?
  4. yourname
    Offline

    yourname Опытный в 1С

    Регистрация:
    15 июл 2007
    Сообщения:
    84
    Симпатии:
    0
    Баллы:
    26
    Можно и так, но смысл тот же: ТаблицаЗначений
    Если уже использовать выборку, тогда просто


    ВЫбратьЭлементы();
    Пока ПолучитьЭлемент()=1 цикл
    Если (Реквзит=...) и (Реквизит1=...) тогда
    .......
    КонецЕсли;
    КонецЦикла;

Поделиться этой страницей