[РЕШЕНО] Нарушение разметки ценника при изменении масштаба колонок УТ 10.3

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Katakiarika, 12 сен 2016.

  1. TopicStarter Overlay
    Katakiarika
    Offline

    Katakiarika

    Регистрация:
    9 сен 2016
    Сообщения:
    28
    Симпатии:
    0
    Баллы:
    1
    Так оно выглядит при ширине/высоте колонок 100мм[​IMG]

    А при изменении ширины/высоты, например, до 80мм - происходит следующее:
    [​IMG]

    Ячейки НаименованиеНоменклатуры и Артикул почему-то сужаются до вот таких размеров. Проверял свойства каждой ячейки и сравнивал с теми, у которых такой проблемы нет - настройки одинаковые.
    --- Объединение сообщений, 12 сен 2016 ---
    Код:
    Функция ПечатьЦенника() Экспорт
    
        Если НЕ ЗначениеЗаполнено(Организация) Тогда
            Предупреждение("Не выбрана организация!");
            Возврат Неопределено;
        КонецЕсли;
    
        ТабДокумент                     = Новый ТабличныйДокумент;
        ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_Ценник";
        Макет                           = ПолучитьМакет("Ценник");
        ОбластьЦенника                  = Макет.ПолучитьОбласть("Строка|Столбец");
       
        ПечШирина = Мин(Макс(ПечШирина, 8), 130);
        ПечВысота = Мин(Макс(ПечВысота, 8), 130);
        ПечКолонок= Мин(Макс(ПечКолонок, 1),  14);
        ПечСтрок  = Мин(Макс(ПечСтрок,   1),  14);
       
        ОбластьЦенника.Области.Орг.ШиринаКолонки = ПечШирина * 0.542 / 2;
        Для Каждого Область из ОбластьЦенника.Области Цикл
            Область.ВысотаСтроки = Область.Шрифт.Размер * 1.345 / 100 * ПечВысота * ?(Область.Имя = "Наим", 3.39, 1);
            Область.Шрифт = Новый Шрифт(Область.Шрифт, , Область.Шрифт.Размер / 100 * (ПечШирина+ПечВысота) / 2 +
                            ?(Область.Имя = "Наим", ДопНаим, 0) +
                            ?(Область.Имя = "Цена", ДопЦена, 0));
        КонецЦикла;
       
        ДатаПечати = РабочаяДата;
    
        ТекСтолбец = 0;
        ТекСтрока  = 0;
    
        Для Каждого СтрокаТаблицы Из Товары Цикл
            Если СтрокаТаблицы.Печать Тогда
                Для Тмп = 1 По СтрокаТаблицы.Количество Цикл
                    ОбластьЦенника.Параметры.Организация                = Организация;
                    ОбластьЦенника.Параметры.ОрганизацияНаименование    = Организация;
                    ОбластьЦенника.Параметры.Артикул                    = СтрокаТаблицы.Номенклатура.Артикул;
                    ОбластьЦенника.Параметры.НоменклатураНаименование   = СтрокаТаблицы.Номенклатура.НаименованиеПолное;
                    ОбластьЦенника.Параметры.Цена                       = ОбщегоНазначения.ФорматСумм(СтрокаТаблицы.Цена, Валюта, "00");
                    ОбластьЦенника.Параметры.ДатаПечати                 = ДатаПечати;
                    ОбластьЦенника.Параметры.ЕдиницаНаименование        = СтрокаТаблицы.ЕдиницаИзмерения;
    
                    Если ТекСтолбец = 0 Тогда
                        ТабДокумент.Вывести(ОбластьЦенника);
                    Иначе
                        ТабДокумент.Присоединить(ОбластьЦенника);
                    КонецЕсли;
                   
                    ТекСтолбец = ТекСтолбец + 1;
    
                    Если ТекСтолбец = ПечКолонок Тогда
                        ТекСтрока  = ТекСтрока + 1;
                        ТекСтолбец = 0;
                    КонецЕсли;
    
                    Если ТекСтрока = ПечСтрок Тогда
                        ТекСтрока = 0;
                        ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();
                    КонецЕсли;
                КонецЦикла;
            КонецЕсли;
        КонецЦикла;
    
        ТабДокумент.ТолькоПросмотр = Истина;
    
        Возврат ТабДокумент;
    
    КонецФункции
    Код всей функции, которая ответственна за это дело, на всякий случай.

    Вложения:

    • 1.jpg
      1.jpg
      Размер файла:
      146,1 КБ
      Просмотров:
      33
    • 2.jpg
      2.jpg
      Размер файла:
      148,4 КБ
      Просмотров:
      33
    Последнее редактирование: 12 сен 2016
  2. kisol
    Offline

    kisol Профессионал в 1С

    Регистрация:
    25 июл 2012
    Сообщения:
    394
    Симпатии:
    41
    Баллы:
    54
    А если поменять местами проблемные ячейки с нормальными. Что происходит?
  3. TopicStarter Overlay
    Katakiarika
    Offline

    Katakiarika

    Регистрация:
    9 сен 2016
    Сообщения:
    28
    Симпатии:
    0
    Баллы:
    1
    Проблема именно с этими значениями. Они становятся меньше на любой позиции.
  4. kisol
    Offline

    kisol Профессионал в 1С

    Регистрация:
    25 июл 2012
    Сообщения:
    394
    Симпатии:
    41
    Баллы:
    54
    Скриншот табличного документа из конфигуратора приложи
  5. TopicStarter Overlay
    Katakiarika
    Offline

    Katakiarika

    Регистрация:
    9 сен 2016
    Сообщения:
    28
    Симпатии:
    0
    Баллы:
    1
    Вот.
    [​IMG]

    Вложения:

    • Скрин.jpg
      Скрин.jpg
      Размер файла:
      72,7 КБ
      Просмотров:
      10
  6. TopicStarter Overlay
    Katakiarika
    Offline

    Katakiarika

    Регистрация:
    9 сен 2016
    Сообщения:
    28
    Симпатии:
    0
    Баллы:
    1
    Блин, всё, отмена. Хотят вообще теперь другу форму ценника - всё переделывать. Буду пытаться с нуля.

Поделиться этой страницей