8.х Написать процедуру вывода предупреждения

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем csusha, 7 фев 2011.

  1. TopicStarter Overlay
    csusha
    Offline

    csusha

    Регистрация:
    7 фев 2011
    Сообщения:
    19
    Симпатии:
    0
    Баллы:
    1
    Никогда сама не писала процедуры. А мне надо написать процедуру, выводящую текст предупреждения в начале работы в системе "Приступаем к работе в системе в 1С:Предприятие 8.1". Я начала, но этот вариант не работает

    Процедура Приступаем к работе в системе 1С:Предприятие 8.1
    НачалоРаботы=Вопрос();
    НачРаб=Строка(НачалоРаботы);
    Ответ=Вопрос("Приступаем к работе в системе 1С:Предприятие 8.1"+НачРаб,
    РежимДиалогаВопрос.ДаНет);
    Если Ответ=КодВозвратаДиалога.Нет Тогда
    КонецЕсли;
    КонецПроцедуры
  2. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    Я так понимаю, вам нужно не предупреждение, а задать вопрос пользователю о желании начать работу?
    Лучше не процедура, а функция:
    Код:
    Функция ПриступитьКРаботе()
    Режим = РежимДиалогаВопрос.ДаНет;
    Ответ = Вопрос("Приступить к работе в системе 1С:Предприятие 8.1?", Режим, 0);
    Возврат (Ответ = КодВозвратаДиалога.Да);
    КонецФункции
    
    А затем функцию вызывать в ПриНачалеРаботыСистемы():
    Код:
    Процедура ПриНачалеРаботыСистемы()
    Если Не ПриступитьКРаботе() Тогда
    ЗавершитьРаботуСистемы(Ложь);
    Возврат;
    КонецЕсли;
    КонецПроцедуры
    
    P.S. Можно и сразу участок кода в ПриНачалеРаботыСистемы() (без всяких функций)

Поделиться этой страницей