8.х Написание отчета.

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Ленок, 27 авг 2013.

  1. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    Ну у Вас в обоих запросах


    Код:
    Запрос.Текст =  "
    |ЗаказыПокупателей.Ссылка
    А должно быть


    Код:
    Запрос.Текст =  "ВЫБРАТЬ
    |ЗаказыПокупателей.Ссылка
  2. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    в обоих запросах нет слова ВЫБРАТЬ в самом начале текста запроса. потому и ошибка

    и зачем вам 2 раза текстзапроса формировать?
  3. TopicStarter Overlay
    Ленок
    Offline

    Ленок

    Регистрация:
    3 окт 2012
    Сообщения:
    40
    Симпатии:
    0
    Баллы:
    1
    НЕТ ВСЕ ТОЖЕ САМОЕ

    {Форма.Форма(25)}: Ошибка при вызове метода контекста (Выполнить): {(2, 1)}: Ожидается выражение "ВЫБРАТЬ"
    <<?>>ЗаказыПокупателей.Ссылка
    Выборка = Запрос.Выполнить().Выбрать();

    Сейчас исправлю посмотрим

    Да что было к тому и пришли
    Код:
    Процедура КнопкаВыполнитьНажатие(Кнопка)
    Если ПустаяСтрока(ПолеВвода1) Тогда
    Предупреждение("Нет слова для поиска");
    Возврат;
    КонецЕсли;
    Запрос = Новый Запрос;
    Запрос.Текст =  "ВЫБРАТЬ
    |ЗаказыПокупателей.Ссылка
    |ИЗ
    |ЖурналДокументов.ЗаказыПокупателей КАК ЗаказыПокупателей
    |ГДЕ
    |ЗаказыПокупателей.ВидОперации = ЗНАЧЕНИЕ(Перечисление.ВидыОперацийЗаказПокупателя.ПродажаКомиссия)
    |И ЗаказыПокупателей.ПометкаУдаления = Ложь
    |И
    |ЗаказыПокупателей.Проведен = Истина
    |И
    | ВЫРАЗИТЬ(НазначениеПлатежа КАК СТРОКА(250)) ПОДОБНО &Усл
    | И Дата МЕЖДУ &НачПериода И &КонПериода
    | УПОРЯДОЧИТЬ ПО Дата";
    
    Запрос.УстановитьПараметр("НачПериода",НачПериода);
    Запрос.УстановитьПараметр("КонПериода",КонПериода);
    Выборка = Запрос.Выполнить().Выбрать();
    Состав.Очистить();
    Пока Выборка.Следующий() Цикл
    НоваяСтрока = Состав.Добавить();
    НоваяСтрока.Документ = Выборка.Ссылка;
    НоваяСтрока.КонтрАгент = Выборка.Ссылка.Контрагент;
    НоваяСтрока.Дата = Выборка.Ссылка.Дата;
    НоваяСтрока.Номер = Выборка.Ссылка.НомерДокумента;
    НоваяСтрока.Сумма = Выборка.Ссылка.СуммаДокумента;
    НоваяСтрока.АдресДоставки = Выборка.Ссылка.РегистрСведений.КонтактнаяИнформация;
    НоваяСтрока.Организация = Выборка.Ссылка.РегистрСведений.КонтактнаяИнформация;
    НоваяСтрока.Организация = Выборка.Ссылка.Справочник.Организаци;
    НоваяСтрока.Экспедитор = Выборка.Ссылка.Справочник.ФизичискиеЛица;
    КонецЦикла;
    КонецПроцедуры
    
    Код:
    {Форма.Форма(24)}: Ошибка при вызове метода контекста (Выполнить): {(6, 41)}: Синтаксическая ошибка "(Перечисление.ВидыОперацийЗаказПокупателя.ПродажаКомиссия)"
    ЗаказыПокупателей.ВидОперации = ЗНАЧЕНИЕ<<?>>(Перечисление.ВидыОперацийЗаказПокупателя.ПродажаКомиссия)
    Выборка = Запрос.Выполнить().Выбрать();
    
  4. TopicStarter Overlay
    Ленок
    Offline

    Ленок

    Регистрация:
    3 окт 2012
    Сообщения:
    40
    Симпатии:
    0
    Баллы:
    1
    Помогите пожалуйста до конца проблему решить(((((
  5. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    У Вас конфигурация какая? посмотрите по конфигуратору какотам тип должен быть
    а так что это
    | ВЫРАЗИТЬ(НазначениеПлатежа КАК СТРОКА(250)) ПОДОБНО &Усл

    что тако назначение платежа и где определенеи параметра Усл
  6. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    попробуйте открыть запрос в конструкторе, выдаст ли ошибку конструктор
  7. TopicStarter Overlay
    Ленок
    Offline

    Ленок

    Регистрация:
    3 окт 2012
    Сообщения:
    40
    Симпатии:
    0
    Баллы:
    1
    убрала назначение платежа!
    ошика все ссылается на слово "Значение"
    Код:
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
    |ЗаказыПокупателей.Ссылка
    |ИЗ
    |ЖурналДокументов.ЗаказыПокупателей КАК ЗаказыПокупателей
    |ГДЕ
    |ЗаказыПокупателей.ВидОперации = Значение(Перечисление.ВидыОперацийЗаказПокупателя.ПродажаКомиссия)
    |И
    |ЗаказыПокупателей.ПометкаУдаления = Ложь
    |И
    |ЗаказыПокупателей.Проведен = Истина";
    
    Запрос.УстановитьПараметр("НачПериода",НачПериода);
    Запрос.УстановитьПараметр("КонПериода",КонПериода);
    Выборка = Запрос.Выполнить().Выбрать();
    Состав.Очистить();
    
    Код:
    {Форма.Форма(21)}: Ошибка при вызове метода контекста (Выполнить): {(6, 41)}: Синтаксическая ошибка "(Перечисление.ВидыОперацийЗаказПокупателя.ПродажаКомиссия)"
    ЗаказыПокупателей.ВидОперации = Значение<<?>>(Перечисление.ВидыОперацийЗаказПокупателя.ПродажаКомиссия)
    Выборка = Запрос.Выполнить().Выбрать();
    
  8. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    глупо, но предложу, слово Значение наберите большими буквами ЗНАЧЕНИЕ
  9. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    Посмотрите у Вас вконфигурации есть такое перечисление Перечисление.ВидыОперацийЗаказПокупателя.ПродажаКомиссия
  10. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    а такое перечисление у вас есть? посмотрите в дереве обЪектов
  11. TopicStarter Overlay
    Ленок
    Offline

    Ленок

    Регистрация:
    3 окт 2012
    Сообщения:
    40
    Симпатии:
    0
    Баллы:
    1
    :cry_1: нету а откуда же я слизала((((( анверно со старой обработки!(
  12. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    не торопитесь, будьте внимательнее, а то в большом коде будет куда солжнее со временем искать такие ляпы

Поделиться этой страницей