7.7 Написал я отчет по Продажам подскажите 1 момент

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Kyznets, 1 фев 2010.

  1. TopicStarter Overlay
    Kyznets
    Offline

    Kyznets Опытный в 1С

    Регистрация:
    24 янв 2010
    Сообщения:
    51
    Симпатии:
    0
    Баллы:
    26
    Вот такая проблема смотрите.. Написал я отчет вроде все нормально считает.. Но сматрите у нас 3 склада Если я формирую отчет по 1му складу все нормально в таблице ЦЕНЫ (закрываю я таблицу из обработки не выхохожу)
    дальше формирую по 2му складу тоже все четка цены товар закрываю таблицу. А когда формирую по 3му складу у меня таблица вылезает 2 го склада с ценами со всем, И по 1му складу тоже данные все 2го склада. Что это такое то.


    НА форме таблица туда при Открытие обработки
    Закидываются склады которые есть.

    а в Процедуре Сформировать()
    Код:
    //вот такой код для выборки склада
    ВыбСкладР="";
    ВыбСклады.ВыбратьСтроки();
    Пока ВыбСклады.ПолучитьСтроку()=1 Цикл
    Если ВыбСклады.Пометка=2 Тогда
    СпрСклад1.НайтиПоКоду(СокрЛП(ВыбСклады.КодСклада));
    сзСклады.ДобавитьЗначение(СпрСклад1.ТекущийЭлемент());
    ВыбСкладР=ВыбСкладР+" / "+СпрСклад1.Наименование;
    КонецЕсли;
    КонецЦикла;
    Если сзСклады.РазмерСписка() > 0 Тогда
    ТекстЗапросаР = ТекстЗапросаР + "Условие(Склад в сзСклады);";
    КонецЕсли;
    
    
    Такое ощущение что Выбор склада не работает после 2 го. раза А почему ???
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    А вы список очищаете перед выборкой?

    Код:
    сзСклады.УдалитьВсе();
    ВыбСкладР="";
    ВыбСклады.ВыбратьСтроки();
    .....................
    
    
    З/Ы не проще ли делать все через запрос?

Поделиться этой страницей