7.7 Найден косяк в Бухгалтерии 535 релиз справки НДФЛ

Тема в разделе "Общие вопросы "1С:Предприятие 7.7"", создана пользователем Vertex, 30 янв 2012.

  1. TopicStarter Overlay
    Vertex
    Offline

    Vertex Опытный в 1С

    Регистрация:
    14 июн 2011
    Сообщения:
    468
    Симпатии:
    4
    Баллы:
    29
    Отчёт, Печать справок по НДФЛ

    Код:
    //	Предопределенная процедура
    //
    Процедура ОбработкаПодбора(Элемент,КонтФормы)
    Если ПустоеЗначение(Элемент)=0 Тогда
    
    Если ТекущаяЗакладка=1 Тогда
    Если Элемент.ЭтоГруппа()=0 Тогда
    Если Элемент.ТекущийЭлемент() <> Элемент Тогда //<< При выборе сотрудника ругалось на неизвесный метод >>>Элемент.ОсновнойЭлемент, заменил на >>Элемент.ТекущийЭлемент()
    Элемент = Элемент.ОсновнойЭлемент //<< Тут также ошибка , нужно поправить
    КонецЕсли;
    Если Элемент.Выбран() = 1 Тогда
    Если Сотрудники.НайтиЗначение(Элемент) = 0 Тогда
    Сотрудники.ДобавитьЗначение(Элемент);
    КонецЕсли;
    КонецЕсли;
    КонецЕсли;
    СпособВыборкиСотрудников = ?((Сотрудники.РазмерСписка()>0) и (СпособВыборкиСотрудников = 1),2,СпособВыборкиСотрудников);
    ИначеЕсли ТекущаяЗакладка=2 Тогда
    
    НомСтроки = "";
    Если ТаблицаСправок2011.НайтиЗначение(Элемент,НомСтроки,"Сотрудник") = 0 Тогда
    ТаблицаСправок2011.НоваяСтрока();
    ТаблицаСправок2011.Сотрудник = Элемент;
    ДозаполнитьСтрокуТаблицыСправок(ТаблицаСправок2011);
    КонецЕсли;
    
    КонецЕсли;
    
    КонецЕсли;  
    КонецПроцедуры	// ОбработкаПодбора()
    Будте внимательны.

Поделиться этой страницей