7.7 Начисление удержаний

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Time dont wait, 25 ноя 2009.

  1. TopicStarter Overlay
    Time dont wait
    Offline

    Time dont wait Опытный в 1С

    Регистрация:
    20 окт 2009
    Сообщения:
    192
    Симпатии:
    0
    Баллы:
    26
    Самописная конфа для выплаты з\п . То что вводится документом - работает, а налоги не расчитываются. вот пример одного вр.ПФ:
    Код:
    Процедура ПровестиРасчет()
    
    НТП = НачалоТекущегоПериода();
    КТП = КонецТекущегоПериода();
    НачалоГода =  НачГода(НТП);
    
    Сотр = Объект;
    ВН = РезультатГруппы(Сотр,ГруппаРасчетов.ВсьогоНараховано,НачалоГода,КТП);
    ОблНал  = ВН;
    Примечание = "Обл. " + Строка(ОблНал);
    Если ВН = 0 тогда
    Результат = 0;
    ИначеЕсли
    Результат = ВН*0.02;
    КонецЕсли;
    КонецЕсли;
    КонецПроцедуры
    
    
    
    
    И сама обработка для расчета з\п

    Вложения:

  2. TopicStarter Overlay
    Time dont wait
    Offline

    Time dont wait Опытный в 1С

    Регистрация:
    20 окт 2009
    Сообщения:
    192
    Симпатии:
    0
    Баллы:
    26
    Все решено, просто после добавления новых расчетов забыл ето учесть в док.Началомесяца

Поделиться этой страницей