7.7 Наборы прав

Тема в разделе "Общие вопросы "1С:Предприятие 7.7"", создана пользователем rshakiro, 3 фев 2012.

  1. TopicStarter Overlay
    rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    Здравствуйте, возможно ли запретить пользователю "отменить проведение документа" из журнала этого документа? Имеется возможность "свойства элементов прав" снять галочки "изменение проведенных документов", "изменение документов без проведения", "проведение документов задним числом". Но для этого пользователя требуется РАЗРЕШИТЬ "проведение задним числом", ЗАПРЕТИТЬ "изменение проведенных документов", отдельно эти галки выставить невозможно ((( Как быть?
  2. serg_buz
    Offline

    serg_buz Опытный в 1С

    Регистрация:
    21 дек 2011
    Сообщения:
    91
    Симпатии:
    0
    Баллы:
    26
    Если только в расширенной настройке документа, и то врят ли... А для чего такие тонкости если не секрет?
  3. TopicStarter Overlay
    rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    В нашей конфигурации имеются документы "Путевые листы", которые обрабатывают сначала Диспетчера(заполняют задания, пробег, расход/приход топлива), затем "Экономисты"(начисляют зар.плату). после начисления зарплаты по путевому листу, Диспетчер может ОТКОРРЕКТИРОВАТЬ задание и провести документ, начисленная зарплата по этому документу изменится. Вот и причина

    В 1с 8.1 - 8.2 имеется нужная мне настройка в роли, где можно запретить "отмена проведения"...
  4. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    В глобальном модуле можно обработать предопределенное событие: "ПриОтменеПроведенияДокумента()"
  5. TopicStarter Overlay
    rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    (Решение) В глобальном модуле прописываем процедуру:

    Код:
    Процедура ПриОтменеПроведенияДокумента(докПЛ)
    док = докПЛ;
    докПЛ = СоздатьОбъект("Документ");
    докПЛ.НайтиДокумент(док);
    Права = НазваниеНабораПрав();
    Если (Права = "Диспетчер") Тогда
    Если (ДокПЛ.НачислятьЗарплатуВодителю = 1) Тогда
    Предупреждение("Этот документ проведен и начислена зарплата, обратитесь к экономисту!!!");
    СтатусВозврата(0);
    Возврат;
    КонецЕсли;
    КонецЕсли;
    КонецПроцедуры
    Спасибо
  6. TopicStarter Overlay
    rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    Считаю целесообразно добавить в глобальном модуле следующую процедуру:

    Код:
    //Действия документа при интерактивном удалении документа
    Процедура ПриУдаленииДокумента(докПЛ)
    док = докПЛ;
    докПЛ = СоздатьОбъект("Документ");
    докПЛ.НайтиДокумент(док);
    Права = НазваниеНабораПрав();
    Если (Права = "Диспетчер") Тогда
    Если (ДокПЛ.НачислятьЗарплатуВодителю = 1) Тогда
    Предупреждение("Этот документ проведен!
    |По данному документу начислена зарплата!
    |Удалять документ запрещено!
    |Обратитесь к экономисту или администратору!!!");
    СтатусВозврата(0);
    Возврат;
    КонецЕсли;
    КонецЕсли;
    КонецПроцедуры

Поделиться этой страницей