8.х На основании заказа покупателя, чеки ККМ

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем malcevm, 15 сен 2015.

  1. TopicStarter Overlay
    malcevm
    Offline

    malcevm

    Регистрация:
    28 янв 2015
    Сообщения:
    40
    Симпатии:
    0
    Баллы:
    1
    Хорошего всем дня. "Управление торговлей", редакция 10.3 (10.3.31.1) Вообщем хотел спросить с чего начать, переносить нужно только номенклатуру и возможно в будущем допилить форму чеков ККМ, во вкладке дополнительно добавить поле контрагент.

    Задача:
    Перенос номенклатуры на основании заказа покупателя в чеки ККМ.
    Может у кого есть готовый код или что то похожее, ну или вариант тебе нужно смотреть здесь тоже подойдет. Любая помощь не оценима. Спасибо!
  2. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    В чем сложность создать документ ЧекККМ на основе заказа ?
  3. TopicStarter Overlay
    malcevm
    Offline

    malcevm

    Регистрация:
    28 янв 2015
    Сообщения:
    40
    Симпатии:
    0
    Баллы:
    1
    Я бы только за, но я не нашел там такого (
  4. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    Есть три варианта:
    1. Писать самому
    2. Заказать обработку
    3. Ждать миценатов.
  5. TopicStarter Overlay
    malcevm
    Offline

    malcevm

    Регистрация:
    28 янв 2015
    Сообщения:
    40
    Симпатии:
    0
    Баллы:
    1
    Идеальным было бы совместить 1 со 2-м )
    --- Объединение сообщений, 15 сен 2015 ---
    Такие темы уже были в нашем уютном форуме, но не одна не доведена до конца.
  6. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    Потому что бесплатно работать никто не хочет. Зачем отнимать хлеб у кого-то ?
  7. TopicStarter Overlay
    malcevm
    Offline

    malcevm

    Регистрация:
    28 янв 2015
    Сообщения:
    40
    Симпатии:
    0
    Баллы:
    1
    может кто подскажет с чего начать?
  8. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.548
    Симпатии:
    716
    Баллы:
    204
    Начинать нужно всегда с чтения литературы/обучения на курсах.
  9. TopicStarter Overlay
    malcevm
    Offline

    malcevm

    Регистрация:
    28 янв 2015
    Сообщения:
    40
    Симпатии:
    0
    Баллы:
    1
    Вот что удалось сделать но оно не работает, выводит чек ККМ, но он пустой. Наверняка что то, где то не углядел.
    Код:
    Процедура ОбработкаЗаполнения(Основание)
           Если ТипЗнч(Основание) = Тип("ДокументСсылка.ЧекККМ") Тогда
            // Заполнение шапки
            Комментарий = Основание.Комментарий;
            Организация = Основание.Организация;
            Ответственный = Основание.Ответственный;
            СуммаДокумента = Основание.СуммаДокумента;
            ТипЦен = Основание.ТипЦен;
            УсловиеПродаж = Основание.УсловиеПродаж;
            Для Каждого ТекСтрокаСоставНабора Из Основание.СоставНабора Цикл
                НоваяСтрока = СоставНабора.Добавить();
                НоваяСтрока.ЕдиницаИзмерения = ТекСтрокаСоставНабора.ЕдиницаИзмерения;
                НоваяСтрока.КлючСтроки = ТекСтрокаСоставНабора.КлючСтроки;
                НоваяСтрока.Количество = ТекСтрокаСоставНабора.Количество;
                НоваяСтрока.Номенклатура = ТекСтрокаСоставНабора.Номенклатура;
                НоваяСтрока.СерияНоменклатуры = ТекСтрокаСоставНабора.СерияНоменклатуры;
                НоваяСтрока.ХарактеристикаНоменклатуры = ТекСтрокаСоставНабора.ХарактеристикаНоменклатуры;
                НоваяСтрока.Цена = ТекСтрокаСоставНабора.Цена;
            КонецЦикла;
            Для Каждого ТекСтрокаТовары Из Основание.Товары Цикл
                НоваяСтрока = Товары.Добавить();
                НоваяСтрока.ЕдиницаИзмерения = ТекСтрокаТовары.ЕдиницаИзмерения;
                НоваяСтрока.КлючСтроки = ТекСтрокаТовары.КлючСтроки;
                НоваяСтрока.Количество = ТекСтрокаТовары.Количество;
                НоваяСтрока.Коэффициент = ТекСтрокаТовары.Коэффициент;
                НоваяСтрока.Номенклатура = ТекСтрокаТовары.Номенклатура;
                НоваяСтрока.ПроцентАвтоматическихСкидок = ТекСтрокаТовары.ПроцентАвтоматическихСкидок;
                НоваяСтрока.ПроцентСкидкиНаценки = ТекСтрокаТовары.ПроцентСкидкиНаценки;
                НоваяСтрока.СерияНоменклатуры = ТекСтрокаТовары.СерияНоменклатуры;
                НоваяСтрока.Сумма = ТекСтрокаТовары.Сумма;
                НоваяСтрока.УсловиеАвтоматическойСкидки = ТекСтрокаТовары.УсловиеАвтоматическойСкидки;
                НоваяСтрока.ХарактеристикаНоменклатуры = ТекСтрокаТовары.ХарактеристикаНоменклатуры;
                НоваяСтрока.Цена = ТекСтрокаТовары.Цена;
            КонецЦикла;
        КонецЕсли;
    КонецПроцедуры
    Последнее редактирование модератором: 16 сен 2015
  10. NovInNik
    Offline

    NovInNik Опытный в 1С

    Регистрация:
    12 ноя 2007
    Сообщения:
    194
    Симпатии:
    1
    Баллы:
    29
    Основание чему равно?

Поделиться этой страницей