Курилка Можно ли из МодуляОбъекта обратиться к МодулюФормы этого же документа?

Тема в разделе "Курилка", создана пользователем web.num, 15 мар 2013.

  1. TopicStarter Overlay
    web.num
    Offline

    web.num Опытный в 1С Команда форума

    Регистрация:
    6 окт 2011
    Сообщения:
    914
    Симпатии:
    4
    Баллы:
    29
    Привет )
    Можно ли из МодуляОбъекта обратиться к МодулюФормы этого же документа?
  2. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    Можно... Какая форма(управляемая или обычная)??
  3. nickpugachev
    Offline

    nickpugachev Профессионал в 1С Команда форума

    Регистрация:
    28 май 2012
    Сообщения:
    3.266
    Симпатии:
    131
    Баллы:
    104
    только если форму передашь в процедуру в качестве параметра
  4. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    я как то раз пыталась - ничего не получилось (к процедурам обратиться в частности)
  5. TopicStarter Overlay
    web.num
    Offline

    web.num Опытный в 1С Команда форума

    Регистрация:
    6 окт 2011
    Сообщения:
    914
    Симпатии:
    4
    Баллы:
    29
    Обычная
  6. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
  7. nickpugachev
    Offline

    nickpugachev Профессионал в 1С Команда форума

    Регистрация:
    28 май 2012
    Сообщения:
    3.266
    Симпатии:
    131
    Баллы:
    104
    а процедуру формы экспортной сделать?
  8. TopicStarter Overlay
    web.num
    Offline

    web.num Опытный в 1С Команда форума

    Регистрация:
    6 окт 2011
    Сообщения:
    914
    Симпатии:
    4
    Баллы:
    29
    Не помогает!

    Ну вот там про УпрФормы, а обычные я так понимаю и понятия не имеют про МодульОбъекта!
  9. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    делала - все равно не вижу ее в модуле обЪекта
  10. nickpugachev
    Offline

    nickpugachev Профессионал в 1С Команда форума

    Регистрация:
    28 май 2012
    Сообщения:
    3.266
    Симпатии:
    131
    Баллы:
    104
    еще как помогает :)

    1. в модуле формы
    Код:
    Процедура Бамц() Экспорт
    
    Предупреждение("Бамц");
    
    КонецПроцедуры
    
    Процедура КнопкаВыполнитьНажатие(Кнопка)
    БамцВМодуле(ЭтаФорма);
    КонецПроцедуры
    
    в модуле объекта

    Код:
    Процедура БамцВМодуле(Форма) Экспорт
    
    Форма.Бамц();
    
    КонецПроцедуры
  11. TopicStarter Overlay
    web.num
    Offline

    web.num Опытный в 1С Команда форума

    Регистрация:
    6 окт 2011
    Сообщения:
    914
    Симпатии:
    4
    Баллы:
    29
    Хм....а если например взять внешние печатные формы, там вроде 1С сразу же обращается к модулю формы, значит не проканает такой вариант!
  12. nickpugachev
    Offline

    nickpugachev Профессионал в 1С Команда форума

    Регистрация:
    28 май 2012
    Сообщения:
    3.266
    Симпатии:
    131
    Баллы:
    104
    у внешних печатных форм 1с образается к модулю объекта обработки

    а что хочется от впф?

Поделиться этой страницей