[РЕШЕНО] Мобильный клиент

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Peroman, 8 ноя 2019.

  1. TopicStarter Overlay
    Peroman
    Offline

    Peroman Профессионал в 1С

    Регистрация:
    26 май 2009
    Сообщения:
    1.028
    Симпатии:
    28
    Баллы:
    54
    Всем доброго времени суток!
    Платформа: 1С:Предприятие 8.3 (8.3.15.1700)

    Код:
        #Если МобильноеПриложениеКлиент ТОГДА
          
            Если СредстваМультимедиа.ПоддерживаетсяФотоснимок() Тогда
                Разрешение = Новый РазрешениеКамерыУстройства;
                Разрешение.Высота = 3840;
                Разрешение.Ширина = 2160;
                Снимок = СредстваМультимедиа.СделатьФотоснимок(ТипКамерыУстройства.Задняя,Разрешение,100,Ложь);
                Если Снимок = Неопределено Тогда
                    ПоказатьПредупреждение(,"Снимок не был сделан");
                    Возврат
                КонецЕсли;
              
                ДвоичныеДанные = Снимок.ПолучитьДвоичныеДанные();
                ХранилищеМоейКартинки = Новый ХранилищеЗначения(ДвоичныеДанные);
              
                ФотоУпражнения = ПолучитьНавигационнуюСсылку(ХранилищеМоейКартинки);
              
                ОбновитьИнтерфейс();
            Иначе
                ПоказатьПредупреждение(,"Камера не поддерживается");
            КонецЕсли;
          
        #КонецЕсли  
    
    При проверке выдает ошибку:
    Хотя в СП в описании:
    Чего я делаю не так или упускаю из вида?
    --- Объединение сообщений, 8 ноя 2019 ---


    Разобрался
    Это само Хранилище доступно, а конструктор только толстый или сервер.
    Будем делать через - ПоместитьВоВременноеХранилище()
    Всем спасибо)
    Последнее редактирование: 8 ноя 2019
    Bkmz нравится это.