7.7 Множественный фильтр в отчете или условие - отбор документов с контрагентами из списка

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Will, 11 мар 2014.

  1. TopicStarter Overlay
    Will
    Offline

    Will Опытный в 1С

    Регистрация:
    15 авг 2012
    Сообщения:
    551
    Симпатии:
    1
    Баллы:
    29
    Здравствуйте. На 1С 7.7 ранее писать не доводилось, а изучать ее времени особо нет.
    Пишу запрос - Суммы розничных продаж по дням за период. То есть запрос должен выглядеть таким образом:

    Период 01.03.2014 - 31.03.2014

    01.03.2014 - 57000 р.
    02.03.2014 - 68400 р.
    03.03.2013 - 41500 р.
    ...
    31.03.2014 - 75000 р.

    Проблема в условии - выбрать все документы продаж, кроме тех, у которых следующие контрагенты:
    ООО "Покупатель 1", ООО "ДТЛ" и ЗАО "Кгртд"

    Со множественным фильтром разобраться не получилось. Сделала так: Добавила на форму Список, куда добавила нужных контрагентов.
    Безымянный.png
    Процедура выглядит так:
    Код:
    Процедура СформироватьРозница()
        Перем Запрос, ТекстЗапроса, Таб;
        //Создание объекта типа Запрос
        Запрос = СоздатьОбъект("Запрос");
        ТекстЗапроса =
        "//{{ЗАПРОС(СформироватьРозница)
        |Период с ВыбНачПериода по ВыбКонПериода;
        |ТекущийДокумент = Документ.РеализацияРозница.ТекущийДокумент;
        |ДатаДок = Документ.РеализацияРозница.ДатаДок;
        |Фирма = Документ.РеализацияРозница.Фирма;
        |Сумма = Документ.РеализацияРозница.Сумма;
        |Склад = Документ.РеализацияРозница.Склад;
        |Контрагент = Документ.РеализацияРозница.Контрагент;
        |Функция СуммаСумма = Сумма(Сумма);
        |Группировка День;
        |Условие(Контрагент в СписокЗнач1);
        |Условие(Склад в ВыбрСклад);
        |Условие(Фирма в ВыбрОрг);
        |"//}}ЗАПРОС
        ;
        // Если ошибка в запросе, то выход из процедуры
        Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
            Возврат;
        КонецЕсли;
    
        // Подготовка к заполнению выходных форм данными запроса
        Таб = СоздатьОбъект("Таблица");
        Таб.ИсходнаяТаблица("СформироватьРозница");
        // Заполнение полей "Заголовок"
        Таб.ВывестиСекцию("Заголовок");
        Состояние("Заполнение выходной таблицы...");
        Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
        Пока Запрос.Группировка(1) = 1 Цикл
            // Заполнение полей День
            Таб.ВывестиСекцию("День");
        КонецЦикла;
        // Заполнение полей "Итого"
        Таб.ВывестиСекцию("Итого");
        // Вывод заполненной формы
        Таб.ТолькоПросмотр(1);
        Таб.Показать("СформироватьРозница", "");
    КонецПроцедуры
    Потом в режиме отладки - когда Список значениями не заполнен, запрос формируется по все контрагентам. Если добавлю в список пару нужных контрагентов, то всё. Отчет ничего не выводит.
    Безымянный1.png
    Подскажите как правильно записать условие в запросе, чтобы в отчет попадали данные по отбору из списка.
  2. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    Что за конфа? В типовой посмотреть не можете, например ТИС... Там 2-мя словами не напишешь, что нужно сделать, чтоб взлетело
    Посмотрите прикрепленный файл из ТИСа, думаю поймете суть...

    Вложения:

    Will нравится это.
  3. TopicStarter Overlay
    Will
    Offline

    Will Опытный в 1С

    Регистрация:
    15 авг 2012
    Сообщения:
    551
    Симпатии:
    1
    Баллы:
    29
    В общем-то на примере этого отчета и смотрела. Конфа ТиС. Думала дописать этот отчет, но у меня не особо вышло...
  4. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    делайте через ТаблицаМФ... Обратите внимание на строку:
    Код:
    НетОш = НетОш * глФильтрПоПеременнойЗапроса()
    Will нравится это.
  5. TopicStarter Overlay
    Will
    Offline

    Will Опытный в 1С

    Регистрация:
    15 авг 2012
    Сообщения:
    551
    Симпатии:
    1
    Баллы:
    29
    Спасибо, вроде получилось.
  6. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    обращайтесь...
    Will нравится это.

Поделиться этой страницей