8.х Множественный диалог выбора файла

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем bluntschi, 28 авг 2015.

  1. TopicStarter Overlay
    bluntschi
    Offline

    bluntschi Опытный в 1С

    Регистрация:
    18 июл 2012
    Сообщения:
    422
    Симпатии:
    0
    Баллы:
    26
    Добрый день, подскажите, у меня есть процедура открытия файла Excel и создание документа на основе этого файла, и организован множественный выбор файла, но я не записываю создаваемые документы, а просто открывается форма создания документа, с данными из Excel, и когда я делаю множественный выбор, то получается, что открываются все по очереди, и они пропадают, и остается только последний, как можно сделать, без сохранения документа, но чтобы открывались все документы, выбранные в множественном выборе?
  2. TopicStarter Overlay
    bluntschi
    Offline

    bluntschi Опытный в 1С

    Регистрация:
    18 июл 2012
    Сообщения:
    422
    Симпатии:
    0
    Баллы:
    26
    вот так почему то не получается, пишет ошибку когда начинает обращаться к процедуре чтения файла xml:

    Код:
    
    Процедура ВыборФайла () Экспорт
    
    Режим = РежимДиалогаВыбораФайла.Открытие;
    ДиалогОткрытияФайла = Новый ДиалогВыбораФайла(Режим);
    Фильтр = "xml|*.xml";
    ДиалогОткрытияФайла.Фильтр = Фильтр;
    ДиалогОткрытияФайла.МножественныйВыбор = Истина;
    
    
    Если ДиалогОткрытияФайла.Выбрать() Тогда
    
    МассивФайлов = ДиалогОткрытияФайла.ВыбранныеФайлы;
        Для Каждого ИмяФайла Из МассивФайлов Цикл
            ВыбФайл = Новый Файл(ИмяФайла);
            ПрочитатьXMLФайлНаСервере(ВыбФайл);
    
        КонецЦикла;
    КонецЕсли;
    
    ОбновитьИнтерфейс();
    КонецПроцедуры
    
    Процедура ПрочитатьXMLФайлНаСервере(ВыбФайл)
    
        ЧтениеXML = Новый ЧтениеXML;
        ПутьКФайлу = ВыбФайл[0];
        ЧтениеXML.ОткрытьФайл(ПутьКФайлу);
    ...
    
    КонецПроцедуры
    
    
  3. TerANik
    Offline

    TerANik Профессионал в 1С

    Регистрация:
    19 ноя 2014
    Сообщения:
    997
    Симпатии:
    70
    Баллы:
    54
    Попробовать присваивать имени файлов индекс в цикле.

Поделиться этой страницей