7.7 Многострочная часть формы списка

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Danik95, 11 май 2010.

  1. TopicStarter Overlay
    Danik95
    Offline

    Danik95 Опытный в 1С

    Регистрация:
    22 мар 2009
    Сообщения:
    127
    Симпатии:
    0
    Баллы:
    26
    Доброго времени суток! Подскажите пожалуйста как перебрать многострочную часть формы списка справочника в 1С 7?
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Код:
    Спр=СоздатьОбъект("Справочник.МойСправочник");
    Спр.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент()=1 Цикл
    //ваши действия
    КонецЦикла;
    
    
  3. dedalx7
    Offline

    dedalx7 Опытный в 1С

    Регистрация:
    20 май 2009
    Сообщения:
    97
    Симпатии:
    0
    Баллы:
    26
    Довольно туманный вопрос, если честно. В 7 нет стандартной многострочной части в метаданных типа "справочник" (по крайней мере, я никогда не видел). Так что вы столкнулись с одним из двух проявлений: либо это Список Значений, либо Таблица Значений.

    Для списка это выглядит примерно так:
    Код:
    Для Индекс = 1 По СписокЗнач.РазмерСписка() Цикл
    Значение = СписокЗнач.ПолучитьЗначение(Индекс);
    //ваши действия
    КонецЦикла;
    
    Для таблицы:
    Код:
    ТабЗнач.ВыбратьСтроки();
    Пока ТабЗнач.ПолучитьСтроку() = 1 Цикл
    Значение1 = ТабЗнач.ИмяКолонки1;
    Значение2 = ТабЗнач.ИмяКолонки2;
    ...
    ЗначениеN = ТабЗнач.ИмяКолонкиN;
    //ваши действия
    КонецЦикла;
    
    Но если вы собираетесь делать это из другой формы (посредством СоздатьОбъект("Справочник") ), стоит помнить что скорее всего данные в "многострочных частях формы" справочника генерируются на лету из других реквизитов исключительно для визуализации данных. Так что вам, может, придется попристальнее разобраться в реквизитах рекомого справочника.
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Речь вообще то шла о справочнике, а не о СпискеЗначений и ТаблицыЗначений...
  5. dedalx7
    Offline

    dedalx7 Опытный в 1С

    Регистрация:
    20 май 2009
    Сообщения:
    97
    Симпатии:
    0
    Баллы:
    26
    О Господи! Только прочитав ПЯТЫЙ раз вопрос, я понял о чем он. :unsure:
    Приношу свои категорические извинения.

    В качестве попытки реабилитироваться:
    К элементу на котором в данный момент установлен курсор можно обращаться просто ТекущийЭлемент() без префиксов.

    Если вы хотите чтобы перебирались не все, а только "нужные" элементы , то смею предположить что эти самые "нужные" элементы собраны в конкретную группу. Легче будет если пользователь будет выбирать курсором саму группу, а вы будете перебирать элементы способом указанным Угодником, проверяя их на
    Код:
    Если Спр.Родитель <> ТекущийЭлемент()
    Продолжить;
    КонецЕсли;
    
    P.S> Надеюсь попытка удалась ;)
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Кажется яснее некуда
  7. TopicStarter Overlay
    Danik95
    Offline

    Danik95 Опытный в 1С

    Регистрация:
    22 мар 2009
    Сообщения:
    127
    Симпатии:
    0
    Баллы:
    26
    Я тоже первым попробовал через СоздатьОбъект, но хотя там и есть элементы но Спр.ВыбратьЭлементы() у меня равно нулю, может ли быть это связано из за того что я вызываю этот метод из самой формы списка элементы которой нужно перебрать?
    Прикрепил на всякий случай изображение справочника.

    Вложения:

    • 326935554.png
      326935554.png
      Размер файла:
      22,5 КБ
      Просмотров:
      89
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Судя по скрину у вас ПОДЧИНЕННЫЙ справочник. Справочник ДокПриходы подчинени справочнику Товары
    Посмотрите метод
    Код:
    ...
    Спр.ИспользоватьРодителя(Родитель);
    ...
    
    
    
  9. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    мои пять копеек))
    Код:
    ИспользоватьВладельца()
    

Поделиться этой страницей