8.х Метод объекта не обнаружен (Печать)

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем vall-n-rol, 28 июл 2011.

  1. TopicStarter Overlay
    vall-n-rol
    Offline

    vall-n-rol Опытный в 1С

    Регистрация:
    18 ноя 2009
    Сообщения:
    291
    Симпатии:
    0
    Баллы:
    26
    В первые создаю внешнюю печатную форму:
    вот код:
    Код:
    Функция Печать() Экспорт
    Запрос = Новый Запрос;
    ЗапросКТоварам = Новый Запрос;
    Запрос.УстановитьПараметр("ТекущийДокумент",    СсылкаНаОбъект);
    Запрос.УстановитьПараметр("ДатаСреза",          СсылкаНаОбъект.Дата);
    Запрос.УстановитьПараметр("СтруктурнаяЕдиница", СсылкаНаОбъект.Склад);
    
    ЗапросКТоварам.УстановитьПараметр("ТекущийДокумент", СсылкаНаОбъект);	
    
    Запрос.Текст =
    "ВЫБРАТЬ РАЗРЕШЕННЫЕ
    |	Номер Как НомерДокумента,
    |	Дата  Как ДатаДокумента,
    |	Организация,
    |   СтруктурноеПодразделение,
    |	Склад.Представление                 КАК Склад,
    |	СуммаДокумента,
    |	Основание,
    |	ВЫБОР
    |		КОГДА ФИОФизЛицСрезПоследних.ФизЛицо ЕСТЬ NULL 
    |			ТОГДА ОтветственныеЛица.ФизическоеЛицо.Наименование
    |		ИНАЧЕ ФИОФизЛицСрезПоследних.Фамилия + ВЫБОР
    |				КОГДА ПОДСТРОКА(ФИОФизЛицСрезПоследних.Имя, 1, 1) <> """"
    |					ТОГДА "" "" + ПОДСТРОКА(ФИОФизЛицСрезПоследних.Имя, 1, 1) + "".""
    |				ИНАЧЕ """"
    |			КОНЕЦ + ВЫБОР
    |				КОГДА ПОДСТРОКА(ФИОФизЛицСрезПоследних.Отчество, 1, 1) <> """"
    |					ТОГДА "" "" + ПОДСТРОКА(ФИОФизЛицСрезПоследних.Отчество, 1, 1) + "".""
    |				ИНАЧЕ """"
    |			КОНЕЦ
    |	КОНЕЦ КАК ПредставлениеОтветственный,
    |	ОтветственныеЛица.ФизическоеЛицо   КАК Ответственный,
    |	ИнвентаризационнаяКомиссия.(
    |		ФизЛицо КАК ФизЛицо,
    |		Председатель КАК Председатель
    |	) КАК ИнвентаризационнаяКомиссия  	
    |ИЗ
    |	Документ.СписаниеТоваров КАК СписаниеТоваров
    |		ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ОтветственныеЛица.СрезПоследних(&ДатаСреза, СтруктурнаяЕдиница = &СтруктурнаяЕдиница) КАК ОтветственныеЛица
    |		ПО ОтветственныеЛица.СтруктурнаяЕдиница = СписаниеТоваров.Склад
    |		ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ФИОФизЛиц.СрезПоследних(&ДатаСреза, ) КАК ФИОФизЛицСрезПоследних
    |		ПО ОтветственныеЛица.ФизическоеЛицо = ФИОФизЛицСрезПоследних.ФизЛицо
    |
    |ГДЕ
    |	СписаниеТоваров.Ссылка = &ТекущийДокумент";
    
    ЗапросКТоварам.Текст = "ВЫБРАТЬ
    |	СписаниеТоваровТовары.Номенклатура КАК Номенклатура,
    |	СписаниеТоваровТовары.СчетУчетаБУ КАК СчетУчетаБУ,
    |	СУММА(СписаниеТоваровТовары.Количество) КАК Количество,
    |	СписаниеТоваровТовары.ЕдиницаИзмерения КАК ЕдиницаИзмерения,
    |	МИНИМУМ(СписаниеТоваровТовары.НомерСтроки) КАК НомерСтроки,
    |	СписаниеТоваровТовары.Ссылка КАК Ссылка,
    |	СписаниеТоваровТовары.СубконтоЗатратБУ1 КАК СубконтоЗатратБУ1,
    |	СписаниеТоваровТовары.СубконтоЗатратБУ2 КАК СубконтоЗатратБУ2,
    |	СписаниеТоваровТовары.СубконтоЗатратБУ3 КАК СубконтоЗатратБУ3,
    |	СписаниеТоваровТовары.СчетЗатратБУ КАК СчетЗатратБУ,
    |	СписаниеТоваровТовары.Коэффициент КАК Коэффициент
    |ПОМЕСТИТЬ ВТ_СписаниеТоваров
    |ИЗ
    |	Документ.СписаниеТоваров.Товары КАК СписаниеТоваровТовары
    |ГДЕ
    |	СписаниеТоваровТовары.Ссылка = &ТекущийДокумент
    |
    |СГРУППИРОВАТЬ ПО
    |	СписаниеТоваровТовары.Номенклатура,
    |	СписаниеТоваровТовары.СчетУчетаБУ,
    |	СписаниеТоваровТовары.ЕдиницаИзмерения,
    |	СписаниеТоваровТовары.Ссылка,
    |	СписаниеТоваровТовары.СубконтоЗатратБУ1,
    |	СписаниеТоваровТовары.СубконтоЗатратБУ2,
    |	СписаниеТоваровТовары.СубконтоЗатратБУ3,
    |	СписаниеТоваровТовары.СчетЗатратБУ,
    |	СписаниеТоваровТовары.Коэффициент
    |;
    |
    |////////////////////////////////////////////////////////////////////////////////
    |ВЫБРАТЬ РАЗРЕШЕННЫЕ
    |	СписаниеТоваров.Номенклатура,
    |	СписаниеТоваров.Количество,
    |	СписаниеТоваров.НомерСтроки КАК НомерСтроки,
    |	СписаниеТоваров.СчетУчетаБУ КАК Счет,
    |	ЕСТЬNULL(ДвиженияТиповой.Сумма / ДвиженияТиповой.КоличествоКт * СписаниеТоваров.Коэффициент * СписаниеТоваров.Количество, 0) КАК Сумма,
    |	ЕСТЬNULL(ДвиженияТиповой.Сумма / ДвиженияТиповой.КоличествоКт * СписаниеТоваров.Коэффициент, 0) КАК Себестоимость,
    |	СписаниеТоваров.СубконтоЗатратБУ1.Наименование КАК СубконтоЗатратБУ1,
    |	СписаниеТоваров.СубконтоЗатратБУ2.Наименование КАК СубконтоЗатратБУ2,
    |	СписаниеТоваров.СубконтоЗатратБУ3.Наименование КАК СубконтоЗатратБУ3,
    |	СписаниеТоваров.СчетЗатратБУ КАК СчетСписания,
    |	СписаниеТоваров.ЕдиницаИзмерения.Представление КАК ЕдиницаИзмерения,
    |	ВЫРАЗИТЬ(СписаниеТоваров.Номенклатура.НаименованиеПолное КАК СТРОКА(1000)) КАК Наименование,
    |	СписаниеТоваров.Номенклатура.Код КАК НоменклатурныйНомер
    |ИЗ
    |	ВТ_СписаниеТоваров КАК СписаниеТоваров
    |		ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
    |			ТиповойДвиженияССубконто.СчетКт КАК СчетКт,
    |			ТиповойДвиженияССубконто.СубконтоКт1 КАК СубконтоКт1,
    |			СУММА(ТиповойДвиженияССубконто.Сумма) КАК Сумма,
    |			СУММА(ТиповойДвиженияССубконто.КоличествоКт) КАК КоличествоКт,
    |			ТиповойДвиженияССубконто.СчетДт КАК СчетДт,
    |			ТиповойДвиженияССубконто.СубконтоДт1 КАК СубконтоДт1,
    |			ТиповойДвиженияССубконто.СубконтоДт2 КАК СубконтоДт2,
    |			ТиповойДвиженияССубконто.СубконтоДт3 КАК СубконтоДт3
    |		ИЗ
    |			РегистрБухгалтерии.Типовой.ДвиженияССубконто(, , Регистратор = &ТекущийДокумент) КАК ТиповойДвиженияССубконто
    |		
    |		СГРУППИРОВАТЬ ПО
    |			ТиповойДвиженияССубконто.СчетКт,
    |			ТиповойДвиженияССубконто.СубконтоКт1,
    |			ТиповойДвиженияССубконто.СчетДт,
    |			ТиповойДвиженияССубконто.СубконтоДт1,
    |			ТиповойДвиженияССубконто.СубконтоДт2,
    |			ТиповойДвиженияССубконто.СубконтоДт3) КАК ДвиженияТиповой
    |		ПО СписаниеТоваров.Номенклатура = ДвиженияТиповой.СубконтоКт1
    |			И СписаниеТоваров.СчетУчетаБУ = ДвиженияТиповой.СчетКт
    |			И СписаниеТоваров.СчетЗатратБУ = ДвиженияТиповой.СчетДт
    |			И (СписаниеТоваров.СубконтоЗатратБУ1 = ДвиженияТиповой.СубконтоДт1
    |				ИЛИ ДвиженияТиповой.СубконтоДт1 ЕСТЬ NULL 
    |					И СписаниеТоваров.СубконтоЗатратБУ1 = НЕОПРЕДЕЛЕНО)
    |			И (СписаниеТоваров.СубконтоЗатратБУ2 = ДвиженияТиповой.СубконтоДт2
    |				ИЛИ ДвиженияТиповой.СубконтоДт2 ЕСТЬ NULL 
    |					И СписаниеТоваров.СубконтоЗатратБУ2 = НЕОПРЕДЕЛЕНО)
    |			И (СписаниеТоваров.СубконтоЗатратБУ3 = ДвиженияТиповой.СубконтоДт3
    |				ИЛИ ДвиженияТиповой.СубконтоДт3 ЕСТЬ NULL 
    |					И СписаниеТоваров.СубконтоЗатратБУ3 = НЕОПРЕДЕЛЕНО)
    |
    |УПОРЯДОЧИТЬ ПО
    |	НомерСтроки";
    
    Шапка = Запрос.Выполнить().Выбрать();
    Шапка.Следующий();
    ВыборкаСтрокТовары = ЗапросКТоварам.Выполнить().Выбрать();
    ТаблицаИнвентаризационнаяКомиссия = Шапка.ИнвентаризационнаяКомиссия.Выгрузить();
    
    СтруктурнаяЕдиницаОрганизация = ОбщегоНазначения.ПолучитьСтруктурнуюЕдиницу(Шапка.Организация, Шапка.СтруктурноеПодразделение);
    
    ТабДокумент = Новый ТабличныйДокумент;
    ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_СписаниеТоваров_АктСписания";
    
    Если СсылкаНаОбъект.ВыводитьОснование=0 Тогда
    Макет = ПолучитьМакет("АктСписания");
    КонецЕсли;	
    // Выводим шапку накладной
    
    ОбластьМакета = Макет.ПолучитьОбласть("Шапка"); 	
    ОбластьМакета.Параметры.Заполнить(Шапка);
    ПредставлениеОрганизации = ОбщегоНазначения.ОписаниеОрганизации(ОбщегоНазначения.СведенияОЮрФизЛице(СтруктурнаяЕдиницаОрганизация, Шапка.ДатаДокумента), "ПолноеНаименование,");
    ОбластьМакета.Параметры.ОрганизацияНаименование = ПредставлениеОрганизации;
    ОбластьМакета.Параметры.НомерДокумента = ОбщегоНазначения.ПолучитьНомерНаПечать(ЭтотОбъект, глСписокПрефиксовУзлов);
    ТабДокумент.Вывести(ОбластьМакета);
    
    ОбластьМакета = Макет.ПолучитьОбласть("Заголовок"); 	
    ТабДокумент.Вывести(ОбластьМакета);
    
    ОбластьСтрока = Макет.ПолучитьОбласть("Строка");
    СуммаИтог = 0;
    СуммаИтогНДС = 0;
    Пока ВыборкаСтрокТовары.Следующий() Цикл
    ОбластьСтрока.Параметры.Заполнить(ВыборкаСтрокТовары);
    
    ОбластьСтрока.Параметры.Наименование = СокрЛП(ВыборкаСтрокТовары.Наименование);
    
    ОбластьСтрока.Параметры.Себестоимость = Формат(ВыборкаСтрокТовары.Себестоимость, "ЧДЦ=2");
    ОбластьСтрока.Параметры.Количество = Формат(ВыборкаСтрокТовары.Количество, "ЧДЦ=3");
    ОбластьСтрока.Параметры.Сумма = Формат(ВыборкаСтрокТовары.Сумма, "ЧДЦ=2");
    
    ПараметрСубконто = ?(ВыборкаСтрокТовары.СубконтоЗатратБУ1 = Null, "",ВыборкаСтрокТовары.СубконтоЗатратБУ1) + Символы.ПС + 
    ?(ВыборкаСтрокТовары.СубконтоЗатратБУ2 = Null, "",ВыборкаСтрокТовары.СубконтоЗатратБУ2) + Символы.ПС + 
    ?(ВыборкаСтрокТовары.СубконтоЗатратБУ3 = Null, "",ВыборкаСтрокТовары.СубконтоЗатратБУ3);
    
    ОбластьСТрока.Параметры.Субконто = СокрЛП(ПараметрСубконто);
    ТабДокумент.Вывести(ОбластьСтрока);
    
    СуммаИтог = СуммаИтог + ВыборкаСтрокТовары.Сумма; 	
    
    КонецЦикла; 		
    ОбластьИтогов = Макет.ПолучитьОбласть("Итоги");
    ОбластьИтогов.Параметры.СуммаИтог = Формат(СуммаИтог, "ЧДЦ=2");	
    
    ТабДокумент.Вывести(ОбластьИтогов);
    // Корректировка НДС
    Если СсылкаНаОбъект.УчитыватьНДС и СсылкаНаОбъект.КорректироватьНДС Тогда
    Запрос = Новый Запрос("ВЫБРАТЬ
    |	СписаниеТоваров.Номенклатура КАК Номенклатура,
    |	-КорректировкаНДС.СуммаКорректировкиОборота КАК Себестоимость,
    |	-КорректировкаНДС.СуммаНДС КАК СуммаНДС,
    |	СписаниеТоваров.Номенклатура.Код КАК НоменклатурныйНомер,
    | ВЫРАЗИТЬ(СписаниеТоваров.Номенклатура.НаименованиеПолное КАК СТРОКА(1000)) КАК Наименование
    |ИЗ
    |	(ВЫБРАТЬ РАЗЛИЧНЫЕ
    |		СписаниеТоваровТовары.Номенклатура КАК Номенклатура
    |	ИЗ
    |		Документ.СписаниеТоваров.Товары КАК СписаниеТоваровТовары
    |	ГДЕ
    |		СписаниеТоваровТовары.Ссылка = &ТекущийДокумент) КАК СписаниеТоваров
    |		ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
    |			КорректировкаНДСКВозмещению.ТМЗ КАК ТМЗ,
    |			СУММА(КорректировкаНДСКВозмещению.СуммаКорректировкиОборота) КАК СуммаКорректировкиОборота,
    |			СУММА(КорректировкаНДСКВозмещению.СуммаНДС) КАК СуммаНДС
    |		ИЗ
    |			РегистрНакопления.КорректировкаНДСКВозмещению КАК КорректировкаНДСКВозмещению
    |		ГДЕ
    |			КорректировкаНДСКВозмещению.Регистратор = &ТекущийДокумент
    |		
    |		СГРУППИРОВАТЬ ПО
    |			КорректировкаНДСКВозмещению.ТМЗ) КАК КорректировкаНДС
    |		ПО СписаниеТоваров.Номенклатура = КорректировкаНДС.ТМЗ
    |ИТОГИ
    |	СУММА(Себестоимость),
    |	СУММА(СуммаНДС)
    |ПО
    |	ОБЩИЕ");
    Запрос.УстановитьПараметр("ТекущийДокумент", СсылкаНаОбъект);
    Результат = Запрос.Выполнить();
    Если не Результат.Пустой() Тогда
    ВыборкаИтоги = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
    ВыборкаИтоги.Следующий();
    
    ОбластьМакета = Макет.ПолучитьОбласть("ЗаголовокНДС"); 	
    ТабДокумент.Вывести(ОбластьМакета);
    
    ОбластьМакета = Макет.ПолучитьОбласть("СтрокаНДС"); 						
    
    ВыборкаДетали = ВыборкаИтоги.Выбрать();			
    Пока ВыборкаДетали.Следующий() Цикл
    ОбластьМакета.Параметры.Заполнить(ВыборкаДетали);
    ОбластьМакета.Параметры.Наименование = СокрЛП(ВыборкаДетали.Наименование);
    ТабДокумент.Вывести(ОбластьМакета);	
    КонецЦикла;                                        			
    ОбластьМакета = Макет.ПолучитьОбласть("ИтогиНДС"); 						
    ОбластьМакета.Параметры.Заполнить(ВыборкаИтоги);
    ТабДокумент.Вывести(ОбластьМакета);	          		
    КонецЕсли;                                        			
    КонецЕсли;	
    
    //Печать данных о комисси
    ОбластьМакета = Макет.ПолучитьОбласть("Комиссия");
    
    // Варианты заголовков разделов с подписями печатной формы	
    ЗаголовокРазделаКомиссии = Новый Структура();
    ЗаголовокРазделаКомиссии.Вставить("ПредседательКомиссии", "Председатель комиссии");
    ЗаголовокРазделаКомиссии.Вставить("ЧленыКомиссии",        "Члены комиссии:");
    
    // Выведем подпись председателя инвентаризационной комиссии
    ПредседательКомиссии = ТаблицаИнвентаризационнаяКомиссия.Найти(Истина, "Председатель");
    
    Если НЕ (ПредседательКомиссии = Неопределено) Тогда
    
    ДанныеПредседателя = ПроцедурыУправленияПерсоналом.ДанныеФизЛица(Шапка.Организация, ПредседательКомиссии.ФизЛицо, Шапка.ДатаДокумента);
    
    ОбластьМакета.Параметры.ЗаголовокРазделаКомиссии = ЗаголовокРазделаКомиссии.ПредседательКомиссии;
    ОбластьМакета.Параметры.Должность                = ДанныеПредседателя.Должность;
    ОбластьМакета.Параметры.РасшифровкаПодписи       = ДанныеПредседателя.Представление;
    
    Иначе
    
    ОбластьМакета.Параметры.ЗаголовокРазделаКомиссии = ЗаголовокРазделаКомиссии.ПредседательКомиссии;
    ОбластьМакета.Параметры.Должность                = "";
    ОбластьМакета.Параметры.РасшифровкаПодписи       = "";
    
    КонецЕсли;
    
    ТабДокумент.Вывести(ОбластьМакета);
    
    // Выведем подписи членов комиссии
    ВыводитьЗаголовок = Истина;
    
    // Сформируем список членов комиссии
    СписокЧленовКомиссии = Новый Массив();
    
    Для Каждого Строка Из ТаблицаИнвентаризационнаяКомиссия Цикл
    Если НЕ Строка.Председатель Тогда
    СписокЧленовКомиссии.Добавить(Строка.ФизЛицо);
    КонецЕсли;
    КонецЦикла;
    
    ДанныеЧленовКомиссии = ПроцедурыУправленияПерсоналом.ДанныеФизЛиц(Шапка.Организация, СписокЧленовКомиссии, Шапка.ДатаДокумента);
    
    // Сначала выведем членов комиссии из выборки
    Для Каждого ЧленКомиссии Из ДанныеЧленовКомиссии Цикл
    
    Если НЕ УниверсальныеМеханизмы.ПроверитьВыводДляТабличногоДокумента(ТабДокумент, ОбластьМакета) Тогда
    
    // Выведем разрыв страницы
    ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();
    ВыводитьЗаголовок = Истина; // на новой странице выведем заголовок набора подписей
    
    КонецЕсли;
    
    ОбластьМакета.Параметры.ЗаголовокРазделаКомиссии = ?(ВыводитьЗаголовок, 
    ЗаголовокРазделаКомиссии.ЧленыКомиссии,
    "");
    ОбластьМакета.Параметры.Должность          = ЧленКомиссии.Должность;
    ОбластьМакета.Параметры.РасшифровкаПодписи = ЧленКомиссии.Представление;
    
    ТабДокумент.Вывести(ОбластьМакета);
    
    ВыводитьЗаголовок = Ложь; // в следующей итерации вывод заголовка не нужен
    
    КонецЦикла;
    
    // Затем выведем пустые места для подписей (чтобы в итоге получилось не менее 3-х
    Если ДанныеЧленовКомиссии.Количество() < 3 Тогда
    
    Если НЕ УниверсальныеМеханизмы.ПроверитьВыводДляТабличногоДокумента(ТабДокумент, ОбластьМакета) Тогда
    
    // Выведем разрыв страницы
    ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();
    ВыводитьЗаголовок = Истина; // на новой странице выведем заголовок набора подписей
    
    КонецЕсли;
    
    Для Итератор = (ДанныеЧленовКомиссии.Количество() + 1) По 3 Цикл
    
    ОбластьМакета.Параметры.ЗаголовокРазделаКомиссии = ?(ВыводитьЗаголовок, 
    ЗаголовокРазделаКомиссии.ЧленыКомиссии,
    "");
    ОбластьМакета.Параметры.Должность          = "";
    ОбластьМакета.Параметры.РасшифровкаПодписи = "";
    
    ТабДокумент.Вывести(ОбластьМакета);
    
    ВыводитьЗаголовок = Ложь; // в следующей итерации вывод заголовка не нужен
    
    КонецЦикла; 
    
    КонецЕсли;  	
    
    ////установим альбомный формат
    //ТабДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
    
    Возврат ТабДокумент;
    
    
    //УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, КоличествоЭкземпляров, НаПринтер, РаботаСДиалогами.СформироватьЗаголовокДокумента(СсылкаНаОбъект, СсылкаНаОбъект.Метаданные().Представление()));
    
    КонецФункции // Печать
    
    в итоге :
    Не удалось сформировать внешнюю печатную форму!
    Метод объекта не обнаружен (Печать)
  2. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.568
    Симпатии:
    717
    Баллы:
    204
    функция Печать() где располагается во внешней обработке?
  3. TopicStarter Overlay
    vall-n-rol
    Offline

    vall-n-rol Опытный в 1С

    Регистрация:
    18 ноя 2009
    Сообщения:
    291
    Симпатии:
    0
    Баллы:
    26
    да в модуле внешней обр
  4. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.568
    Симпатии:
    717
    Баллы:
    204
    может в названии функции Печть буквы "а"/"е" - латинские?
    бывает такое....
  5. TopicStarter Overlay
    vall-n-rol
    Offline

    vall-n-rol Опытный в 1С

    Регистрация:
    18 ноя 2009
    Сообщения:
    291
    Симпатии:
    0
    Баллы:
    26
    нет я проверил русский шрифт
  6. vartanet
    Offline

    vartanet Опытный в 1С Команда форума

    Регистрация:
    16 ноя 2010
    Сообщения:
    2.698
    Симпатии:
    15
    Баллы:
    29
    функцию Печать() как вызываете? откуда?
  7. TopicStarter Overlay
    vall-n-rol
    Offline

    vall-n-rol Опытный в 1С

    Регистрация:
    18 ноя 2009
    Сообщения:
    291
    Симпатии:
    0
    Баллы:
    26
    из документа
  8. vartanet
    Offline

    vartanet Опытный в 1С Команда форума

    Регистрация:
    16 ноя 2010
    Сообщения:
    2.698
    Симпатии:
    15
    Баллы:
    29
    как? ВнешняяОбработка.Печать()?
  9. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.568
    Симпатии:
    717
    Баллы:
    204

    Вложения:

    • ВПФ_.epf
      Размер файла:
      4,2 КБ
      Просмотров:
      470
  10. TopicStarter Overlay
    vall-n-rol
    Offline

    vall-n-rol Опытный в 1С

    Регистрация:
    18 ноя 2009
    Сообщения:
    291
    Симпатии:
    0
    Баллы:
    26
    после того как добавил обработку, во внешнюю печатную форму, потом она поевилась в списке по кнопке печать из самого документа
  11. TopicStarter Overlay
    vall-n-rol
    Offline

    vall-n-rol Опытный в 1С

    Регистрация:
    18 ноя 2009
    Сообщения:
    291
    Симпатии:
    0
    Баллы:
    26
    непробывал

    как быть я в тупике, помогите
  12. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.568
    Симпатии:
    717
    Баллы:
    204
    тестовая ВПФ работает(моя)?
  13. TopicStarter Overlay
    vall-n-rol
    Offline

    vall-n-rol Опытный в 1С

    Регистрация:
    18 ноя 2009
    Сообщения:
    291
    Симпатии:
    0
    Баллы:
    26
    а она для какого документа
  14. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.568
    Симпатии:
    717
    Баллы:
    204
    для любого :)
  15. TopicStarter Overlay
    vall-n-rol
    Offline

    vall-n-rol Опытный в 1С

    Регистрация:
    18 ноя 2009
    Сообщения:
    291
    Симпатии:
    0
    Баллы:
    26
    такуюже ошибку выдает

    нет другую вот:
    Не удалось сформировать внешнюю печатную форму!
    Поле объекта не обнаружено (СсылкаНаОбъект)
  16. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.568
    Симпатии:
    717
    Баллы:
    204
    так, а реквизит "СсылкаНаОбъект" с типом Документ.Ссылка в вашей ВПФ имеется?

    в моей - его данного реквизита нет

    поправил
    Посмотреть вложение 8084

    пробуем ещё раз

    Вложения:

    • ВПФ_.epf
      Размер файла:
      4,2 КБ
      Просмотров:
      303
  17. TopicStarter Overlay
    vall-n-rol
    Offline

    vall-n-rol Опытный в 1С

    Регистрация:
    18 ноя 2009
    Сообщения:
    291
    Симпатии:
    0
    Баллы:
    26
    в твоей нет а в моей есть сылка на мой документ
  18. TopicStarter Overlay
    vall-n-rol
    Offline

    vall-n-rol Опытный в 1С

    Регистрация:
    18 ноя 2009
    Сообщения:
    291
    Симпатии:
    0
    Баллы:
    26
    помогите плиз
  19. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.568
    Симпатии:
    717
    Баллы:
    204
    моя исправленная ВПФ работает или нет?
  20. TopicStarter Overlay
    vall-n-rol
    Offline

    vall-n-rol Опытный в 1С

    Регистрация:
    18 ноя 2009
    Сообщения:
    291
    Симпатии:
    0
    Баллы:
    26
    я добавил туда ссылку, нет неработает

Поделиться этой страницей